Kaspersky World

Kaspersky World - утилита для разработчиков Kaspersky Lab.

Системные требования

  • Операционная система:
    • Windows 2000,
    • Windows ME,
    • Windows XP,
    • Windows Server 2003,
    • Windows Vista,
    • Windows 7,
    • Windows Server 2008;
  • Поддерживаемые продукты Kaspersky Lab:
    • Kaspersky Antivirus 6,
    • Kaspersky Antivirus 7,
    • Kaspersky Antivirus 2009,
    • Kaspersky Antivirus 2010,
    • Kaspersky Antivirus 2011,
    • Kaspersky Antivirus 2012,
    • Kaspersky Internet Security 6,
    • Kaspersky Internet Security 7,
    • Kaspersky Internet Security 2009,
    • Kaspersky Internet Security 2010,
    • Kaspersky Internet Security 2011,
    • Kaspersky Internet Security 2012,
    • Kaspersky Pure (Crystal),
    • Kaspersky Endpoint Security,
    • Kaspersky Small Office Security,
    • Kaspersky Antivirus for Windows Workstations.

Что я могу?

  1. Загружать ключи для продуктов Kaspersky Lab;
  2. Активировать Kaspersky используя файл ключа;
  3. Редактировать реестровые данные Kaspersky;
  4. Реактивировать Kaspersky;
  5. Удалять/восстанавливать уведомления о триальной версии.

ЧаВо:

  • В: Где я могу скачать ключ для Kaspersky Pure (Kaspersky Crystal)?
  • О: Ищите "Kaspersky Total Security" и "Kaspersky Pure" ключи в полных .kkll-файлах.
  • В: Ваши ключи с китайских сайтов?
  • О: Ни в коем случае.
  • В: Я хочу перевести программу ня свой язык. Что я должен сделать?
  • О: Читайте "Для разработчиков и переводчиков:"
  • В: Страница загрузки ключей неактивна Что делать?
  • О: Это значит что программа не может соединиться с интернетом и/или ей не дает это сделать Касперский, соответственно никакой ключ скачать не получится. Чтобы узнать есть соединение с интернетом или нет посмотрите есть ли надпись на рамке программы "Offline mode".

Для разработчиков и переводчиков

Для перевода программы:
  1. Скачайте English.lng
  2. Откройте в текстовом редакторе и переведите все значения после знака "=".
  3. Вы можете протестировать ваш языковой файл. Выберите в главном меню - "Настройки" -"Загрузить внешний язык" - и выберите свой языковой файл.
  4. Сохраните файл и отправьте команде разработчиков.
  5. Ждите ответа (1-2 дня).

Доступные языки:

  • English
  • Arabic
  • Bulgarian
  • Dutch
  • French
  • German
  • Italian
  • Korean
  • Polish
  • Portuguese
  • Russian
  • Serbian
  • Spanish
  • Turkish
  • Ukrainian

История версий

[+] Show

  • From 1.0.0.67 to 1.1.0.80:
    • Added "Ganjin-method" in "Trial life-module";
    • Added "Load external language" item in Main menu to help translators;
    • Added "Remove\Restore trial notifications" in "Trial life-module";
    • Added "Key activation-module";
    • Added "Tweaks-module";
    • Changed main design;
    • Changed associated icons;
    • Enabled "maximize" button;
  • 1.1.0.81:
    • Changed language-file;
    • Corrected main design;
  • 1.1.0.82:
    • Updated Italian.lng;
  • 1.1.1.47:
    • Added "Welcome page";
  • 1.1.1.49:
    • Added Spanish.lng;
  • 1.1.1.55:
    • Added Arabic.lng;
    • Fixed error "patchAIinstalled"
    • Restored "Feedback-module"
    • Updated languages;
  • 1.1.2.91:
    • Added "Trial Reset for KIS12";
    • Fixed resizing "Key Loader"
    • Changed main design;
    • Changed Kaspersky's status;
    • Corrected main combobox;
  • 1.2.0.124:
    • Added "blacklist-comparing function";
    • Allowed program-resizing;
    • Modified kkll-processor
  • 1.2.1.41:
    • Fixed error in "ADVAPI32.dll" on Windows 2000;
    • Modified "KeyLoader"-window (resizing function);
    • Modified downloader-function;
    • Modified "Trial Reset"-module;
  • 1.2.1.44:
    • Fixed repaint function of top image;
    • Fixed error on .kkll drop;
  • 1.2.1.51:
    • Allowed drag&drop external language files;
    • Fixed "Kaspersky Lab product - detection" when Kaspersky upgraded from lower version;
    • Fixed collision with USBAntivirus;
    • Optimized quicksort function;
  • 1.2.1.59:
    • Added window "Restart after Trial Reset on Kav\Kis 2012";
    • Modified registry-detection metod on Windows 2000;
  • 1.2.2.81:
    • Added "quick blacklist-compare"-function;
    • Corrected "Remove\Restore trial notifications" on KAV\KIS 2012;
  • 1.2.2.86:
    • Added German.lng;
  • 1.2.2.87:
    • Included KAV\KIS2012 keys support;
    • Updated Turkish.lng;
  • 1.2.2.93:
    • Updated Serbian.lng;
    • Modified "Trial reset" function for WKS 6.0.4.1424 Patch d,f;
    • Modified "Trial reset" function for KAV/KIS 12.0.0.374 Patch a,b,c,d,e,f;
  • 1.2.2.95:
    • Modified "Trial reset" function for KSOS2;
  • 1.2.2.103:
    • Fixed "Trial reset" function for KSOS2;
  • 1.2.3.30:
    • Added Polish.lng;
    • Included database aging period editor in "Tweaks" page;
  • 1.2.4.103:
    • Added "Trial Reset" function for KES8;
    • Added "Trial Reset" function for KSOS2FS;
    • Added single "Blacklist checker";
  • 1.2.4.126:
    • Added "Trial Reset" function for KAV6/KIS6;
    • Added drag&drop panel for single blacklist checker;
    • Changed about-window;
    • Updated "Serbian.lng";
  • 1.2.4.128:
    • Updated "Dutch.lng";
    • Updated "Turkish.lng";

Обратная связь:

Вопросы и предложения: AlexSlipknot@europe.com

Пожертвования разработчикам: Webmoney: Z282380295989 or R127994545567 or E130575658030

© Slipknot Corp. 2008-2011


Where to begin

Kaspersky World при старте проверяет обновления, и автоматически обновляется, но Касперский может блокировать соединение с сайтом обновлений, поэтому на ремя работы программы нужно деактивировать Касперского.

Exit from Kaspersky

Или можно добавить программу и сервер обновлений в исключения:

Add file to exclusions

Add site to exclusions


Выбор языка

Программа владеет несколькими языками. Вы можете выбрать свой язык в главном меню. "Настройки" -> "Язык"


Загрузка внешнего языкового файла

Load external language

Вы можете использовать свой языковой файл. Для загрузки языкового файла выберите "Настройки" -> "Загрузить внешний язык".


Загружать bonus.kkll при старте

Download bonus.kkll on start

"Bonus.kkll" - мини список ключей для Касперского, которые можно загрузить. Программа может автоматически загружать данный список если выбрать соответствующие настройки в главном меню. Этот пункт отмечен по умолчанию.


Reading blacklist on reading .kkll

Вы можете сравнивать ключи с черным списком. Это будет происходить автомачически если выбрать "читать blacklist при чтении .kkll" в "Настройках". Этот пункт выбран по умолчанию.


Ассоциировать программу с выбранными расширениями

Associating program with selected extensions

Вы можете ассоциировать программу с выбраными расширениями в главном меню программы. Нажмите "Настройки" -> "Ассоциировать с..."

Если вы хотите активировать Касперского с помощью ключа просто запуская key-файл - просто выберите пункт "Ассоциировать с .key".

Если у вас KIS 9.0.0.736, то вы должны выбрать пункт "Ассоциировать с .key (пароль)" так как для этой версии нужна защита паролем. Затем нужно настроить защиту паролем Касперского: "Включать защиту паролем" в настройках Касперского.


Возможность выполнения операций

Когда программа запущена без административных привилегий вы можете только загружать ключи, активировать Касперского ключом и отправлять отчет.

Когда программа запущена с административными привилегиями и самозащита Касперского выключена вы можете выполнять все операции кроме "Сброса триала".


Установленная версия Касперского

Installed Kaspersky product

В левом верхнем углу вы можете увидеть установленную версию продукта Касперского.


Offline mode

Kaspersky World может быть запужен в оффлайн режиме. В этом режиме программа не может быть обновлена. Также вы не можете использовать "Загрузчик ключей"


Shortcuts

Вы можете использовать горячие клавиши чтобы упростить использование Kaspersky World.

  • Ctrl+B - Загрузить и прочиттать blacklist;
  • Ctrl+O - Открыть kkll-файл;
  • Ctrl+A - Выделить все ключи;
  • Ctrl+I - Выделить все похожие ключи;
  • Ctrl+Z - Отменить выделение;
  • Ctrl+M or Space - Отметить выбраные ключи;
  • Ctrl+U or Space - Убрать отметки;
  • Ctrl+D - Загрузить отмеченные ключи;
  • F10 - Выход.


Сортировка

Для сортировки ключей - кликните на колонке которую хотите отсортировать.


Фильтрация

Вы можете найти ключ для любой версии очень быстро используя фильтрацию. Просто введите имя или тип ключа в поле ввода фильтрации и похожий ключ выделится подсветкой.


Сброс триала

Вы можете реактивировать Касперского в любое время использую данную возможность. Это значит что вы можете пользоваться бесплатной пробной лицензией. Перед продолжением вы должны выключить самозащиту и выйти из Касперского.


Триальные уведомления

Если вы используете пробную лицензию то видите уведомления в правом нижнем углу об использовании триальной лицензии. Если вы хотите от них избавиться - нажмите "Удалить триальные надписи". Также вы можете их восстановить нажав "Восстановить триальные надписи". Перед выполнением этой операции вы должны выключить самозащиту Касперского.


Активация ключом

Для активации Касперского ключом просто перетащите файл ключа. Внимание! Некоторые версии Касперского требуют включение защиты паролем для выполнения этой операции. Например если у вас KIS 9.0.0.736 или другой продукт который требует защиты паролем - при активации введите пароль в поле ввода. Программа не сохраняет ваши пароли! Также вы можете ассоциировать программу с расширением .key для более удобной активации. В этом случае Касперский будет активирован простым запуском файла ключа.


Сверка с черным списком

Когда вы активируете Касперского с помощью файла ключа - ключ автоматически проверяется на текущем черном списке.

Вы можете проверить файл ключа перед активацией. Впишите номер ключа в поле ввода и нажмите "Проверить". Если поле ввода примет черный цвет - ключ заблокирован.


Твики

В этой вкладке вы можете включать/выключать Касперского.

Также вы можете изменять период старения баз. Для примера: если у вас имеются антивирусные базы месячной давности и вы не хотите или у вас нет возможности их обновить, а Касперский постояно информирует вас об угрозе "Базы сильно устарели" вы можете поменять значение старения баз "Базы устарели" и "Базы давно не обновлялись" - на 32 - в этом случае сообщение появится через 32 дня.


Расширенные

Эта страница позволяет редактировать и модифицировать реестровые данные Касперского

Пример: если изменить параметр для "ProductType" можно получить:

  • kis - Kaspersky Internet Security;
  • kav - Kasersky Antivirus;
  • kts - Kaspersky Pure (Crystal);
  • wks - Kaspersky Antivirus for Windows Workstations;
  • ksospc - Kaspersky Small Office Security for Personal Computer;
  • ksosfs - Kaspersky Small Office Security for File Server;
  • kes - Kaspersky Endpoint Security.

Также можно поменять параметр для "ProductStatus":

  • Release - стандартная версия;
  • Beta - beta версия;