Общие сведения о WinRAR

WinRAR это архиватор RAR для Windows — мощный инструмент для архивирования и управления архивами. Помимо Windows, существуют версии RAR для других операционных систем — Linux, FreeBSD, Mac OS X, Android.

RAR для Windows доступен в двух вариантах:

  • WinRAR.exe – версия с графическим интерфейсом (GUI);
  • RAR.exe – консольная версия, запускаемая из командной строки и работающая в текстовом режиме.

WinRAR и модули самораспаковки WinRAR работают в среде Windows XP SP3 и новее.

Некоторые отличительные особенности WinRAR

  • полная поддержка архивов RAR и ZIP 2.0;
  • собственный высокоэффективный алгоритм сжатия данных;
  • графический интерфейс с поддержкой перетаскивания (drag & drop);
  • возможность использования интерфейса командной строки;
  • работа с архивами других форматов (7Z, ACE, ARJ, BZ2, CAB, GZ, ISO, JAR, LZ, LZH, TAR, UUE, XZ, Z, 001 и ZIPX нескольких типов);
  • поддержка непрерывного (solid) архивирования, при котором, как правило, достигается заметно более высокая степень сжатия (на 10–50% и более), чем дают обычные методы, особенно если упаковывается значительное количество небольших файлов однотипного содержания;
  • поддержка многотомных (состоящих из нескольких частей) архивов;
  • создание самораспаковывающихся (SFX) обычных и многотомных архивов с помощью разных SFX-модулей;
  • возможность восстановления физически повреждённых архивов;
  • особые тома для восстановления, позволяющие воссоздавать отсутствующие или повреждённые тома многотомных архивов.
  • поддержка кодировки Юникод в именах файлов;
  • другие дополнительные функции, например шифрование содержимого и имён файлов в архиве, добавление архивных комментариев, запись журнала ошибок и пр.


Ограничения WinRAR

Внутренний формат архивов RAR и ZIP, создаваемых WinRAR, позволяет хранить практически любое количество файлов практически любого размера. Реальные ограничения зависят лишь от файловой системы и доступной памяти. Так, некоторые старые файловые системы не поддерживают файлы объёмом более 4 ГБ.

WinRAR распределяет память для хранения имени и атрибутов каждого архивируемого файла. Если в архив добавлена информация для быстрого открытия, хранение имён и атрибутов файлов требует вдвое больше памяти. Конкретный объём зависит от длины имени файла в кодировке UTF-8; чтобы оценить требования к памяти при архивации, обычно можно добавлять несколько сотен байт на каждый файл к памяти, необходимой для словаря сжатия. Следует также помнить о том, что 32-разрядная версия WinRAR не может использовать более 2 ГБ памяти. Если требуется обрабатывать большие количества файлов или использовать крупные словари, предпочтительнее 64-разрядная версия WinRAR.

Максимальная длина пароля для шифрования данных – 127 символов. Более длинные пароли усекаются до этой длины.


Консольная версия RAR

Кроме WinRAR в комплект поставки входит файл Rar.exe. Это тоже версия RAR для Windows, но она поддерживает только интерфейс командной строки и работает в текстовом (консольном) режиме. Консольную версию RAR удобно использовать для вызова из пакетных файлов (BAT и CMD), для запуска из командной строки и т.п. У неё больше команд и ключей в командной строке, чем у WinRAR. Общие аспекты синтаксиса командной строки WinRAR, описанные в разделе "Интерфейс командной строки", верны и для консольного RAR. Однако этот файл справки не содержит описания тех ключей и параметров, которые присущи только консольной версии. Подробные сведения о консольной версии RAR приведены в файле rar.txt.


Благодарности

Выражаем глубокую благодарность Рону Двайту (Ron Dwight), так много сделавшему для WinRAR и его пользователей. Очень жаль, что Рону уже не суждено увидеть следующие версии WinRAR…

Для работы с архивами ZIP в WinRAR применяется программный код, разработанный группой Info-ZIP.

Алгоритм сжатия текстов основан на общедоступных исходных кодах PPMII (автор Дмитрий Шкарин) и carryless rangecoder (автор Дмитрий Субботин). Их можно найти на ftp.elf.stuba.sk/pub/pc/pack.

Применяемое в WinRAR шифрование данных использует части кода алгоритма AES (авторы Szymon Stefanek и Brian Gladman), а также исходный код SHA-1 (автор Steve Reid).

Применяемая в WinRAR функция вычисления контрольных сумм CRC32 основана на алгоритме Intel Slicing-by-8.

Архивы RAR могут факультативно включать хеш BLAKE2sp, разработанный Jean-Philippe Aumasson, Samuel Neves, Zooko Wilcox-O'Hearn и Christian Winnerlein.

Значительно увеличить степень и скорость сжатия архивов RAR позволили полезные советы Александра Хорошева и Булата Зиганшина.

Для распаковки архивов 7z используется библиотека 7zxa.dll, авторские права на которую принадлежат Игорю Павлову, разработчику архиватора 7-Zip. Библиотека распространяется по лицензии LGPL версии 2.1 или новее. Части 7zxa.dll разрешается модифицировать и выполнять обратный инжиниринг исключительно с целями отладки модификаций библиотеки 7zxa.dll в соответствии с LGPL. Для распаковки архивов XZ и LZMA ZIP используется общедоступный LZMA SDK Игоря Павлова. Исходный код библиотеки 7zxa.dll и LZMA SDK доступны на сайте www.7-zip.org.

Для улучшения производительности кодов Рида-Соломона мы использовали документ "Screaming Fast Galois Field Arithmetic Using Intel SIMD Instructions" авторов James S. Plank, Kevin M. Greenan и Ethan L. Miller. Мы также выражаем признательность Артёму Дробанову и Булату Зиганшину за примеры и идеи, позволившие повысить эффективность кодов Рида-Соломона.

Для распаковки архивов ACE применяется библиотека unacev2.dll, предоставленная разработчиками архиватора WinAce - www.winace.com<.

Большая часть графического оформления WinRAR выполнена Francesco Indrio (<om-studio@tiscali.it>, <omstudio@mail15.com>).

Идея встраивания WinRAR в оболочку операционной системы была навеяна отличной программой "RAR shell extension" (автор Ylian Saint-Hilaire).

Отдельная благодарность Андрею Спасибожко за помощь в разработке и реализации ранних версий RAR.

Перевод программы и сопутствующей документации на русский язык: Дмитрий Ерохин (выражаю благодарность Юрию Марцинчику, более пяти лет принимавшему участие в поддержке русскоязычной версии WinRAR).


Краткое введение

Режимы графической оболочки и командной строки

Краткое введение

WinRAR можно использовать двумя способами: в режиме графической оболочки (со стандартным интерфейсом Windows-программ) и в командной строке. Чтобы использовать WinRAR в режиме графической оболочки, дважды щёлкните левой кнопкой мыши на значке WinRAR — после этого для архивации и извлечения файлов вы сможете пользоваться кнопками и меню. В двух следующих разделах приведены последовательные инструкции.

Как извлечь файлы с помощью графической оболочки WinRAR

Как заархивировать файлы с помощью графической оболочки WinRAR

Для использования WinRAR в режиме командной строки необходимо в системном меню "Пуск" открыть окно "Выполнить..." или окно "Программы/Стандартные/Командная строка" и ввести нужную команду. Примеры простых команд архивации и извлечения файлов приведены в двух указанных ниже разделах, а более полное описание режима командной строки дано в разделе "Интерфейс командной строки". Обратите внимание, что если запустить WinRAR из командной строки без параметров, то будет активизирована графическая оболочка.

Как извлечь файлы в режиме командной строки

Как заархивировать файлы в режиме командной строки

Если при установке WinRAR вы не выключали параметр "Встроить WinRAR в оболочку", то извлекать и архивировать файлы можно прямо из оболочки Windows (из Проводника или с рабочего стола). Подробности см. ниже.

Как извлечь файлы в Проводнике или на рабочем столе

Как заархивировать файлы в Проводнике или на рабочем столе


Краткое введение: извлечение файлов в графической среде WinRAR

Краткое введение: извлечение файлов в режиме графической среды WinRAR

Чтобы извлечь из архива файлы, используя графическую оболочку WinRAR, сначала нужно открыть архив в WinRAR. Это можно сделать несколькими способами:

· дважды щёлкнуть левой кнопкой мыши или нажать <Enter> на файле архива в оболочке Windows (в Проводнике или на рабочем столе). Если при установке WinRAR был связан (ассоциирован) с файлами-архивами (что делается по умолчанию), то архив будет открыт в WinRAR. Связать WinRAR с архивами можно и после его установки в окне "Интеграция";

· дважды щёлкнуть мышью или нажать <Enter> на файле архива в окне WinRAR;

· перетащить архив на значок или окно WinRAR. Перед тем как это сделать, убедитесь, что в окне WinRAR не открыт другой архив, иначе перетаскиваемый архив будет добавлен в уже открытый;

· запустить WinRAR из командной строки с именем архива в качестве параметра.

При открытии архива в окне WinRAR выводится его содержимое. Выделите файлы и папки, которые вы хотите извлечь. Это можно сделать клавишами управления курсором или левой кнопкой мыши при нажатой клавише <Shift> (как в Проводнике и других Windows-программах). Выделять файлы в WinRAR можно также клавишами <Пробел> и <Insert>. Клавиши <+> и <-> на цифровой клавиатуре позволяют выделять и снимать выделение с группы файлов с помощью шаблонов (т.е. задавая маски файлов символами '*' и '?').

Выделив один или несколько файлов, нажмите кнопку "Извлечь..." вверху окна WinRAR, или же нажмите <Alt+E>, введите в появившемся окне нужный путь, после чего нажмите кнопку OK. Здесь же можно поменять несколько дополнительных параметров (более подробную информацию см. в разделе "Окно указания пути и параметров извлечения").

Во время извлечения отображается окно со статистикой. Если вы хотите прервать извлечение, нажмите кнопку "Отмена". Окно WinRAR можно минимизировать в область уведомлений панели задач: для этого нажмите кнопку "Фоновый режим". Если извлечение закончится без ошибок, то WinRAR вернётся в оболочку, в противном случае появится окно диагностических сообщений.


Краткое введение: извлечение файлов в командной строке

Краткое введение: извлечение файлов в режиме командной строки

Общий синтаксис командной строки для извлечения файлов с полными путями таков:

WinRAR X [ -ключи ] <архив> [ файлы ] [ @файлы-списки ] [ папка назначения\ ]

Для извлечения файлов без путей:

WinRAR E [ -ключи ] <архив> [ файлы ] [ @файлы-списки ] [ папка назначения\ ]

К примеру, если вы хотите извлечь файл LETTER.TXT в текущую папку из архива LETTERS.RAR, это можно сделать следующей командой:

WinRAR X LETTERS.RAR LETTER.TXT

Расширение архива указывать не обязательно.

Следующая команда извлечёт все *.WAV файлы из архива Songs в папку Audio:

WinRAR X Songs *.WAV Audio\

Файлы для извлечения можно также перечислить не в командной строке, а в текстовом файле. В этом случае в командной строке необходимо указать имя этого текстового файла, причём перед ним должен стоять символ @. Так, вы можете создать файл Binaries, содержащий строки *.exe и *.com, и выполнить команду

WinRAR X TOOLS @Binaries

чтобы извлечь в текущую папку из архива TOOLS все файлы с расширениями .EXE и .COM.

Во время извлечения отображается окно со статистикой. Если вы хотите прервать извлечение, нажмите кнопку "Отмена". Окно WinRAR можно минимизировать в область уведомлений панели задач: для этого нажмите кнопку "Фоновый режим". Если извлечение закончится без ошибок, WinRAR завершит свою работу, в противном случае появится окно диагностических сообщений.

Подробное описание команд и ключей см. в разделе "Интерфейс командной строки".


Краткое введение: извлечение файлов в Проводнике или на рабочем столе

Если при установке WinRAR вы не выключали параметр "Встроить WinRAR в оболочку", то извлекать файлы можно прямо в оболочке (Проводнике) Windows. Щёлкните правой кнопкой мыши на значке архива, выберите команду "Извлечь файлы...", введите в появившемся окне имя папки, в которую их надо извлечь, и нажмите кнопку OK. В этом же окне можно настроить несколько дополнительных параметров (более подробную информацию см. в разделе "Окно указания пути и параметров извлечения").

Вы можете также выбрать команду "Извлечь в <имя папки>", чтобы распаковать файлы в предложенную папку без каких-либо дополнительных запросов или "Извлечь в текущую папку" для извлечения в текущую папку.

Обратите внимание, что если включён параметр "Вложенные контекстные меню" в окне параметров интеграции, то для доступа к описанным пунктам меню вам нужно войти в подменю "WinRAR". Если данный параметр выключен, то эти пункты будут находиться на верхнем уровне контекстного меню.

Ещё один способ извлечь файлы — перетащить один или несколько архивов правой кнопкой мыши в папку назначения, а затем выбрать в появившемся меню команду "Извлечь в текущую папку".


Краткое введение: архивация файлов в графической среде WinRAR

Прежде всего, запустите WinRAR. Дважды щёлкните мышью или нажмите <Enter> на значке WinRAR. Вы также можете запустить его из меню "Пуск": зайдите в группу "Программы", потом в группу "WinRAR" и выберите пункт "WinRAR".

При запуске WinRAR показывает в своём окне список файлов и папок в текущей папке. Перейдите в папку, в которой находятся файлы, предназначенные для архивации. Для изменения текущего диска можно нажать комбинацию клавиш <Ctrl+D>, воспользоваться списком дисков (под панелью инструментов), или щёлкнуть на маленьком значке диска в нижнем левом углу окна. Для перехода в родительскую папку нажмите клавиши <Backspace> или <Ctrl+PgUp>, щёлкните на маленькой кнопке "Вверх" (под панелью инструментов) или дважды щёлкните на папке ".." в списке файлов. Для перехода в другую папку нажмите <Enter>, <Ctrl+PgDn> или дважды щёлкните мышью на этой папке. Для перехода в корневую папку текущего диска или папку с архивом нажмите сочетание клавиш <Ctrl+\>.

После того как вы вошли в папку с нужными файлами, выделите файлы и папки, которые хотите заархивировать. Это можно сделать клавишами управления курсором или левой кнопкой мыши при нажатой клавише <Shift> (как в Проводнике и других программах Windows). Выделять файлы в окне WinRAR можно также клавишами <Пробел> и <Insert>. Клавиши <+> и <-> на цифровой клавиатуре позволяют выделять и снимать выделение с группы файлов с помощью шаблонов (т.е. задавая маски файлов символами '*' и '?').

Выделив один или несколько файлов, нажмите кнопку "Добавить" (то же действие происходит при нажатии <Alt+A> или при выборе команды "Добавить файлы в архив" из меню "Команды"). В появившемся окне введите имя архива или просто подтвердите имя, предложенное по умолчанию. Здесь же можно выбрать формат нового архива (RAR или ZIP ), метод сжатия, размер тома и прочие параметры архивации. Подробно это окно описано в разделе "Окно ввода имени архива и его параметров". Нажмите кнопку OK, чтобы создать архив.

Во время архивации отображается окно со статистикой. Если вы хотите прервать процесс упаковки, нажмите кнопку "Отмена". Окно WinRAR можно минимизировать в область уведомлений панели задач: для этого нажмите кнопку "Фоновый режим". По окончании архивации окно статистики исчезнет, а созданный архив станет текущим выделенным файлом.

Добавлять файлы в существующий архив RAR можно также методом перетаскивания. Выделите архив в окне WinRAR и нажмите <Enter> (или дважды щёлкните мышью) на его имени — RAR прочтёт архив и покажет его содержимое. Теперь вы можете добавлять файлы в архив, просто перетаскивая их из другой программы в окно WinRAR.


Краткое введение: архивация файлов из командной строки

Краткое введение: архивация файлов в режиме командной строки

Общий синтаксис командной строки для архивации файлов таков:

WinRAR A [-ключи ] <Архив> [ Файлы ] [ @Файлы-списки ]

Например, если вы хотите добавить файл LETTER.TXT в архив LETTERS.RAR, введите:

WinRAR A LETTERS.RAR LETTER.TXT

Если не указать расширение архива, WinRAR будет использовать формат архива по умолчанию, определённый в профиле архивации по умолчанию. Однако вы можете задать тип архива явно, введя соответствующее расширение файла архива — .RAR или .ZIP.

Следующий пример добавляет все файлы *.WAV в непрерывный RAR-архив Songs:

WinRAR A -S Songs.RAR *.WAV

Файлы для архивации можно также перечислить не в командной строке, а в текстовом файле. В этом случае в командной строке необходимо указать имя этого текстового файла, причём перед ним должен стоять символ @. Так, вы можете создать файл Binaries, содержащий строки *.exe и *.com, и выполнить команду

WinRAR A TOOLS.ZIP @Binaries

чтобы добавить в ZIP-архив TOOLS все файлы из текущей папки с расширениями .EXE и .COM.

Во время архивации отображается окно со статистикой. Если вы хотите прервать архивацию, нажмите кнопку "Отмена". Окно WinRAR можно свернуть в область уведомлений панели задач: для этого нажмите кнопку "Фоновый режим". Если архивация закончится без ошибок, WinRAR завершит свою работу, в противном случае появится окно диагностических сообщений.

Подробное описание команд и ключей см. в разделе "Интерфейс командной строки".


Краткое введение: архивация файлов в Проводнике или на рабочем столе

Если при установке WinRAR вы не выключали параметр "Встроить WinRAR в оболочку", то архивировать файлы можно прямо в оболочке (Проводнике) Windows. В Проводнике или на рабочем столе выделите файлы, которые хотите заархивировать, нажмите правую кнопку мыши на выделенных файлах и выберите команду "Добавить в архив...". В появившемся окне введите имя архива или просто подтвердите имя, предложенное по умолчанию. Здесь же можно выбрать формат нового архива (RAR или ZIP), метод сжатия, размер тома и прочие параметры архивации. Более подробные сведения см. в описании окна ввода имени архива и его параметров. Нажмите кнопку OK для создания архива. Архив будет создан в той же папке, где находятся выделенные файлы.

Чтобы добавить файлы в предложенный архив без дополнительных запросов, воспользуйтесь командой "Добавить в <имя архива>". В этом случае будут применены параметры архивации из профиля архивации по умолчанию.

Обратите внимание, что если включён параметр "Вложенные контекстные меню" в окне параметров интеграции, то для доступа к описанным пунктам меню вам необходимо открыть подменю "WinRAR". Если данный параметр выключен, то эти пункты будут находиться на верхнем уровне контекстного меню.

Ещё один способ заархивировать файлы — перетащить значки файлов на значок существующего архива. В этом случае файлы будут добавлены в этот архив.


RAR или ZIP?

WinRAR может создавать архивы двух разных форматов: RAR и ZIP. Ниже описаны сравнительные особенности каждого из них.

Архивы ZIP

Основное преимущество формата ZIP — его популярность. Так, большинство архивов в Интернете имеют формат ZIP. Если вы хотите кому-то отправить архив, но не уверены, что у адресата есть программа WinRAR для распаковки архива, то имеет смысл использовать формат ZIP. Впрочем, в этом случае вы можете отправить и самораспаковывающийся (SFX) архив. Такие архивы чуть больше обычных, но для их распаковки не требуется никаких дополнительных программ.

Другое преимущество ZIP — скорость. Архивы ZIP обычно создаются быстрее архивов RAR, однако на современных компьютерах эта разница в скорости часто не имеет решающего значения.

Архивы RAR

Формат RAR, как правило, обеспечивает лучшее сжатие, чем ZIP, особенно в режиме создания непрерывных архивов. Многотомные архивы формата RAR имеют больше функций, нежели ZIP, например поддерживают самораспаковывающиеся тома.

Кроме того, у формата RAR есть ряд очень важных функций, отсутствующих у ZIP, например добавление данных для восстановления, которые позволяют восстановить физически повреждённый файл, блокировка архивов для предотвращения случайной модификации особенно ценной информации и др.

Оба формата — RAR и ZIP — позволяют обрабатывать файлы практически неограниченного размера (до 8 589 934 591 ГБ).


Архивный формат RAR 5.0

В WinRAR 5.0 появилась новая версия формата архивов RAR.

Новые особенности формата RAR 5.0:

  • Максимальный размер словаря сжатия увеличен до 1 ГБ. При упаковке больших файлов, особенно в непрерывном режиме, крупный словарь нередко позволяет достичь более высокой степени сжатия.
  • Шифрование данных основано на алгоритме AES-256, который теоретически более надёжен, чем AES-128, использующийся в RAR 4.x.
  • Данные для восстановления используют коды коррекции ошибок Рида-Соломона, имеющие значительно большую устойчивость к множественным повреждениям, чем данные для восстановления в RAR 4.x.
  • Ускорены операции с томами для восстановления. Максимальное количество томов RAR+REV в RAR 5.0 составляет 65 535, а не 255, как это было ранее.
  • Информация о времени файлов хранится во Всемирном координированном времени (Coordinated Universal Time, UTC), а не в местном, как это было в RAR 4.x, благодаря чему упростился обмен файлами между пользователями в разных часовых поясах.
  • В качестве контрольных сумм файлов можно использовать BLAKE2sp. В отличие от контрольных сумм CRC32, для BLAKE2 практически исключена ситуация, когда два разных файла имеют одинаковую контрольную сумму. Поэтому BLAKE2 можно применять для идентификации файлов.
  • В архивы можно добавлять информацию для быстрого открытия, ускоряющую чтение оглавления архива.
  • Поддержка многопоточности в алгоритме распаковки. Прирост скорости особенно заметен на больших файлах с плохо сжимаемыми данными или с контрольными суммами BLAKE2.
  • Поддержка точек соединения (reparse points), символических (мягких) ссылок и жёстких ссылок для накопителей с файловой системой NTFS.
  • Возможность хранить вторые и последующие копии идентичных файлов как ссылки на первую копию такого файла.
  • Полная поддержка Юникода. Имена файлов и комментарии хранятся в формате UTF-8.

В формат RAR 5.0 не включены некоторые устаревшие или неэффективные функции RAR 4.x:

  • В архивах RAR 5.0 недоступны особые алгоритмы упаковки, среди которых сжатие текста, необработанного аудио и полноцветной (TrueColor) несжатой графики, исполняемых файлов Itanium. Необработанные аудиоданные и графика TrueColor, распознаваемые RAR предыдущих версий, сегодня стали значительно менее распространёнными. Скорость сжатия текста на современных многоядерных процессорах слишком мала в сравнении с производительностью обычного алгоритма сжатия. Однако хотя эти алгоритмы не поддерживаются в архивах RAR 5.0, новейшие версии WinRAR способны распаковывать любые архивы RAR 4.x, включая те, в которых использованы упомянутые выше алгоритмы. В RAR 5.0 по-прежнему включены алгоритмы сжатия исполняемых файлов Intel IA-32 и дельта-сжатия как остающиеся эффективными для современных данных и аппаратуры.
  • При создании многотомных архивов не поддерживается старый стиль именования томов на основе изменения расширений файлов — archive.r00, archive.r01 и т.д. Главной целью такого именования была совместимость с файловой системой MS-DOS, однако эта схема не слишком хороша на таких платформах, как Windows, где расширения файлов используются для определения типов файлов и ассоциаций.

Старые программы, включая WinRAR версий до 5.0, не распознают архивы RAR 5.0. Поэтому если нужна уверенность, что архив будет распакован старым ПО, имеет смысл выбирать формат архивов RAR 4.x. Это можно сделать либо в окне Имя и параметры архива, либо с помощью ключа -ma в командной строке. Кроме того, формат RAR 4.x может быть предпочтительнее, если требуется использовать особые алгоритмы сжатия текста или мультимедийных данных, либо старая схема именования архивных томов.


Поддержка архивов других форматов

Помимо полной поддержки архивов RAR и ZIP, в WinRAR также реализована поддержка основных операций с архивами форматов 7Z, ACE, ARJ, BZ2, CAB, GZ, ISO, JAR, LZ, LZH, TAR, UUE, XZ, Z, созданными с помощью других программ. WinRAR способен распаковывать такие архивы, просматривать их содержимое, показывать комментарии и информацию об архиве. Никаких дополнительных программ для работы с этими архивами не требуется.

Кроме того, WinRAR умеет объединять файлы, разделённые на несколько частей и имеющие расширения .001, .002 и т.д. Таким образом, можно открыть файл .001 как обычный архив и затем распаковать его содержимое. Перед началом извлечения (объединения) убедитесь, что все части находятся в одной папке.


Непрерывные архивы

Непрерывные (solid) архивы

Непрерывный (solid) архив — это архив, упакованный специальным способом, при котором несколько или все сжимаемые файлы рассматриваются как один последовательный поток данных. WinRAR поддерживает непрерывную архивацию только в формате RAR, для формата ZIP такого типа упаковки не существует. Чтобы использовать непрерывное архивирование, включите параметр "Создать непрерывный архив" в окне архивирования или укажите в командной строке ключ -s.

Непрерывная архивация значительно увеличивает степень сжатия при добавлении в архив существенного количества небольших файлов с похожим содержимым. Однако следует иметь в виду, что у непрерывной архивации есть и некоторые недостатки:

· обновление непрерывных архивов (т.е. добавление файлов в уже существующий архив или их удаление из него) происходит медленнее, чем обновление обычных архивов;

· чтобы извлечь один файл из непрерывного архива, нужно проанализировать все предыдущие заархивированные файлы, поэтому извлечение отдельных файлов из середины или конца непрерывного архива происходит медленнее, чем извлечение из обычного архива. Однако если из непрерывного архива извлекаются все или расположенные последовательно первые файлы, то в этом случае скорость распаковки практически равна скорости распаковки обычного архива;

· если в непрерывном архиве какой-либо файл окажется повреждённым, то не удастся извлечь и все файлы, следующие после него. Поэтому при сохранении непрерывного архива на потенциально ненадёжных носителях настоятельно рекомендуется добавлять данные для восстановления (впрочем, эти данные могут оказаться нелишними и в других случаях, поэтому без веских причин пренебрегать ими не следует).

Непрерывные архивы предпочтительнее использовать в тех случаях, когда:

· архив предполагается редко обновлять;

· вы планируете чаще распаковывать весь архив, нежели извлекать из него один или несколько файлов;

· нужно достичь более плотной степени сжатия, даже в ущерб скорости упаковки.

Файлы в непрерывных архивах обычно отсортированы по расширению, однако сортировку можно отменить с помощью ключа -ds или самостоятельно задать альтернативный порядок сортировки посредством специального файла rarfiles.lst.

Многотомные и самораспаковывающиеся архивы тоже могут быть непрерывными.

См. также: ключ -s , ключ -ds, файл-список RarFiles.lst


Тома (архивы из нескольких частей)

С помощью WinRAR можно создать архив, состоящий из нескольких файлов. Такой архив называется многотомным, а отдельные файлы, составляющие этот архив, называются томами. Тома обычно используются для хранения больших объёмов данных на сменных носителях или для передачи данных по электронной почте.

WinRAR может создавать тома в форматах RAR и ZIP. Тома ZIP также часто называют разделёнными (split) ZIP-файлами.

По умолчанию тома RAR получают имена вида "имя_тома.partNNN.rar", где NNN — номер тома. Для формата RAR 4.x с помощью ключа -vn можно выбрать схему именования, основанную на расширениях файлов, при которой первый том многотомного архива получает расширение .rar, а расширения последующих томов нумеруются как .r00, .r01, .r02 и т.д. до .r99. Для архивов формата RAR 5.0 ключ -vn и имена на основе расширений не поддерживаются.

Тома RAR также могут быть непрерывными и самораспаковывающимися. Первый самораспаковывающийся том имеет другое (не .rar) расширение, например у SFX-томов для Windows это будет .exe.

Чтобы распаковать тома RAR, нужно начинать распаковку с первого тома. Если тома находятся на несменном носителе (например на жёстком диске), необходимо перед началом извлечения поместить все тома в одну папку.

Тома ZIP получают имена вида "имя_тома.zip", "имя_тома.z01", "имя_тома.z02". Для выполнения всех операций обработки архива, например чтобы начать извлечение или открыть архив, нужно использовать том с расширением ".zip".

В отличие от томов RAR, тома ZIP не могут быть самораспаковывающимися. Для создания или распаковки ZIP-томов с помощью WinRAR необходимо, чтобы был доступен сразу весь набор ZIP-томов. Поэтому создавать или распаковывать тома ZIP на сменных носителях, по одному тому на диск, невозможно. Если вы хотите получить многотомный ZIP-архив, нужно сначала создать все тома в одной и той же папке, после чего вручную скопировать тома на сменные диски. Аналогично и с извлечением: сначала требуется собрать все тома ZIP в одной папке, и лишь затем начинать распаковку.

Уже созданные многотомные архивы не допускают изменения, т.е. в них нельзя добавлять, обновлять или удалять файлы. Можно создать только новый набор томов.

Начиная с версии 3.40, WinRAR сохраняет номер тома внутри самого RAR-тома. Этот номер можно увидеть вверху окна с информацией, если вызвать его командой Показать информацию на архивном томе. Этот номер может пригодиться, если файлы с томами по какой-либо причине окажутся переименованными, и придётся восстанавливать имена вручную.


Тома для восстановления

Тома для восстановления представляют собой особые файлы с расширением .rev, создаваемые WinRAR и служащие для воссоздания отсутствующих и повреждённых томов в многотомном архиве. Тома для восстановления можно использовать только с многотомными архивами.

Данная возможность особенно полезна при резервном копировании или, к примеру, при отправке многотомного архива в сетевую конференцию (форум) в случае, когда до некоторых подписчиков дошли не все тома. В подобной ситуации повторная отправка томов для восстановления может быть более экономичной с точки зрения количества пересылаемых файлов, чем отправка обычных томов.

С помощью каждого тома для восстановления можно воссоздать один отсутствующий том RAR-архива. Например, если архив состоит из 30 томов, и для него создано три тома для восстановления, вы сможете воссоздать любые три отсутствующих тома. Если файлов .rev меньше, чем отсутствующих томов, воссоздание такого архива невозможно. Общее количество обычных томов и томов для восстановления не может превышать 255 для формата RAR 4.x, и 65 535 для формата RAR 5.0. Томов для восстановления должно быть меньше, чем томов RAR-архива.

После создания томов для восстановления исходные тома RAR-архива модифицировать нельзя. При воссоздании отсутствующих томов RAR алгоритм восстановления использует данные, хранящиеся как в REV-файлах, так и в томах RAR. Поэтому если после создания REV-файлов вы измените тома RAR, например заблокируете их от изменения, то восстановление выполнить не удастся.

Помимо данных для восстановления, в томах для восстановления RAR 5.0 хранится такая служебная информация, как контрольные суммы защищённых RAR-файлов. Поэтому эти тома чуть больше по размеру, чем тома RAR, которые они защищают. Если вы собираетесь копировать отдельные файлы RAR и REV на какой-либо сменный носитель, следует это учитывать и указывать размер томов RAR на несколько килобайт меньше, чем объём носителя.

Чтобы WinRAR воссоздал недостающие и повреждённые тома, нужно либо щёлкнуть мышью на файле .rev, либо воспользоваться командой rc. Кроме того, если WinRAR при распаковке не находит следующего тома, но обнаруживает необходимое число файлов .rev, то он воссоздаёт недостающие тома автоматически.

Чтобы создать тома для восстановления, вы можете воспользоваться соответствующим параметром в окне "Имя и параметры архива" на вкладке "Дополнительно" или аналогичным параметром в окне, вызываемом командой защиты архива от повреждений. В режиме командной строки тома для восстановления создаются с помощью команды RV или ключа -rv.

Исходные копии повреждённых томов перед реконструкцией переименовываются в *.bad. Например, volname.part03.rar будет переименован в volname.part03.rar.bad.


Самораспаковывающиеся архивы

Самораспаковывающиеся архивы (SFX)

Самораспаковывающийся (SFX, от англ. SelF-eXtracting) архив — это архив, к которому прикреплён исполняемый модуль. Этот модуль позволяет извлекать файлы простым запуском архива как обычной программы. Таким образом, для извлечения содержимого SFX-архива не требуются никакие дополнительные внешние программы. Вместе с тем, WinRAR может работать с SFX-архивом точно так же, как с любым другим, поэтому если вы не хотите запускать SFX-архив (например, когда не можете гарантировать, что в нём нет вирусов), то для просмотра или извлечения его содержимого можно использовать WinRAR.

SFX-архивы, как и любые другие исполняемые файлы, обычно имеют расширение .EXE.

SFX-архивы удобны в тех случаях, когда нужно передать кому-то архив, но вы не уверены, что у адресата есть соответствующий архиватор для его распаковки. SFX-архивы также можно использовать для распространения своих собственных программ. Например, при создании дистрибутива WinRAR используется SFX-модуль Default.sfx с графическим интерфейсом.

Чтобы создать SFX-архив из командной строки, можно использовать ключ -sfx при создании нового архива или команду S для преобразования существующего архива в SFX. При создании нового архива в оболочке WinRAR включите параметр "Создать SFX-архив" в окне ввода имени и параметров архива.

Если же нужно создать SFX-архив из уже существующего, то войдите в него и нажмите кнопку "SFX".

В комплект поставки WinRAR входит несколько SFX-модулей. Все SFX-модули (они имеют расширение .sfx) должны находиться в той же папке, что и WinRAR. По умолчанию WinRAR всегда использует модуль Default.sfx, но можно указать имя другого модуля сразу после ключа -sfx или команды S. Например, для преобразования архива myarchive.rar в SFX с модулем WinCon.SFX выполните следующую команду:

WinRAR SWinCon.SFX myarchive.rar

В оболочке WinRAR нужный SFX-модуль можно выбрать из списка, появляющегося при выполнении команды "Преобразовать архив в SFX".

Здесь можно ознакомиться с информацией о следующих SFX-модулях:

Графические SFX-модули RAR и ZIP (Default.SFX и Zip.SFX)

Консольный SFX-модуль RAR (WinCon.SFX)


Шифрование

Оба формата — RAR и ZIP — поддерживают шифрование информации. Чтобы зашифровать файлы, нужно до начала архивации указать пароль — в командной строке, в меню или непосредственно на вкладке "Общие" окна "Имя и параметры архива". В командной строке это делается с помощью ключа -p<пароль>. Для ввода пароля в оболочке WinRAR нажмите <Ctrl+P> (то же действие происходит при выборе команды "Установить пароль по умолчанию" в меню "Файл" или при щелчке мышью на маленьком значке ключа в левом нижнем углу окна WinRAR). Для ввода пароля в окне "Имя и параметры архива" необходимо нажать кнопку "Установить пароль" на вкладке "Дополнительно".

В отличие от ZIP, формат RAR позволяет шифровать не только данные файлов, но и другие важные области архива: имена файлов, размеры, атрибуты, комментарии и другие блоки. Если вы хотите задействовать эту функцию, включите параметр "Шифровать имена файлов" в окне задания пароля. Чтобы включить общее шифрование в режиме командной строки, вместо ключа -p[пароль] нужно указать ключ -hp[пароль]. Зашифрованный в таком режиме архив нельзя без пароля не только распаковать, но даже просмотреть список находящихся в нём файлов.

Непрерывные RAR-архивы и архивы с зашифрованными именами содержащихся в них файлов могут содержать только один пароль, одинаковый для всех файлов в архиве. Файлы в обычных (не непрерывных) RAR-архивах без шифрования имён файлов и в архивах ZIP могут быть зашифрованы с разными паролями (в одном архиве могут содержаться файлы с разными паролями).

Не забывайте удалять введённый пароль после того, как он становится ненужным, иначе вы можете случайно запаковать какие-либо файлы с паролем, абсолютно не намереваясь этого делать. Чтобы удалить пароль, введите пустую строку в окне ввода пароля или закройте WinRAR и снова его запустите. Когда пароль введён, жёлтый значок ключа становится красным. Кроме того, если вы начинаете архивацию с использованием пароля, заголовок окна ввода имени и параметров архива дважды мигнёт.

Если в окне ввода пароля вы включили параметр "Использовать для всех архивов" и указали в качестве пароля пустую строку, команды извлечения и тестирования будут пропускать все зашифрованные файлы и архивы. В этом режиме значок с изображением в строке состояния WinRAR не отображается.

Если вы ввели пароль непосредственно в окне "Имя и параметры архива", то вам не нужно отменять его самостоятельно — пароль будет действовать только в течение одной операции архивирования, по окончании которой автоматически сбросится.

При извлечении зашифрованных файлов можно ввести пароль заранее, хотя это и необязательно. Если пароль не был введён перед началом извлечения, и WinRAR обнаружил зашифрованный файл, он спросит пароль у пользователя.

Архивы RAR 5.0 шифруются по алгоритму AES-256 в режиме CBC, архивы RAR 4.x шифруются по алгоритму AES-128 в режиме CBC. Функция деривации ключа в RAR 5.0 основана на PBKDF2 с использованием HMAC-SHA256.

По умолчанию в архивах ZIP применяется алгоритм шифрования AES-256 в режиме CTR. Однако такие архивы могут быть несовместимыми с некоторыми старыми программами распаковки ZIP-файлов. Если требуется обеспечить лучшую совместимость со старыми программами, включите параметр "Традиционное (устаревшее) шифрование ZIP" в окне установки пароля, чтобы использовать устаревшее шифрование ZIP (которое значительно менее стойкое, чем AES).

Несмотря на то, что WinRAR позволяет использовать шифрование AES-256 как в архивах RAR, так и в ZIP, выбранные в RAR параметры функции деривации ключа, как ожидается, способствуют большей устойчивости шифрования RAR к атакам посредством перебора (brute force). Кроме того, RAR позволяет шифровать имена и другие свойства файлов. Поэтому если необходимо зашифровать конфиденциальную информацию, лучше выбирать формат RAR. Для обеспечения достаточно высокого уровня надёжности используйте пароли длиной не менее восьми символов. Избегайте в паролях распространённые слова – они ослабляют пароль. Обратите внимание, что в паролях учитывается рЕгиСтР букв. Максимальная длина пароля равна 127 символам. При указании более длинного пароля он будет обрезан до этой длины.

Если параметр "Шифровать имена файлов" выключен, контрольные суммы зашифрованных в RAR 5.0 файлов изменяются посредством особого, зависящего от пароля алгоритма. Это важно, поскольку иначе можно было бы угадывать содержимое файлов только по значениям контрольных сумм, без знания пароля. Особенно велик этот риск в случае маленьких файлов или при использовании надёжных контрольных сумм BLAKE2. Поэтому не ожидайте, что контрольные суммы зашифрованных файлов совпадут с действительными значениями CRC32 или BLAKE2. Если параметр "Шифровать имена файлов" включён, контрольные суммы хранятся в немодифицированном виде, поскольку доступ к ним возможен лишь после ввода правильного пароля.

Помните, что если вы потеряете свой пароль, извлечь из архива зашифрованные файлы не удастся, и в этом вам не сумеет помочь даже сам автор WinRAR.


Комментарий архива

В архивы RAR и ZIP можно добавлять необязательную текстовую информацию. Эта информация называется комментарием архива. Чтобы добавить комментарий вручную к уже существующему архиву в режиме графической оболочки WinRAR, используйте команду "Добавить комментарий архива", для чтения комментария из файла в режиме командной строки — команду "c " или ключ "-z<файл>".

Комментарий можно также указать непосредственно при архивации файлов в окне "Имя и параметры архива".

Если вы открываете в WinRAR архив, содержащий комментарий, а в окне настроек программы включён параметр "Показывать комментарий архива", то справа от списка файлов будет отображаться окно с комментарием. Ширину этого окна можно изменять, перетаскивая мышью его левый край.


Защита архивов от повреждений

Формат архивов RAR поддерживает особый тип избыточной информации, называемой данными для восстановления. Наличие в архиве таких данных увеличивает его размер, но позволяет восстановить архив даже в случае физического повреждения информации (например, из-за сбоя диска) или её потери вследствие любых других причин при условии, что повреждение не слишком серьёзное. Восстановление повреждённого архива выполняется командой Восстановить архив. Архивы ZIP не могут содержать данные для восстановления.

Чтобы добавить в архив данные для восстановления, включите параметр "Добавить данные для восстановления" в окне "Имя и параметры архива". Ещё один способ — включить соответствующий параметр в профиле архивации по умолчанию. В этом случае данные для восстановления будут добавляться в архив после любого изменения архива.

О том, как добавить данные для восстановления в режиме командной строки, см. в описаниях команды rr[N] и ключа -rr[N].

Данные для восстановления в архивах RAR 5.0 для исправления ошибок используют коды Рида-Соломона. В случае идущих подряд повреждений их возможности примерно такие же, как в версии RAR 4.x — они позволяют восстанавливать информацию чуть меньшего объёма, чем размер данных для восстановления. Однако если повреждения множественные и расположены в разных областях, возможности восстановления в RAR 5.0 значительно более эффективны, чем в RAR 4.x.

Данные для восстановления в RAR 4.x располагаются в секторах размером 512 байт, общее число которых не может превышать 524 288. Таким образом, полезный объём и возможность восстановления информации ограничены значением 256 МБ. В случае формата RAR 5.0 данные для восстановления могут быть такого же размера, как сам архив.

Размер данных для восстановления задаётся на вкладке "Дополнительно" окна "Имя и параметры архива" как процент от размера архива. Также его можно задать в команде "Добавить данные для восстановления". Чем больше данные для восстановления, тем более крупную повреждённую область можно восстановить, однако это сильнее увеличивает размер архива и замедляет обработку. Обычно разумным выбором будут значения 3–10% от размера архива. Из-за накладных расходов под служебные данные настоящий объём данных для восстановления лишь приблизительно соответствует указанному пользователем, и чем меньше архив, тем больше может быть эта разница.

Для восстановления повреждённого архива, защищённого с помощью данных для восстановления, в WinRAR служит команда "Восстановить". В командной строке используется команда r. Восстановленный архив получает имя fixed.имя_архива.rar, где 'имя_архива' – это имя исходного (повреждённого) архива. Если повреждённый архив не защищён данными для восстановления или если его невозможно полностью восстановить из-за крупного повреждения, то происходит вторая стадия процесса восстановления, в ходе которой реконструируется только структура архива. Файлы с неверной контрольной суммой после этой операции восстановить не удастся, однако становится возможным восстановить неповреждённые файлы, которые ранее были недоступны из-за нарушения структуры архива. Данный метод в основном работает с обычными, но не с непрерывными архивами. Эта стадия не выполняется для архивов с зашифрованными именами файлов. Такие архивы могут быть исправлены только при наличии данных для восстановления.

По окончании второго этапа реконструированному архиву присваивается имя rebuilt.имя_архива.rar, где 'имя_архива' – имя исходного архива.

Данные для восстановления RAR 5.0 более устойчивы и к повреждениям их самих, поэтому даже при частичной порче данных для восстановления их всё равно можно использовать для восстановления информации. Обратите, однако, внимание, что команда "Восстановить архив" не исправляет повреждённые блоки в данных для восстановления, восстанавливаются только файловые данные. После успешной починки архива следует создать новые данные для восстановления для сохранённых файлов.

Данные для восстановления в версиях RAR 4.x и 5.0 наиболее эффективны, если повреждённая информация в архиве находится на своих исходных местах, т.е. никуда не смещена. Если для копирования архива с повреждённого носителя вы применяете какую-либо специальную программу, и она предоставляет выбор между заполнением повреждённых мест нулями (или любыми другими данными) и вырезанием таких мест из файла, лучше выбрать заполнение, так как в этом случае будет сохранена исходная последовательность данных. Тем не менее данные для восстановления обеих версий пытаются восстановить информацию даже в неоптимальном режиме, когда она была смещена в разумных пределах из-за вставок или удалений. Данные для восстановления в RAR 5.0 обрабатывают удаления и вставки эффективнее, чем в RAR 4.x.


Блокировка архивов

Архивный формат RAR поддерживает блокировку архивов. Заблокированный архив невозможно изменить с помощью WinRAR, таким образом, вы можете заблокировать свои важные данные, чтобы их нельзя было случайно модифицировать.

Для блокировки архива служит команда "Блокировка архива" в режиме оболочки WinRAR или команда K и ключ -k в командной строке.


Выбор оптимальных параметров архивации

При создании нового архива на вкладке Общие окна "Имя и параметры архива" предлагается несколько относящихся к сжатию параметров. Сначала нужно выбрать формат архива: RAR, ZIP или RAR4. Формат ZIP предпочтителен, если нет уверенности, что у получателя есть программа WinRAR или другое ПО для распаковки RAR-архивов. В противном случае рекомендуется выбирать формат RAR, так как он значительно богаче функционально и обеспечивает более сильное сжатие. RAR4 – это предыдущая версия формата RAR, у которой отсутствуют некоторые важные изменения, появившиеся в формате RAR5 в 2013 году, например шифрование AES-256, более эффективная защита архивов от повреждений, увеличенные размеры словаря. Ряд старых программ, включая WinRAR версий ниже 5.0, неспособны распаковывать архивы RAR новейшего формата. Если вы хотите создавать архивы RAR, совместимые с таким ПО, то выберите формат RAR4.

Вслед за форматом архива необходимо выбрать метод архивации. Доступны следующие методы: "Без сжатия", "Скоростной", "Быстрый", "Обычный", "Хороший" и "Максимальный". Метод "Максимальный" обеспечивает наиболее высокую степень сжатия, но с наименьшей скоростью. Напротив, "Скоростной" сжимает сравнительно плохо, но очень быстро. При выборе метода "Без сжатия" файлы просто добавляются в архив с максимально возможной скоростью в своём исходном виде, т.е. без сжатия. Для создания ежедневных резервных копий лучше всего использовать метод "Скоростной", для распространения данных в Интернете — "Максимальный", а метод "Обычный" хорошо подходит для повседневного применения, например для упаковки вложений в сообщения электронной почты.

Если выбран формат ZIP, то на этом этапе подготовка заканчивается. Форматы RAR и RAR5 поддерживают ещё два важных параметра, влияющих на степень сжатия данных — размер словаря и непрерывное (solid) архивирование.

Словарь — это область в памяти, используемая алгоритмом упаковки для поиска и сжатия повторяющихся наборов данных. Больший размер словаря обычно способствует улучшению степени сжатия крупных файлов, особенно в режиме непрерывного архивирования, однако при этом также снижается скорость упаковки и повышаются требования к памяти. В повседневной работе мы рекомендуем использовать словарь размером 4 МБ для формата RAR, и 32 МБ — для формата RAR5 (RAR 5.0). Подробнее о размере словаря можно прочитать тут.

Если включён параметр "Создать непрерывный архив", архивируемые файлы сжимаются как один непрерывный поток данных, благодаря чему достигается высокая степень сжатия при упаковке значительного количества небольших файлов с однотипным содержимым. Следует, однако, иметь в виду, что изменение уже созданных непрерывных архивов выполняется медленнее, чем обычных, и, кроме того, в случае повреждения непрерывного архива потери данных могут быть более существенными, чем при повреждении обычного (не solid) архива. Этот режим подробно описан в разделе "Непрерывные архивы".

Вот и все основные установки, влияющие на степень и скорость сжатия. Но даже их необязательно настраивать перед каждой архивацией. Можно просто один раз указать свои наиболее часто используемые установки в профиле архивации по умолчанию, задаваемом в окне "Параметры архивации".


Знакомство с интерфейсом WinRAR

В этом разделе кратко описаны основные части интерфейса WinRAR.

Меню WinRAR содержит следующие пункты: "Файл", "Команды", "Операции", "Избранное", "Параметры" и "Справка". Щёлкните на интересующей вас ссылке, чтобы показать информацию о соответствующем меню.

Ещё один элемент интерфейса — панель инструментов. Она находится ниже меню и выше списка файлов. Кнопки на панели инструментов повторяют пункты из меню "Команды" (обратите внимание, что у всех пунктов в этом меню есть "горячие клавиши" для быстрого доступа). Во время просмотра содержимого архива некоторые кнопки могут быть отключены, если их функции неприменимы к архиву. При желании вы можете выбрать отображаемые кнопки, убрать текст с кнопок или уменьшить их размер, вызвав окно общих параметров программы или щёлкнув правой кнопкой мыши на панели инструментов.

Под панелью инструментов находится маленькая кнопка со стрелкой вверх и строка списка дисков. При нажатии этой кнопки происходит переход в родительскую папку. Список дисков служит для выбора текущего диска или, скажем, сети. Этот список также можно открыть нажатием клавиши <F4>. При желании кнопку "Вверх" и список дисков можно перетащить в правый угол панели инструментов. Текущий диск также можно изменить нажатием сочетания клавиш <Ctrl+D> или щелчком мыши на маленьком значке диска в строке состояния.

Ниже панели инструментов расположено файловое окно. В нём отображается содержимое текущей папки или, если в WinRAR открыт архив, содержимое архива. Эти режимы называются режимом управления файлами и режимом управления архивами. Для каждого файла выводится следующая информация: имя, размер, тип и дата изменения. Для файлов в архиве показываются ещё два параметра — контрольная сумма и упакованный размер. Контрольная сумма — это особое значение, вычисляемое на основании данных файла, с её помощью можно определить, не повреждены ли упакованные в архиве файлы. Для вычисления контрольных сумм WinRAR может использовать либо CRC32, либо алгоритм BLAKE2.

Все параметры представлены в виде колонок. Порядок сортировки файлов можно поменять щелчком на заголовке колонки (там же синей стрелкой указывается направление сортировки). Кроме того, можно изменить ширину колонок, перетаскивая мышью разделители заголовков колонок. Несколько дополнительных параметров списка можно изменить в окне "Список файлов".

Если находящийся в архиве файл зашифрован, то после его имени будет стоять звёздочка ( * ). Если файл продолжается в следующем томе, то после его имени будут стоять символы "-->". Если файл продолжается из предыдущего тома, то после имени будут стоять символы "<--". А если файл продолжается из предыдущего и переходит на следующий том, то после его имени будут стоять символы "<->".

Прежде чем обрабатывать файлы, их необходимо выделить. Помимо стандартных способов выделения Windows в WinRAR для той же цели служат несколько дополнительных клавиш: <Пробел>, <Insert>, а также <+> и <-> на цифровой клавиатуре. Более подробно это описано в разделе "Выделение файлов".

Следующие комбинации клавиш можно использовать для навигации по списку файлов. Чтобы перейти в родительскую папку, нажмите клавиши <Backspace>, <Ctrl+PgUp> или дважды щёлкните мышью на папке ".." в списке файлов. Если вы сделаете это в корневой папке архива, то закроете архив и перейдёте в папку на диске, где он находится. Для перехода в другую папку нажмите <Enter>, <Ctrl+PgDn> или дважды щёлкните левой кнопкой мыши на этой папке. То же действие на файле архива приведёт к открытию архива. Для перехода в корневую папку диска или папку с архивом служит комбинация клавиш <Ctrl+\>.

Чтобы попробовать открыть как архив файл с расширением, отличным от стандартного архивного, нажмите Ctrl+PgDn. Например если вы хотите проверить, не является ли exe-файл самораспаковывающимся архивом, но не хотите его запускать, то нажмите Ctrl+PgDn на имени этого файла. Если данный файл – SFX-архив, то WinRAR покажет содержимое архива.

Если щёлкнуть правой кнопкой мыши на списке файлов, то появится меню с командами интерфейса и управления файлами. Эти команды доступны также из обычных меню WinRAR, с панели инструментов и с помощью сочетаний клавиш, поэтому вы можете использовать наиболее удобный для себя способ.

В левой части окна WinRAR может отображаться панель с деревом папок, если это включено в подменю "Дерево папок" в меню "Параметры". Дерево папок удобно использовать для быстрой навигации по папкам на диске и в архиве. Ширину панели с деревом можно изменять, перетаскивая мышью её правую границу.

Если включён параметр "Показывать комментарий" в окне общих параметров, а в открытом архиве есть комментарий, он будет показан в специальном окне справа от списка файлов. Ширину окна комментария можно изменять, перетаскивая мышью его левый край.

Внизу окна WinRAR (под списком файлов) находится строка состояния. В её левой части расположены два маленьких значка: "накопитель" и "ключ". Щелчком по значку "накопитель" можно изменить текущий диск, а щелчком по "ключу" — текущий пароль. Две соответствующие команды также есть в меню "Файл". По умолчанию значок "ключ" жёлтого цвета, но если введён пароль, то он становится красным. В средней части строки состояния выводится информация об общем размере выделенных файлов или о текущем состоянии. В правой части строки состояния отображаются общее количество файлов в текущей папке и их размер.


Режимы управления файлами и архивами

Оболочка WinRAR имеет два основных режима: режим управления файлами и режим управления архивами.

В режиме управления файлами в окне WinRAR отображается список файлов и папок в текущей папке. Вы можете выделить эти файлы и папки с помощью мыши или клавиатуры (как принято в Windows) и произвести с выделенными файлами различные операции, например заархивировать их или удалить. В этом режиме также можно протестировать группу архивов и извлечь из них файлы.

В режиме управления архивами в окне WinRAR отображается список файлов и папок в открытом архиве. Здесь вы также можете выделить файлы и папки и выполнить с ними различные действия, специфичные для архива, например распаковать, протестировать или добавить комментарий.

В обоих режимах можно изменить текущую папку (на диске или в архиве). Для перехода в родительскую папку нажмите клавишу <Backspace> или <Ctrl+PgUp>, либо дважды щёлкните мышью на папке ".." в списке файлов. Если вы сделаете это в корневой папке архива, то закроете архив и перейдёте в папку на диске, в которой он находится. Для перехода в другую папку нажмите <Enter>, <Ctrl+PgDn> или дважды щёлкните мышью на этой папке. То же действие на файле архива приведёт к открытию архива. Для перехода в корневую папку диска или папку с архивом служит комбинация клавиш <Ctrl+\>.

Для входа в режим управления файлами запустите WinRAR двойным щелчком на его значке или введите в командной строке "WinRAR" без параметров.

Для входа в режим управления архивами запустите WinRAR в режиме управления файлами, поместите курсор на выбранный архив и нажмите <Enter> (это же действие выполняется при выборе пункта "Открыть архив" в меню "Файл" или при двойном щелчке мышью на имени архива). Кроме того, вход в режим управления архивами происходит при нажатии на архиве <Enter> или двойном щелчке мышью в оболочке Windows (в Проводнике или на рабочем столе), но только в том случае, если WinRAR ассоциирован с архивами (что делается по умолчанию во время установки). Связать WinRAR с архивами несложно и после установки — для этого служит окно "Параметры интеграции". И, наконец, зайти в нужный архив также можно непосредственно из командной строки, передав WinRAR в командной строке в виде единственного параметра имя этого архива.


Выделение файлов

Перед выполнением любой операции нужно выделить в списке файлов WinRAR те файлы и папки, которые необходимо обработать.

Если вы хотите выделить только один файл, то просто переместите на него курсор, после чего можно выполнять желаемую операцию. Существует несколько способов выделения файлов. Как и в других Windows-программах, для выделения непрерывной группы файлов можно использовать клавиши управления курсором или левую кнопку мыши, удерживая нажатой клавишу <Shift>. Чтобы выделить несколько отдельных элементов, держите нажатой клавишу <Ctrl> и щёлкайте мышью на каждом нужном элементе. Чтобы выделить все файлы и папки в текущей папке, нажмите <Ctrl+A> или воспользуйтесь командой "Выделить все" в меню "Файл".

Все описанные выше способы служат для обычного, непостоянного выделения, которое сбрасывается при перемещении курсора. Как правило, этих стандартных методов достаточно, но иногда более удобно постоянное выделение, позволяющее перемещать курсор в текущей папке без потери выделения ранее отмеченных элементов. Для этого в WinRAR предусмотрено несколько клавиш:

<Пробел>, <Insert> | Выделяет файл, находящийся под курсором, и перемещает курсор вниз. Для отмены выделения файла, отмеченного клавишами <Пробел> или <Insert>, ещё раз нажмите на этом файле <Пробел> или <Insert>, или используйте "-" на цифровой клавиатуре
<*> (на цифровой клавиатуре) | Инвертирует текущее выделение
<+> (на цифровой клавиатуре) | Выделяет файлы, соответствующие введённому шаблону
<-> (на цифровой клавиатуре) | Снимает выделение с файлов, соответствующих введённому шаблону

Если перед началом извлечения или тестирования не было выделено ни одного файла, то будут извлечены или протестированы все файлы в архиве. Это правило справедливо только для операций извлечения и тестирования.


Темы интерфейса

Интерфейсные темы дают возможность изменять стандартный вид графической оболочки WinRAR. Темы распространяются в виде архивов RAR с расширением ".theme.rar". Ряд тем доступен для загрузки в разделе "Themes" на сайте WinRAR. Чтобы установить новую тему, нужно лишь открыть файл с этой темой в WinRAR подобно любому другому обычному RAR-архиву (например дважды щёлкнув мышью на значке архива). После WinRAR выведет окно, в котором потребуется подтвердить установку.

Список установленных тем находится в подменю "Темы" меню "Параметры". Чтобы активизировать нужную вам тему, просто выберите в списке её название. Находящиеся в этом же меню команды "Упорядочить темы…" и "Загрузить дополнительные темы…" служат для манипулирования темами и загрузки их с web-сайта, соответственно.

Файлы тем хранятся в папке "Themes", вложенной в папку %APPDATA%\WinRAR.


Режим мастера

Режим мастера WinRAR предназначен для пользователей-новичков, чтобы максимально облегчить им выполнение основных операций архивирования и распаковки с помощью простой пошаговой процедуры.

Чтобы вызвать окно мастера, нажмите кнопку "Мастер" на панели инструментов WinRAR. По умолчанию эта кнопка отображается и при нахождении внутри архивов, и вне их, но вы можете отключать/включать её (подобно остальным кнопкам) в окне выбора кнопок, вызываемом кнопкой "Выбрать кнопки…" в окне общих параметров программы. Другой расположенный в том же окне параметр - "При старте запускать мастера" - позволяет включить режим, при котором мастер будет вызываться автоматически при каждом запуске WinRAR.

Каждое окно мастера снабжено краткой инструкцией, в которой описывается содержимое окна и возможные действия пользователя. Если этой информации будет недостаточно, нажмите кнопку "Справка", чтобы ознакомиться с более подробными инструкциями.


Мастер: Выбор операции

Здесь вам нужно выбрать, какую следует выполнить операцию.

Если вы хотите извлечь содержимое RAR, ZIP или архивов других типов, выберите параметр "Распаковать архив". Укажите его, если, например, нужно распаковать полученный из Интернета файл.

Если вы хотите создать новый архив и поместить в него свои файлы в уплотнённом виде, выберите параметр "Создать новый архив". Сжатие файлов полезно перед отправкой их по электронной почте или копированием на внешний накопитель, так как они при этом будут занимать меньше места и, следовательно, экономить ваши ресурсы.

Если вы хотите добавить файлы в уже существующий архив (т.е. не создавая нового архива), выберите параметр "Добавить файлы в уже существующий архив".

Выбрав желаемую операцию, нажмите расположенную внизу окна кнопку "Далее". Если вы выбрали параметр "Создать новый архив" или "Добавить файлы в уже существующий архив", то появится окно выбора файлов, в котором вам будет нужно выбрать те файлы, которые вы хотите заархивировать. Если же был указан параметр "Распаковать архив", то вы сразу попадёте в окно выбора архива.


Мастер: Выбор архива

Здесь вам нужно указать архив, который требуется распаковать.

Нажмите кнопку "Обзор", найдите свой архив, щёлкните мышью на его имени и нажмите кнопку "Открыть". Вместо использования кнопки "Обзор" вы также можете просто перетащить мышью значок архива на это окно.

Выбрав имя архива, нажмите расположенную внизу окна кнопку "Далее".

Обратите внимание, что при вызове этого окна WinRAR пытается "угадать" архив и подставить имя существующего архива с рабочего стола. Если это действительно тот архив, который требуется распаковать, просто нажмите кнопку "Далее". Если же предположение WinRAR оказалось неправильным, укажите нужный вам архив, как описано выше.


Мастер: Выбор архива

Здесь вам нужно указать архив, который требуется создать или обновить.

Если вы создаёте новый архив, WinRAR обычно сам предлагает для него имя. Вы можете либо согласиться с предложенным именем, либо ввести другое. Если поле "Папка по умолчанию для архивов" в настройках WinRAR не пусто, WinRAR предложит создать архив в этой папке. В противном случае предложенное имя будет без пути, а архив будет создан на рабочем столе Windows. Если вы хотите создать архив в другой папке, нажмите кнопку "Обзор", найдите папку для размещения в ней архива, введите имя архива в поле "Имя файла" и нажмите кнопку "Открыть".

Если вы хотите добавить файлы в уже существующий архив, можно также воспользоваться кнопкой "Обзор" для поиска обновляемого архива или перетащить мышью значок архива на это окно.

Выбрав имя архива, нажмите расположенную внизу окна кнопку "Далее".


Мастер: Выбор папки для распаковки файлов

Здесь вам нужно выбрать папку, в которую будут помещаться извлекаемые из архива файлы.

По умолчанию WinRAR предлагает извлекать их в папку, указанную в поле "Папка по умолчанию для извлекаемых файлов" в настройках путей, либо, если папка не задана, на рабочий стол. Вы можете либо принять предложенное имя, либо нажать кнопку "Обзор" и выбрать папку самостоятельно.

Выбрав имя папки, нажмите расположенную внизу окна кнопку "Готово", чтобы начать извлечение.


Мастер: Параметры архивации

Здесь вы можете указать некоторые дополнительные параметры архивирования.

Если для вас важна высокая скорость архивирования, и вы готовы пожертвовать ради этого степенью сжатия, включите параметр "Сжимать быстрее, но менее плотно".

Если вы хотите, чтобы после успешного помещения файлов в архив они были удалены с диска, включите параметр "Удалить файлы после архивации".

Если вам требуется создать самораспаковывающийся архив, включите параметр "Создать самораспаковывающийся (.exe) архив". Для распаковки такого архива WinRAR не требуется — архив имеет расширение .EXE, и чтобы извлечь его содержимое, достаточно лишь запустить этот файл (дважды щёлкнуть мышью на его значке).

Если вы хотите зашифровать архивируемые файлы, нажмите кнопку "Установить пароль" и укажите пароль. Будьте внимательны: если вы забудете свой пароль, извлечь файлы из архива будет невозможно!

Кроме того, при создании нового архива его можно разделить на несколько отдельных частей (так называемых "томов" ). В некоторых ситуациях несколько файлов меньшего размера бывают удобнее, чем один большой файл. Если вы решили создать архив из нескольких частей, просто введите размер одной его части в поле, расположенном внизу окна. Размер можно указывать в байтах, килобайтах, мегабайтах или гигабайтах. Просто выберите подходящий элемент из выпадающего списка правее поля ввода размера тома. Допускается указывать десятичные дроби.

Если вы обновляете уже существующий архив, параметры для создания самораспаковывающегося архива и разделения архива на тома недоступны. Они применимы только в случае создания нового архива.

Обратите внимание, что все параметры в этом окне — необязательные, обычно вы можете оставлять их значения, принимаемые по умолчанию.

Когда определитесь с выбором параметров, нажмите расположенную внизу окна кнопку "Готово", чтобы начать архивирование.


Просмотр файлов

При выполнении команды "Просмотреть файл" WinRAR показывает содержимое файла под курсором в окне встроенной программы просмотра вне зависимости от содержимого файла и параметров настройки, однако при нажатии <Enter> на имени файла возможны несколько вариантов. Если находящийся под курсором файл является архивом, то WinRAR откроет и покажет содержимое этого архива, в противном случае последующие действия зависят от параметров, указанных в окне параметров просмотра. В этом окне можно указать, что для просмотра файла WinRAR будет:

а) всегда использовать внутреннюю программу просмотра,

б) запускать внешнюю программу просмотра,

в) запускать программу, связанную в Windows с файлом этого типа, или

г) перед каждым просмотром файла выдавать запрос о том, какой из трёх описанных выше способов следует применить.

WinRAR можно использовать для просмотра как заархивированных, так и обычных файлов. Если для просмотра архивного файла вызывается внешняя программа, то WinRAR извлекает этот файл во временную папку, передаёт его имя внешней программе и ожидает, пока она закончит свою работу. Далее WinRAR проверяет время изменения файла, и если он был обновлён внешней программой, предлагает обновить его в архиве. После этого временная папка вместе с извлечённым файлом удаляется.

Обратите внимание, что эта схема слегка меняется, если вы нажимаете <Enter> на находящемся в архиве файле с расширением .exe. В этом случае WinRAR извлекает во временную папку не только этот файл, но и всё содержимое архива, после чего запускает выделенный исполняемый файл. Последующие шаги аналогичны описанным выше: WinRAR ожидает окончания работы программы, затем проверяет время изменения извлечённых и наличие новых файлов, предлагая по мере необходимости обновить архив. После этого временная папка со всем её содержимым удаляется. Данный метод обработки EXE-файлов позволяет запускать программы непосредственно из архива. Например, вы можете установить новую программу, не распаковывая при этом её дистрибутив, а просто войдя в архив и нажав <Enter> на файле setup.exe или install.exe.


Встроенное средство просмотра

Команды встроенного средства просмотра:

Меню / Пункт | Клавиша | Функция
Файл / Выход | Alt+F4, Ctrl+W | Выход из встроенного просмотра
Правка / Копировать | Ctrl+C | Скопировать выделенный текст в буфер обмена
Правка / Выделить все | Ctrl+A | Выделить весь просматриваемый текст
Правка / Найти | Ctrl+F | Найти строку в тексте
Правка / Найти далее | F3 | Найти следующую соответствующую строку
Вид / Просмотр как текста Windows | Ctrl+I | Использовать таблицу символов Windows
Вид / Просмотр как текста DOS | Ctrl+D | Использовать таблицу символов DOS
Вид / Просмотр как текста в Юникоде (UTF-16LE) |  | Просмотр текста как Юникода в формате UTF-16 little-endian
Вид / Просмотр как текста в Юникоде (UTF-8) |  | Просмотр текста как Юникода в формате UTF-8
Вид / Перенос по словам | Ctrl+S | Включить/выключить режим переноса строк по словам
Вид / Шрифт… |  | Установить шрифт для просмотра
Справка / Справка по просмотру | F1 | Показать справку по встроенному просмотру

Чтобы изменить таблицу символов, щёлкните мышью в правой части строки состояния программы просмотра, где отображается имя текущей таблицы символов. Таблицу символов, которая будет использоваться по умолчанию, можно указать в окне параметров просмотра.


Команда "Добавить файлы в архив"

Эта команда доступна как в режиме управления файлами, так и в режиме управления архивами.

Если WinRAR находится в режиме управления файлами, выделите те файлы и папки, которые нужно заархивировать. После этого выберите команду "Добавить файлы в архив" в меню "Команды" (это же действие выполняется при нажатии кнопки "Добавить" на панели инструментов или комбинации клавиш <Alt+A>). Укажите имя архива и параметры в окне ввода имени архива и его параметров и нажмите <Enter> для начала архивации.

Если WinRAR находится в режиме управления архивами, то сначала нужно выбрать команду "Добавить файлы в архив", потом в появившемся окне выделить добавляемые файлы, а затем указать имя и параметры архива, как описано выше.

Эквивалент командной строки: команда "A"


Команда "Извлечь в указанную папку"

Эта команда доступна как в режиме управления файлами, так и в режиме управления архивами.

В режиме управления архивами, когда WinRAR отображает содержимое архива, выделите в архиве те файлы и папки, которые требуется извлечь. После этого воспользуйтесь командой "Извлечь в указанную папку" из меню "Команды", кнопкой "Извлечь..." на панели инструментов или комбинацией клавиш <Alt+E>. В окне указания пути и параметров извлечения вы можете указать папку, в которую будут извлечены файлы, и при необходимости настроить дополнительные параметры. После закрытия этого окна начнётся процесс извлечения файлов.

В режиме управления файлами можно одновременно распаковать несколько архивов. В целом операция похожа на описанную выше, однако вместо выбора файлов внутри архива необходимо выбрать архивы и папки, в которых WinRAR будет искать архивы. Если в результате поиска будет найден хоть один архив, то появится окно "Пути и параметры извлечения". После закрытия этого окна начнётся распаковка всех найденных архивов.

Эквивалент командной строки: команда "X"


Команда "Протестировать файлы в архиве"

Эта команда доступна как в режиме управления файлами, так и в режиме управления архивами.

В режиме управления архивами, когда WinRAR отображает содержимое архива, выделите в архиве те файлы и папки, которые требуется извлечь. После этого воспользуйтесь командой "Протестировать файлы в архиве" в меню "Команды", кнопкой "Тест" на панели инструментов или комбинацией клавиш <Alt+T>.

Любые обнаруженные при тестировании ошибки будут отображены в окне "Диагностические сообщения". Если ни одной ошибки не произойдёт, WinRAR выдаст соответствующее сообщение.

В режиме управления файлами можно одновременно протестировать несколько архивов. В целом операция похожа на описанную выше, только вместо выбора файлов внутри архива необходимо выбрать архивы и папки, в которых WinRAR будет искать архивы. Если в результате поиска будет найден хоть один архив, WinRAR протестирует все найденные архивы.

Эквивалент командной строки: команда "T"


Команда "Просмотреть файл"

Эта команда доступна как в режиме управления файлами, так и в режиме управления архивами. Она открывает файл, на который указывает курсор, во встроенной программе просмотра. Для запуска этой программы используйте пункт "Просмотреть файл" в меню "Команды", кнопку "Просмотр" на панели инструментов или комбинацию клавиш <Alt+V>.

См. также: Встроенная программа просмотра, Просмотр файлов


Команда "Удалить файлы"

Эта команда доступна как в режиме управления файлами, так и в режиме управления архивами. В режиме управления файлами она удаляет выделенные файлы и папки в Корзину, поэтому случайно удалённые данные впоследствии можно будет восстановить. Однако в режиме управления архивами выделенные файлы и папки удаляются окончательно, поэтому будьте осторожны. Для запуска этой команды используйте меню "Команды", кнопку "Удалить" на панели инструментов, клавиши <Alt+D> или <Del>.

Окончательно удалять файлы, не помещая их в Корзину, можно и в режиме управления файлами. Для этого вместо <Del> используйте комбинацию клавиш <Shift+Del>. Нажатие <Shift+Del> удаляет без дополнительных запросов даже файлы с системными атрибутами и только для чтения, а также позволяет удалять файлы с нестандартными именами, например с пробелами или точками в конце. Обычное удаление в Корзину может не справиться с такими именами.

Эквивалент командной строки: команда "D"


Команда "Переименовать файл"

Эта команда позволяет переименовать файл или папку под курсором. Она доступна и в режиме управления файлами, и в режиме управления архивами. Переименование файлов внутри архивов поддерживается для форматов RAR и ZIP. Чтобы воспользоваться этой командой, вызовите её в меню "Команды" или нажмите клавишу <F2>.

Команда переименования имеет некоторые ограничения при работе с многотомными архивами. Переименовать можно только те файлы, которые находятся в текущем томе. Если вы собираетесь переименовывать файлы в многотомных архивах, необходимо выключить параметр "Объединять содержимое томов" на вкладке "Список файлов" в окне настроек WinRAR и открывать тома, содержащие требующиеся файлы.

Выбирайте новое имя файла внимательно! Если имя будет содержать символы, не поддерживаемые файловой системой, впоследствии вы можете столкнуться с проблемами при извлечении переименованного файла. Если такое всё же произойдёт, просто переименуйте файл ещё раз, дав ему более подходящее имя.

Эквивалент командной строки: команда "RN"


Команда "Печать файла"

Эта команда предназначена для распечатки файла, на котором установлен курсор. Она доступна как в режиме управления файлами, так и в режиме управления архивами. Команду можно вызвать из меню "Команды" или комбинацией клавиш <Ctrl+I>.


Команда "Извлечь без подтверждения"

Эта команда доступна и в режиме управления архивами, и в режиме управления файлами. Если WinRAR находится внутри архива, вам нужно выделить те находящиеся в архиве файлы и папки, которые требуется извлечь. Если же WinRAR находится в режиме управления файлами вне архивов, выделите те файлы и папки, среди которых будет выполняться поиск архивов для распаковки. После этого воспользуйтесь командой "Извлечь без подтверждения" из меню "Команды", кнопкой "Извлечь" на панели инструментов или комбинацией клавиш <Alt+W>. Выделенные файлы будут извлечены в текущую папку или в папку для извлекаемых файлов по умолчанию, если это определено в окне настроек путей. Если вы хотите указать папку для распаковки или другие дополнительные параметры, то можете применить команду "Извлечь в указанную папку".

Эквивалент командной строки: команда "X"


Команда "Добавить комментарий архива"

Эта команда доступна как в режиме управления файлами, так и в режиме управления архивами. Если WinRAR находится внутри архива, никакие файлы выделять не нужно, просто воспользуйтесь командой "Добавить комментарий архива" из меню "Команды", кнопкой "Комментарий" на панели инструментов или комбинацией клавиш <Alt+M> и введите в появившемся окне комментарий архива. Если же вы находитесь в режиме управления файлами вне архивов, сначала выделите те файлы и папки, среди которых будет выполняться поиск архивов для добавления комментариев.

Эквиваленты командной строки: команда "C" , ключ -z<f>


Команда "Добавить данные для восстановления"

Эта команда доступна как в режиме управления файлами, так и в режиме управления архивами. Если WinRAR находится внутри архива, никакие файлы выделять не нужно, просто воспользуйтесь командой "Добавить данные для восстановления" в меню "Команды", кнопкой "Защита" на панели инструментов или комбинацией клавиш <Alt+P>. Если же вы находитесь в режиме управления файлами вне архивов, сначала выделите те файлы и папки, среди которых будет выполняться поиск архивов для добавления защитных данных.

Эта команда добавляет в текущий открытый архив или в выделенные архивы данные для восстановления. Такие данные могут впоследствии помочь восстановить архив, если он по какой-либо причине окажется физически повреждённым. Данная функция применима только к архивам формата RAR.

Если открытый архив – первый файл в последовательности томов многотомного архива, для него также можно создать тома для восстановления. Для этого просто укажите количество создаваемых файлов .rev. Кроме того, к этому параметру можно добавить знак процента (%), и тогда количество создаваемых файлов .rev будет вычисляться как процент от общего количества томов RAR-архива.

Эквивалент командной строки: команда "RR", команда "RV"


Команда "Запретить изменения в архиве"

Команда "Заблокировать архив"

Эта команда доступна как в режиме управления файлами, так и в режиме управления архивами. Если WinRAR находится внутри архива, никакие файлы выделять не нужно, просто воспользуйтесь командой "Заблокировать архив" в меню "Команды", кнопкой "Запрет" на панели инструментов или комбинацией клавиш <Alt+L>. Если же вы находитесь в режиме управления файлами вне архивов, сначала выделите те файлы и папки, среди которых будет выполняться поиск архивов для блокировки.

Заблокированный архив (т.е. архив, изменение которого запрещено) невозможно изменить средствами WinRAR. Блокировка может пригодиться, например, чтобы предотвратить случайное изменение важных архивов.

Блокировать можно только архивы RAR.

Эквивалент командной строки: команда "K"


Команда "Проверить архив на вирусы"

Эта команда доступна как в режиме управления файлами, так и в режиме управления архивами. Она распаковывает один или несколько архивов во временную папку, после чего проверяет содержимое этой папки с помощью одного из антивирусных сканеров, установленных в компьютере пользователя. В режиме управления архивами обрабатывается содержимое только открытого в данный момент архива, а в режиме управления файлами обработке подлежат все архивы, обнаруженные среди выделенных файлов и папок.

Данная команда вызывает окно со следующими полями:

  • Обнаруженные антивирусные программы

    Список антивирусных программ, установленных в компьютере и обнаруженных WinRAR. Если в этом списке содержатся несколько антивирусных сканеров, то можно выбрать любой из них по вкусу. Если же список состоит только из элемента "Задано пользователем", это означает, что WinRAR не смог найти в системе ни одной антивирусной программы, и вы должны указать имя и параметры сканера самостоятельно.

  • Имя антивирусного сканера

    Имя исполняемого файла антивирусного сканера. Информацию в этом поле следует изменять только тогда, когда WinRAR не смог обнаружить установленного в компьютере антивирусного ПО, и в списке "Обнаруженные антивирусные программы" присутствует только элемент "Задано пользователем". В этом случае нужно нажать кнопку "Обзор" и указать exe-файл вашего антивируса, который будет вызываться WinRAR для проверки извлечённых из архивов файлов.

  • Параметры антивирусного сканера

    Параметры, передаваемые антивирусному сканеру. Информацию в этом поле следует изменять только тогда, когда WinRAR не смог обнаружить установленного в компьютере антивирусного ПО, либо когда указанные параметры не соответствуют данному сканеру. Такое может произойти, например, если в новой версии антивирусной программы изменился синтаксис командной строки. Обычно для антивирусных сканеров требуется указывать только один параметр – имя папки, содержащей распакованные файлы. Для обозначения этой папки WinRAR использует символ %f. Поскольку в имени могут содержаться пробелы, его необходимо заключать в кавычки, поэтому вероятнее всего в этом поле следует указывать строку "%f". Тем не менее, некоторые антивирусы могут нуждаться в дополнительных параметрах, сведения о которых приведены в соответствующей документации.

    Если вы постоянно пользуетесь только одной антивирусной программой, и потому нет необходимости изменять её параметры при каждом сканировании, то можете выключить появление окна выбора антивирусного сканера с помощью параметра "Предлагать выбор антивирусного сканера" в настройках безопасности.

    Примечания

    а) WinRAR не ищет вирусы самостоятельно, а лишь вызывает для этого антивирусное ПО, уже установленное в компьютере. Если такого ПО в вашей системе нет, воспользоваться этой командой WinRAR не удастся;

    б) WinRAR не выводит никаких сообщений по окончании работы этой команды. Чтобы узнать, найдены вирусы или нет, вы должны следить за информацией, отображаемой антивирусным сканером;

    в) перед вызовом антивирусного сканера WinRAR распаковывает все выбранные архивы во временную папку, поэтому позаботьтесь о том, чтобы на диске хватило свободного места для всех извлечённых файлов. По окончании сканирования WinRAR удаляет эти файлы;

    г) WinRAR умеет автоматически обнаруживать множество популярных антивирусных программ, поэтому обычно не требуется самостоятельно редактировать поля "Имя антивирусного сканера" и "Параметры антивирусного сканера". Просто выберите в списке название сканера и нажмите OK, а два других поля потребуются только в том случае, если этот метод не сработает;

    д) WinRAR запоминает параметры антивирусного сканера, которые использовались в прошлый раз, и подставляет их при следующем вызове данной команды.


Команда "Преобразовать архивы"

Эта команда позволяет преобразовывать архивы из одного формата в другой. Данная команда доступна как в режиме управления файлами, так и в режиме управления архивами. В режиме управления файлами можно выделить несколько файлов и папок для обработки – и тогда WinRAR просканирует их и сконвертирует найденные архивы. В режиме управления архивами по умолчанию преобразованию подвергается только текущий архив. Ниже приведено описание параметров в окне "Преобразование архивов", определяющих выполнение команды.

  • Архивы для преобразования

    Список архивов, которые будут преобразованы с помощью WinRAR. Вы можете добавлять и удалять элементы этого списка кнопками "Добавить" и "Удалить". Нажатие кнопки "Удалить" не удаляет файлы с диска, а лишь убирает их из списка конвертируемых.

    Содержание списка архивов зависит от следующего параметра — списка форматов (типов).

  • Типы архивов

    Здесь можно выбрать, архивы каких форматов следует преобразовать. Архивные форматы в этом списке могут дополняться числом в круглых скобках. Оно показывает, сколько архивов данного типа найдено и готово к преобразованию. Например, "zip(12)" означает, что WinRAR обнаружил 12 архивов ZIP. Если число отсутствует, это значит, что архивы данного типа не найдены.

    Параметры преобразования

  • Минимально допустимая степень сжатия

    Этот параметр позволяет указать наименьшее допустимое процентное соотношение <размер нового архива>/<размер старого архива>, при котором следует выполнять преобразование. Например, если указать значение 100, то WinRAR будет сохранять уже существующие архивы, когда новый архив окажется больше старого. Если параметр выключен, размеры архивов не учитываются.

  • Сжатие

    Кнопка "Сжатие" вызывает окно, в котором можно выбрать различные параметры для преобразованных архивов, например результирующий формат — RAR или ZIP.

  • Папка для преобразованных архивов

    Здесь можно указать папку, в которую будут помещаться преобразованные архивы. Если это поле пустое, то новые архивы будут располагаться в одной папке со старыми.

  • Удалять исходные архивы

    Этот параметр позволяет выбрать, следует ли удалять исходные архивы после удачного преобразования.

    Если исходный и новый архивы имеют один и тот же формат, а в поле "Папка для преобразованных архивов" ничего не указано, исходные архивы будут удалены вне зависимости от состояния этого параметра.

  • Пропускать зашифрованные архивы

    Если включено, то архивы, содержащие зашифрованные данные, не будут обрабатываться. Это может пригодиться, когда требуется выполнить преобразование без участия пользователя, чтобы избежать запросы паролей. Однако если известно, что во всех зашифрованных архивах используется один и тот же пароль, этот параметр можно выключить и установить пароль по умолчанию в меню "Файл" перед вызовом команды преобразования.

    Кнопка "Сохранить"

    Эта кнопка сохраняет состояние всех управляющих элементов окна за исключением списка "Архивы для преобразования", чтобы при следующем вызове этого окна все настройки были восстановлены. Вы можете использовать эту функцию для сохранения своих привычных параметров преобразования.

    Примечания

    * WinRAR сохраняет новый архив только в том случае, если он был успешно создан и протестирован, а общий объём несжатых файлов в нём равен общему объёму несжатых файлов в исходном архиве.

    * WinRAR старается по возможности сохранять комментарии архивов. Однако если пользователь указал свой комментарий в окне, вызываемом кнопкой "Сжатие", это будет иметь более высокий приоритет. Комментарии файлов не преобразовываются. Другая содержащаяся в архивах информация (например потоки NTFS и сведения о файловых правах) может либо преобразовываться, либо нет – это зависит от параметров сжатия и формата архива.

    * Перед преобразованием WinRAR распаковывает исходные архивы во временную папку, поэтому необходимо обеспечить, чтобы в этой папке был достаточный объём свободного места.

    * WinRAR может отказаться преобразовывать архивы, содержащие такие особые данные, как ссылки или версии файлов.


Команда "Восстановить архив"

Эта команда доступна как в режиме управления файлами, так и в режиме управления архивами. При этом считается, что выделенные файлы или открытый архив — это повреждённые архивы, и предпринимается попытка их восстановить. Для выполнения этой команды можно воспользоваться меню "Операции", кнопкой "Исправить" на панели инструментов или комбинацией клавиш <Alt+R>.

WinRAR умеет восстанавливать только архивы RAR и ZIP. Тип архива программа пытается определить автоматически по данным в файле архива и по его расширению, но можно указать тип архива и принудительно.

Исходный архив не изменяется. Полученный в результате выполнения операции восстановленный архив будет записан под именем fixed.arcname.rar или rebuilt.arcname.rar, где "arcname" – имя исходного архива.

Успех восстановления зависит от типа архива, а также от типа и размера повреждённой области. Шансы на удачное восстановление архива RAR значительно выше, если в нём есть данные для восстановления. Если архив не содержит таких данных, это снижает шансы на успешную починку непрерывных архивов, а архивы с зашифрованными именами файлов восстановлению не подлежат.

Технические детали восстановления архива описаны в разделе, посвящённом команде R, которая является эквивалентом командной строки для команды "Восстановить архив".

Эквивалент командной строки: команда "R"


Команда "Преобразовать архив в SFX"

Эта команда доступна как в режиме управления файлами, так и в режиме управления архивами. Она преобразовывает архив в самораспаковывающийся (SFX). Если WinRAR находится внутри архива, никакие файлы выделять не нужно, просто воспользуйтесь командой "Преобразовать архив в SFX" в меню "Операции", кнопкой "SFX" на панели инструментов или комбинацией клавиш <Alt+X> и выберите в появившемся списке нужный SFX-модуль. Если же вы находитесь в режиме управления файлами вне архива, сначала выделите те файлы и папки, среди которых будет выполняться поиск архивов для преобразования в SFX.

Если архив уже является самораспаковывающимся, то из него можно удалить SFX-модуль. В этом случае WinRAR не изменяет исходный архив, а создаёт новый с тем же содержимым, но без модуля самораспаковки.

Если выбран SFX-модуль с графическим интерфейсом (он предлагается по умолчанию), то можно также нажать кнопку "Дополнительные параметры SFX", чтобы указать ряд дополнительных параметров SFX-модуля, например пути распаковки по умолчанию, заголовок и текст окна. Подробности об этом см. в разделе "Дополнительные параметры SFX".

В следующих разделах содержится информация об SFX-модулях, входящих в комплект поставки WinRAR:

Графические SFX-модули RAR и ZIP (Default.SFX и Zip.SFX)

Консольный SFX-модуль RAR (WinCon.SFX)

Эквивалент командной строки: команда "S"


Команда "Найти файлы"

Эта команда доступна как в режиме управления файлами, так и в режиме управления архивами. С помощью окна "Поиск файлов" можно искать файлы, содержащие указанную строку, либо в открытом архиве, либо в выделенных папках или дисках. Ниже приведено описание элементов окна.

  • Искомые имена файлов

    По умолчанию в этом поле указана звёздочка ( * ), т.е. будут просматриваться все файлы. При желании можно ввести здесь другую маску файлов, например чтобы выполнить поиск только в TXT-файлах, введите "*.txt". Допускается указывать несколько масок файлов, разделяя их пробелами. Если требуется указать имя файла, содержащее пробелы, его нужно заключить в кавычки.

  • Искомая строка

    Здесь указывается строка для поиска. Если оставить это поле пустым, WinRAR покажет все файлы, удовлетворяющие выбранным критериям.

  • Учитывать регистр букв

    Включите этот параметр, если хотите, чтобы при сравнении строк учитывался регистр букв (прописные/строчные).

  • Использовать все таблицы

    Если включить этот параметр, то при поиске строки будут использоваться таблицы символов ANSI, Юникода и OEM (MS-DOS). Если же параметр выключен, WinRAR при поиске использует только стандартную таблицу символов Windows (ANSI).

  • Шестнадцатеричный поиск

    Если параметр включён, введённая строка будет рассматриваться программой как последовательность шестнадцатеричных значений, разделённых пробелами.

  • Диски и папки

    Это поле содержит список дисков, папок или архивов, в которых нужно выполнить поиск. Кроме того, можно выбрать из выпадающего списка предопределённые значения <Текущая папка>, <Локальные жёсткие диски>, а также отдельные диски.

  • Типы архивов

    Типы архивов, в которых нужно выполнить поиск. По умолчанию в этом поле указана звёздочка ( * ), что означает все поддерживаемые архивные форматы, однако если вы хотите найти данные только в архивах RAR, то укажите "*.rar". Допускается указывать несколько масок архивов, разделяя их пробелами. По техническим причинам WinRAR не выполняет поиск текста в архивах ACE; для остальных форматов, поддерживаемых WinRAR, этого ограничения нет.

  • Поиск во вложенных папках

    Этот параметр заставляет WinRAR выполнять поиск не только в указанной папке, но и в её вложенных папках.

  • Поиск в файлах

    Если включён этот параметр, WinRAR будет также искать данные в обычных (не архивированных) файлах в соответствии с указанным именем файла.

  • Поиск в архивах

    Этот параметр включает поиск в архивных файлах. Чтобы найти нужную строку в архивах и обычных файлах, включите оба параметра — "Поиск в файлах" и "Поиск в архивах".

  • Пропускать зашифрованные

    Если для поиска внутри зашифрованного архива требуется ввод пароля, такой архив пропускается без вывода сообщения.

  • Кнопка "Сохранить"

    Эта кнопка сохраняет текущее состояние окна, чтобы оно было автоматически восстановлено при следующем вызове.

    • Эквивалент командной строки: команда "i"


Команда "Информация об архиве"

Команда "Информация"

Эта команда доступна как в режиме управления файлами, так и в режиме управления архивами. Просто воспользуйтесь командой "Показать информацию" в меню "Операции", кнопкой "Информация" на панели инструментов или комбинацией клавиш <Alt+I>.

В режиме управления файлами эта команда позволяет получать информацию о содержимом выбранных файлов и папок: общий объём, количество файлов и вложенных папок, количество архивов. Для ускорения операции архивы определяются только по расширениям имён файлов, поэтому самораспаковывающиеся архивы в подсчёте не участвуют. Сканирование файлов может занимать достаточно продолжительное время, однако при желании можно в любой момент закрыть окно.

Занимаемое файлами место на диске определяется блоками фиксированного размера, называемыми кластерами. Например, если размер кластера равен 4096 байтам, а размер файла — всего 1 байт, то такой файл в действительности займёт на диске 4096 байт. Поэтому чтобы дать пользователю возможность оценить, как много места занимают файлы на самом деле и сколько дискового пространства можно сэкономить после их архивирования, в информационном окне помимо прочего отображается размер кластера для текущего диска, истинный объём, занимаемый выделенными файлами с учётом неиспользованных остатков кластеров, а также общий объём потерь на остатках кластеров.

По завершении сканирования файлов можно нажать кнопку "Оценить", чтобы получить прогноз о возможной степени и предполагаемом времени сжатия выбранных файлов. Прогноз выполняется для метода сжатия "Максимальный", при этом предполагается, что диск быстрый и время, затрачиваемое на обмен данными с диском, мало. Оценка очень быстра и весьма приблизительна, поэтому не нужно ожидать здесь точного результата. Впрочем, этой информации обычно достаточно, чтобы понять, имеет ли смысл вообще тратить время на упаковку выбранных данных. Если до того, как закрыть это окно, вы включили параметр "Оценивать автоматически", то при следующем вызове этого окна подсчёт начнётся автоматически, без нажатия кнопки "Оценить".

Кроме того, после выполнения сканирования можно перейти на другие страницы этого окна и указать ряд параметров архивов, например комментарий, размер данных для восстановления, модуль SFX и т.д. Таким образом, имеется возможность применить все необходимые изменения ко всем RAR- и ZIP-архивам, содержащимся среди выбранных папок и файлов. В отличие от процедуры сканирования, здесь также обрабатываются и самораспаковывающиеся архивы. Будьте осторожны при использовании этой операции: она способна изменить параметры сразу сотен и тысяч архивов! Как и любая другая мощная функция, она может оказаться достаточно опасной при неправильном употреблении.

Если команда "Информация" вызывается, когда WinRAR находится внутри архива или вне его, но в списке файлов при этом выделен всего один архив, то выводится следующая информация об этом архиве:

· имя архива (в заголовке окна);

· тип архива (непрерывный, SFX, многотомный) и формат (RAR, ZIP, CAB, ARJ, LZH или др.). Все эти параметры объединены в одной строке вверху окна.
Для томов RAR, созданных с помощью WinRAR версии 3.40 или новее, эта строка также содержит номер тома. Данный номер может пригодиться в случае, когда утеряны исходные имена томов, и их требуется правильно восстановить вручную;

· минимальная версия архиватора, необходимая для извлечения файлов. Для некоторых архивных форматов (например ZIPX) в этом поле может быть также указано название алгоритма сжатия;

· операционная система, в среде которой был создан архив;

· общее количество файлов;

· общий размер несжатых и сжатых файлов;

· общая степень сжатия;

· размер модуля самораспаковки или 0 (ноль) для обычных архивов;

· наличие архивного комментария;

· наличие зашифрованных файлов;

· наличие блокировки архива;

· максимальный размер последовательно повреждённых данных, которые ещё можно восстановить с помощью данных для восстановления (если они имеются в архиве);

· максимальный размер словаря, использованный для упаковки файлов в архиве.

Если в архиве имеется главный комментарий, он отображается на соответствующей вкладке окна.

Как и в режиме управления файлами, для текущего архива также допускается переходить на другие страницы этого окна и указывать различные параметры. Чтобы получить более подробные сведения об элементах на других страницах, просто нажмите там кнопку "Справка".


Команда "Создать отчёт"

Эта команда применима в обоих режимах WinRAR: как вне, так и внутри архивов.

В режиме управления архивами данная команда создаёт отчёт, содержащий полный список файлов в текущем открытом архиве. Выделение файлов при этом игнорируется.

В режиме управления файлами отчёт содержит информацию только о выбранных элементах. В зависимости от указанных параметров, в отчёт могут быть помещены сведения как об обычных файлах, так и о содержимом архивов, если таковые имеются среди выбранных элементов. Если выделить папку, WinRAR обработает имеющиеся в ней файлы, а также вложенные папки.

Стиль отчёта можно изменять с помощью следующих параметров:

  • Сохранить отчёт в файле

    Здесь можно указать имя файла для сохранения отчёта. Если вы не хотите сохранять отчёт в файле, оставьте это поле пустым.

  • Распечатать отчёт

    Включите этот параметр, если хотите отправить отчёт на принтер.

  • Скопировать отчёт в буфер обмена

    Включите этот параметр, чтобы скопировать отчёт в буфер обмена. Поскольку для сохранения данных в буфере обмена требуется определённое количество памяти, применяйте этот параметр осмотрительно, особенно если предполагается создание многомегабайтного отчёта. Это может потребовать слишком много памяти и замедлить скорость операции.

  • Формат вывода (HTML, текст в Юникоде, текст)

    Выберите формат вывода для файла отчёта. Форматы HTML и Текст в Юникоде поддерживают Юникод, поэтому не-английские символы в именах файлов и архивов будут отображаться правильно. Формат Текст несовместим с Юникодом и потому может повредить не-английские символы.

  • Тип сортировки файлов (без сортировки, по имени, по размеру, по размеру в архиве, по времени изменения, по контрольной сумме)

    Здесь можно указать режим сортировки или выбрать значение "без сортировки", чтобы помещать сведения в отчёт в их исходном порядке.

  • Сортировать архивы отдельно

    Если включён этот параметр, содержимое каждого включённого в отчёт архива будет сортироваться отдельно от других архивов и файлов, т.е. все файлы каждого архива будут помещаться в отдельные группы. В противном случае все помещённые в архив сведения о файлах будут отсортированы как единый поток без учёта границ архивов. Данный параметр не влияет на исходный порядок режима сортировки.

    Элементы для добавления в отчёт

  • Содержимое архивов

    Этот параметр доступен только в режиме управления файлами. Если параметр включён, WinRAR анализирует все файлы, и если среди них обнаруживается архив, то в отчёт помещается его содержимое. В том случае, когда требуется получить лишь список обычных файлов на диске без содержимого архивов, выключите данный параметр, чтобы ускорить операцию.

  • Обычные файлы

    Этот параметр доступен только в режиме управления файлами. Если параметр включён, WinRAR помещает в отчёт сведения об обычных файлах. Если вам нужен отчёт, содержащий сведения только об архивных файлах, данный параметр следует выключить.

  • Имена архивов

    Если включено, в отчёт будет добавляться имя архива перед каждой группой файлов, содержащихся в этом архиве. Как правило, данный параметр всегда следует оставлять включённым, выключая лишь в особых случаях, например когда требуется передать отчёт внешней программе.

  • Сводная информация

    Если включено, WinRAR будет помещать в конец отчёта информацию об общем количестве и размере файлов. При выбранном параметре "Обычные файлы" в общую информацию включаются сведения, относящиеся только к обычным файлам, в противном случае будут присутствовать сведения только об архивных файлах. Подсчёт и обычных, и архивных файлов вместе невозможен. Если файлы разделены между томами, общая информация подсчитывается для тех из них, которые начинаются с текущего тома. Это сделано во избежание многократного подсчёта разделённых файлов при обработке группы томов.

  • Размеры файлов

    Если включено, в отчёт будут помещаться сведения о размерах несжатых файлов.

  • Размеры сжатых файлов

    Если включено, в отчёт будут помещаться сведения о размерах сжатых файлов. Для обычных файлов значения могут отличаться от размеров несжатых файлов только на дисках с файловой системой NTFS и только тогда, когда файл имеет атрибут "Сжатый".

  • Даты файлов

    Помещать в отчёт даты модификации файлов. Вне зависимости от системных региональных установок, даты всегда указываются в формате: ГГГГ-ММ-ДД чч:мм.

  • Контрольные суммы файлов

    Помещать в отчёт контрольные суммы файлов. Этот параметр работает как с файлами в архиве, так и с обычными файлами. Тип контрольной суммы для файлов в архиве зависит от формата архива и от настроек, а для обычных файлов всегда применяется CRC32. Использование параметра с обычными файлами может значительно замедлить операцию, поскольку в этом случае WinRAR придётся считывать данные файлов и вычислять CRC32 для каждого обработанного файла. Обычно архивы уже содержат ранее вычисленные контрольные суммы, поэтому для файлов в архивах этот параметр никаких задержек не вызывает.

Кнопка "Сохранить"

Эта кнопка позволяет запомнить все значения параметров окна, за исключением имени файла отчёта. WinRAR сохраняет для данной команды два набора принимаемых по умолчанию значений: один для режима управления архивами, другой для режима управления файлами.


Команда "Тест быстродействия"

Команда "Тест быстродействия" позволяет сравнивать производительность алгоритма сжатия RAR на разных компьютерах.

Эта команда генерирует случайные данные, вызывающие повышенную нагрузку на процессор и память. Затем данные сжимаются и распаковываются по алгоритму RAR, после чего результат распаковки сравнивается с исходными данными. Если обнаруживается какое-либо различие, в окне команды в строке "Ошибки" выводится сообщение "Да". Такие ошибки могут свидетельствовать о наличии проблем с аппаратурой, например о нестабильной работе памяти. Кроме того, WinRAR отображает объём обработанных данных и скорость сжатия, текущую и результирующую, измеряемую в КБ/с. Значение результирующей скорости можно использовать для сравнения производительности RAR в различных условиях. Например, это может пригодиться при выборе нового компьютера, чтобы узнать, какой из них быстрее сжимает данные. Используется только общий алгоритм компрессии в режиме "максимальное сжатие" со словарём объёмом 4096 КБ, все дополнительные фильтры и алгоритмы отключаются, т.е. измеряется производительность основного алгоритма сжатия RAR на произвольном наборе данных.

С помощью параметра "Многопоточность" можно сравнить производительность обычной однопоточной и многопоточной (оптимизированной для мультипроцессорных архитектур) версий алгоритма сжатия RAR. В зависимости от результатов, многопоточность можно включить или отключить в окне общих настроек.

Для заполнения словаря упаковки, который в начале операции пуст, требуется некоторое время. Пока он не будет заполнен, значение скорости непостоянно, поэтому текущая скорость начинает отображаться лишь через несколько секунд после вызова команды. Результирующая скорость выводится только после сбора статистики, необходимой для получения точного результата. После того как результирующая скорость установлена, она больше не изменяется. Несмотря на то что исходные данные случайны, степень их избыточности и другие параметры всегда остаются одинаковыми, поэтому команда выдаёт практически постоянную текущую скорость вне зависимости от длительности выполнения при условии, что загрузка системы не изменяется.

Учтите, что разные версии WinRAR могут показывать разные скорости сжатия, поэтому если вы используете эту команду для сравнения производительности различных компьютеров, проследите, чтобы во всех тестах участвовала одна и та же версия WinRAR. Кроме того, прежде чем приступать к тестированию, рекомендуется закрыть все остальные запущенные приложения.

Команда "Тест быстродействия" не имеет автоматического завершения, вы должны прекратить её работу самостоятельно. Она не использует жёсткий диск, все операции выполняются в оперативной памяти.


Меню "Файл"

Команда | Клавиша | Функция
Открыть архив | Ctrl+O | Открыть указанный архив (это можно сделать и другими способами).
Выбрать диск | Ctrl+D | Изменить текущий диск.
Установить пароль по умолчанию | Ctrl+P | Установить пароль, используемый по умолчанию. Для подтверждения правильности пароль необходимо ввести дважды. Этот пароль будет использован для всех операций архивации.
Скопировать файлы в буфер обмена | Ctrl+C | Скопировать файлы (находящиеся в архиве или обычные) в буфер обмена Windows. Например, можно выделить файлы в архиве, нажать <Ctrl+C>, открыть папку в Проводнике и нажать <Ctrl+V>, чтобы распаковать в неё эти файлы. Вы можете нажать <Ctrl+V> в текстовом редакторе, чтобы вставить только имена файлов, а не их содержимое.
Вставить файлы из буфера обмена | Ctrl+V | Вставка файлов в WinRAR вызывает операцию архивирования, т.е. можно выделить файлы в Проводнике и вставить их в WinRAR, чтобы заархивировать эти файлы.
Скопировать полные имена в буфер обмена |  | Скопировать в буфер обмена только полные имена выбранных файлов или папок, но не содержимое файлов.
Выделить все | Ctrl+A | Выделить все файлы и папки.
Выделить группу | + (на цифровой клавиатуре) | Выделить все файлы и папки, соответствующие введённому шаблону.
Снять выделение | – (на цифровой клавиатуре) | Снять выделение со всех файлов и папок, соответствующих введённому шаблону.
Инвертировать выделение | * (на цифровой клавиатуре) | Инвертировать выделение всех файлов и папок.
Выход | Alt+F4, Ctrl+W | Завершить работу WinRAR.

В зависимости от состояния параметра "Вести историю архивов" в окне Общих параметров, ниже команды "Выход" могут находиться имена недавно открывавшихся файлов. Их можно использовать для быстрого открытия этих архивов.


Меню "Команды"

Функция | Клавиша
Добавить файлы в архив | Alt+A
Извлечь в указанную папку | Alt+E
Протестировать файлы в архиве | Alt+T
Просмотреть файл | Alt+V
Удалить файлы | Del, Shift+Del
Переименовать файл | F2
Печать файла | Ctrl+I
Извлечь без подтверждения | Alt+W
Добавить комментарий архива | Alt+M
Добавить данные для восстановления | Alt+P
Заблокировать архив | Alt+L


Меню "Операции"

Функция | Клавиша
Мастер |
Проверить архив(ы) на вирусы | Alt+D
Преобразовать архив(ы) | Alt+Q
Восстановить архив(ы) | Alt+R
Преобразовать архив(ы) в SFX | Alt+X
Найти файлы | F3
Показать информацию | Alt+I
Создать отчёт | Alt+G
Тест быстродействия | Alt+B


Меню "Избранное"

Меню "Избранное" содержит список ваших избранных папок и архивов. Чтобы добавить в этот список открытый в настоящий момент архив или папку, воспользуйтесь командой "Добавить к избранному" или комбинацией клавиш <Ctrl+F>. При желании к элементам списка можно добавлять необязательные комментарии. Если комментарий присутствует, WinRAR будет отображать в меню именно его, а если нет, то имя архива или папки.

При выборе архива или папки из этого списка они будут открыты в окне WinRAR. Обратите внимание, что вы можете открыть первые десять пунктов из этого меню с помощью комбинаций клавиш <Ctrl+1> ... <Ctrl+0>. Нажатие <Ctrl+1> активизирует первый избранный элемент, <Ctrl+2> — второй, …, <Ctrl+9> — девятый, <Ctrl+0> — десятый.

Команда "Упорядочить избранное" позволяет редактировать или удалять пункты этого меню, а также перемещать их выше или ниже по списку. Выберите нужный пункт и нажмите соответствующую кнопку для выполнения необходимого действия. Чтобы удалить один из пунктов, можно нажать кнопку "Удалить" или воспользоваться клавишей <Del>.


Меню "Параметры"

Команда "Установки…" этого меню вызывает окно со следующими вкладками: Общие, Архивация, Пути, Список файлов, Просмотр, Безопасность и Интеграция. Выберите любую из этих ссылок для получения подробной информации. Окно "Установки…" также можно вызвать комбинацией клавиш <Ctrl+S>.

С помощью двух соответствующих команд в подменю "Импорт/Экспорт" можно экспортировать параметры WinRAR и импортировать их потом для восстановления ранее сохранённой конфигурации. Имя файла – Settings.reg, по умолчанию он находится в папке %APPDATA%\WinRAR, но вы можете указать для него другую папку в окнах сохранения или загрузки параметров WinRAR. Восстановление параметров из файла может существенно сократить время, необходимое для настройки WinRAR при переустановке Windows или переносе WinRAR на другой компьютер. Если во время запуска WinRAR не может найти свои параметры в реестре, а в папке WinRAR или %APPDATA%\WinRAR находится файл Settings.reg, то он будет импортирован автоматически. Чтобы некоторые из импортированных параметров вступили в силу, может потребоваться перезапуск WinRAR. Эти команды недоступны, если для сохранения установок используется файл WinRAR.ini.

Команда "Создать файл WinRAR.ini" в подменю "Импорт/экспорт" создаёт новый файл WinRAR.ini и копирует в него из реестра имеющиеся установки WinRAR.

Подменю "Список файлов" содержит две группы параметров. Команда "Одноуровневый вид папок" (быстрый вызов: Ctrl+H) переключает стиль отображения содержимого архива между обычным классическим и "одноуровневым", при котором все находящиеся в архиве файлы и папки выводятся в одном списке (словно все они расположены в одной корневой папке). Данная функция работает только в режиме управления архивами. Две другие команды в этом подменю, "Список" и "Таблица", влияют на вид списка файлов. В режиме "Список" включается многоколоночный режим, при котором показываются только имена файлов, а в режиме "Таблица" выводится более подробная информация о файлах, включая их размеры и другие параметры.

Подменю "Дерево папок" позволяет включать/выключать вывод панели с деревом папок. Вывод панели можно настроить отдельно для режима управления файлами (пункт меню "Показывать папки на дисках") и для режима управления архивами (пункт "Показывать папки в архивах"). Ещё один способ включать/выключать вывод панели с деревом папок – использовать горячую клавишу <Ctrl+T>. Дерево папок удобно для быстрой навигации по папкам на дисках или в архивах. Ширину панели с деревом можно изменять, перетаскивая мышью её правую границу.

Подменю "Темы" содержит список доступных WinRAR интерфейсных тем, команду "Упорядочить темы…" для манипулирования темами, а также команду "Загрузить дополнительные темы…" для загрузки тем с web-сайта.

Подменю "Кодировка имён" позволяет указывать кодировку для имён файлов в архиве.

Ещё одна команда в этом меню — "Просмотр журнала…". При её выполнении во встроенном средстве просмотра открывается файл rar.log, который находится в папке %APPDATA%\WinRAR. Обратите внимание, что запись ошибок журнал WinRAR ведёт только в случае, если включён параметр "Записывать журнал ошибок" в окне общих установок.

Для очистки журнала используйте команду "Очистить журнал", также присутствующую в этом меню.

Запись ошибок в журнал доступна только в зарегистрированной версии RAR.


Меню "Справка"

Выберите команду "Содержание" для вывода оглавления справки WinRAR.

Если у вас есть доступ в Интернет, то с помощью пункта "Web-страница WinRAR" вы можете посетить домашнюю страницу WinRAR в Интернете, где всегда доступна самая свежая версия WinRAR. Там же предоставляется возможность зарегистрировать вашу копию программы.

Пункт меню "О программе…" вызывает окно с информацией о версии и авторских правах на программу WinRAR.


Как открыть архив в среде Windows

Если при установке WinRAR вы не выключали параметр, отвечающий за ассоциацию WinRAR с архивами, то открыть архив в Проводнике или на рабочем столе с помощью WinRAR очень просто — нужно лишь дважды щёлкнуть мышью на значке архива.

Связать WinRAR с архивами можно и после установки с помощью окна параметров интеграции.


Использование контекстных меню

Если при установке WinRAR вы не выключали параметр "Встроить WinRAR в оболочку", то в обычные контекстные меню папок и файлов, вызываемые щелчком на них правой кнопкой мыши в Проводнике или на рабочем столе, будут добавлены несколько дополнительных пунктов.

Для архивов WinRAR добавляются элементы "Извлечь файлы...", "Извлечь в <имя папки>" и "Извлечь в текущую папку". Все эти команды вызывают WinRAR для извлечения содержимого архива, но первая команда позволяет ввести имя папки для распаковки и некоторые параметры извлечения в окне указания пути и параметров извлечения, вторая извлекает файлы из архива в предложенную папку, а третья — в текущую папку без дополнительных запросов. При распаковке группы архивов контекстное меню также содержит пункт "Извлечь каждый архив в отдельную папку", позволяющий поместить распакованное содержимое каждого архива в отдельную папку. В 64-разрядной версии Windows эта функция не поддерживается.

WinRAR также изменяет в контекстном меню архивов пункт "Свойства", дополняя его вкладкой для отображения информации об архиве и комментария архива, если он есть. Информация об архиве аналогична той, которая выводится командой "Информация".

В контекстные меню обычных файлов и папок WinRAR помещает пункты "Добавить в архив...", "Добавить в архив <имя архива>", "Добавить в архив и отправить по e-mail" и "Добавить в архив <имя архива> и отправить по e-mail", где <имя архива> заменяется действительным именем архива. Обе команды "Добавить…" вызывают WinRAR для добавления выбранных файлов в архив, но первая команда позволяет ввести имя архива и некоторые параметры архивации в окне ввода имени архива и его параметров, а вторая немедленно начинает добавлять файлы в предложенный архив без дополнительных запросов. Аналогично, обе команды "…e-mail" предназначены для упаковки выбранных файлов и прикрепления созданного архива к сообщению электронной почты, но первая команда позволяет указать дополнительные параметры, а вторая сразу начинает выполнять операцию без всяких запросов. Команды "…e-mail" работают только в том случае, если установленная почтовая программы совместима с интерфейсом MAPI (этот интерфейс поддерживают большинство современных почтовых программ).


Поддержка перетаскивания

WinRAR поддерживает применяемый в Windows-программах способ "перетаскивания" элементов (drag & drop).

Если в режиме управления файлами в окно WinRAR перетащить один архив, то WinRAR перейдёт в режим управления архивами и отобразит содержимое этого архива.

Если в режиме управления файлами перетащить в окно WinRAR один или несколько обычных файлов (не архивов), то WinRAR запросит имя архива и добавит их в этот архив.

Если в режиме управления архивами перетащить один архив на панель инструментов или адресную строку WinRAR, в окне WinRAR будет показано содержимое этого архива. Если вы хотите добавить один или несколько файлов в текущий открытый архив, их нужно перетащить в поле со списком файлов. Впрочем, если файлы не являются архивами, то при их перетаскивании на панель инструментов или адресную строку они также будут добавлены в открытый архив. Перетаскивание файлов доступно только для архивов RAR и ZIP.

Перетаскивать файлы из окна WinRAR в другие программы можно вне зависимости от текущего режима WinRAR и формата просматриваемого архива.

Если при установке вы не выключали параметр "Встроить WinRAR в оболочку", то для добавления файлов в архивы ZIP или RAR можно перетаскивать эти файлы на значок архива на рабочем столе. Кроме того, если перетащить архив с помощью правой кнопки мыши в другую папку, то в контекстном меню можно выбрать пункт "Извлечь в текущую папку" для извлечения всех папок из перетаскиваемого архива в папку назначения. Если нажать правую кнопку мыши и перетащить в папку назначения один не являющийся архивом файл или несколько файлов, то в этой папке можно создать архив, содержащий данные файлы – для этого нужно будет выбрать в контекстном меню команду "Добавить в архив..." или "Добавить в <имя архива>".


Общий синтаксис командной строки

Синтаксис командной строки

WinRAR допускает управление из командной строки.

Общий синтаксис командной строки:

WinRAR <команда> -<ключ1> -<ключN> <архив> <файлы…> <@файл-список…> <путь для извлечения\>

команда | Комбинация символов, определяющая действие, которое будет выполнять WinRAR. См. список команд.
ключ | Ключи используются для определения специфических действий, степени сжатия, типа архива и пр. См. список ключей.
архив | Имя обрабатываемого архива.
файлы | Имена обрабатываемых файлов.
файл-список | Файлы-списки — это обычные текстовые файлы, содержащие имена файлов для обработки. Каждое имя файла должно быть указано на отдельной строке и начинаться с её первой позиции. В файл-список можно помещать комментарии; признак начала комментария — символы «//» (без кавычек). Например, для архивирования файлов *.txt из папки c:\work\doc, файлов *.bmp из папки c:\work\image и всех файлов из папки c:\work\misc можно создать файл-список backup.lst, содержащий следующие строки: c:\work\doc\*.txt//резервная копия текстов c:\work\image\*.bmp//резервная копия рисунков c:\work\misc После этого для архивирования достаточно будет выполнить команду: winrar a backup @backup.lst В одной и той же командной строке разрешается указывать как обычные имена или группы файлов для обработки, так и файлы-списки. Если не указаны ни файлы, ни файлы-списки, то подразумевается шаблон *.* (т.е. будут обработаны все файлы).
путь для извлечения | Используется только с командами e и x и указывает папку, в которую нужно извлекать файлы. Если эта папка не существует, то она будет создана.

Примечания

а) Если не указаны ни файлы, ни файл-список, то подразумевается шаблон *.* (т.е. будут обработаны все файлы).

б) Если при создании архива не указано его расширение, то будет использоваться формат архива по умолчанию, выбранный в профиле архивации по умолчанию. Но если вы хотите указать тип архива явно, то это можно сделать добавлением расширения .rar или .zip к имени архива.

Если при распаковке архива не указано его расширение, то WinRAR считает, что это архив .rar, т.е. маска «*» (без кавычек) означает все архивы с расширением .rar. Если требуется обработать все архивы, не имеющие в имени расширения, то нужно использовать маску «*.» (без кавычек). Маска *.* выбирает все файлы. Символы подстановки (шаблоны) можно использовать в большинстве операций (извлечение, тестирование и др.), однако при архивировании и удалении шаблоны запрещены.

в) Ключи в командной строке имеют более высокий приоритет, чем соответствующие установки в окне конфигурации, т.е. используются параметры, заданные ключами.

г) Для команд C, E, S, T, RR, K и X в имени архива допускается использовать шаблоны, поэтому одной командой можно обработать сразу нескольких архивов. Если вместе с этими командами указать ключ -r, то поиск архивов будет выполняться и во всех вложенных папках.

д) Некоторые команды и ключи применимы только к архивам RAR, некоторые — к архивам RAR и ZIP, а некоторые — к архивам всех поддерживаемых форматов. Это зависит от возможностей, заложенных в формате архива.

е) Команды и ключи можно набирать как строчными, так и прописными буквами — они не зависят от регистра.

ж) Если какой-либо компонент командной строки содержит пробелы, то он должен быть заключён в двойные кавычки.

Примеры

  1. Добавить папку "c:\latest data" в архив Info.rar

WinRAR a Info.rar "c:\latest data"

  2. Распаковать архив Info.rar в папку d:\data

WinRAR x Info.rar d:\data\


Алфавитный список команд

A | Добавить файлы в архив
C | Добавить комментарий архива
CH | Изменить параметры архива
CV | Преобразовать архивы
CW | Сохранить комментарий архива в файле
D | Удалить из архива
E | Извлечь файлы из архива без сохранённых в архиве путей
F | Обновить файлы, имеющиеся в архиве
I | Найти строку в архивах
K | Заблокировать архив
M | Переместить в архив файлы и папки
R | Восстановить повреждённый архив
RC | Воссоздать отсутствующие тома
RN | Переименовать файлы в архиве
RR[N] | Добавить данные для восстановления
RV[N] | Создать тома для восстановления
S[имя] | Преобразовать архив в самораспаковывающийся (SFX)
S- | Удалить из архива SFX-модуль
T | Протестировать файлы в архиве
U | Обновить файлы в архиве
X | Извлечь файлы из архива с полными путями


Команда A - добавить в архив

Команда A — добавить в архив

Добавляет в архив указанные файлы и папки. Эта команда является эквивалентом командной строки команды "Добавить".

Замечание: так как модификация многотомных архивов невозможна, этой командой нельзя добавлять файлы в архивные тома, с её помощью можно их только создавать.

Примеры:

а) Добавить все файлы *.hlp из текущей папки в архив help.rar:

WinRAR a help *.hlp

б) Заархивировать все файлы из текущей и вложенных папок в самораспаковывающийся непрерывный архив, разделённый на тома save.part1.exe, save.part2.rar, save.part3.rar, … размером по 362 000 байт, и добавить к каждому тому данные для восстановления:

WinRAR a -r -v362 -s -sfx -rr save

Так как имена обрабатываемых файлов не указаны, подразумеваются все файлы (*.*).

в) Как особое исключение, если в качестве аргумента указано имя папки, и это имя не содержит файловых масок и завершающих символов обратной косой черты (\), то в архив будет добавлено всё содержимое указанной папки и её вложенных папок, даже если не указан ключ -r. Следующая команда добавит все файлы из папки Bitmaps и вложенных в неё папок в RAR-архив Pictures:

WinRAR a -r Pictures.rar Bitmaps

г) Если в имени папки содержатся файловые маски или завершающие символы обратной косой черты, то применяются обычные правила, и чтобы включить в обработку вложенные папки, необходимо указать ключ -r.

Следующая команда добавит все файлы из папки Bitmaps, но не из её вложенных папок, так как не указан ключ -r:

WinRAR a Pictures.rar Bitmaps\*


Команда C - добавить комментарий архива

Команда C — добавить комментарий архива

Эта команда позволяет добавить в архив комментарий. Максимальная длина комментария составляет 256 КБ для архивов RAR, и 32 768 байт — для архивов ZIP. Комментарии можно также добавлять с помощью команды "Добавить комментарий архива" в режиме управления архивами.

Так как изменение многотомных архивов невозможно, эта команда неприменима к томам. Для добавления комментария в тома нужно использовать ключ -z<файл> при их создании.

Примеры:

а) Добавить комментарий в архив distrib.rar:

WinRAR c distrib.rar

б) С помощью ключа -z<файл> комментарий можно добавить из файла:

WinRAR c -zinfo.txt dummy


Команда CH - изменить параметры архива

Команда CH — изменить параметры архива

Данная команда позволяет изменять параметры архива, и её можно применять с большинством ключей, служащих для модификации архивов. Это особенно удобно для таких ключей, как -cl, -cu, -tl, которые не имеют специально предназначенных для них команд.

Этой командой нельзя переупаковывать, зашифровывать или расшифровывать данные в архиве, а также объединять архивные тома или создавать их. При использовании без ключей команда 'ch' просто копирует архивные данные без их модификации.

Пример:

Установить время архива по времени новейшего файла:

WinRAR ch -tl files.rar


Команда CV - преобразовать архивы

Команда CV — преобразовать архивы

Эта команда позволяет использовать WinRAR для преобразования архивов из командной строки. Чтобы в начале операции не появлялось окно "Преобразование архивов", эту команду следует сочетать с ключом -y, в этом случае операция будет выполнена с параметрами по умолчанию. Для изменения параметров по умолчанию в окне "Преобразование архивов" имеется кнопка "Сохранить".

Пример:

Преобразовать все архивы ZIP в папке c:\files с использованием параметров преобразования по умолчанию:

WinRAR cv -y c:\files\*.zip


Команда CW - сохранить комментарий архива в файле

Команда CW — сохранить комментарий архива в файле

С помощью этой команды можно сохранять в файле комментарий архива. Формат результирующего файла зависит от ключа -sc.

Примеры:

а) Сохранить комментарий архива arc в ASCII-файл comment.txt:

WinRAR cw arc comment.txt

б) Сохранить комментарий архива arc в файл unicode.txt в кодировке Юникод:

WinRAR cw -scuc arc unicode.txt


Команда D - удалить из архива

Команда D — удалить из архива

Эта команда удаляет из архива указанные файлы и папки. Она является эквивалентом командной строки команды Удалить режима управления архивами.

Замечания:

1) Если при выполнении этой команды из архива удаляются все файлы, то пустой архив также удаляется.

2) Эта команда неприменима к томам, так как изменение многотомных архивов невозможно.

Пример: удалить из архива dummy все файлы *.dmy:

WinRAR d dummy *.dmy


Команда E - извлечь файлы без сохранённых в архиве путей

Команда E — извлечь файлы без сохранённых в архиве путей

Эта команда извлекает из архива файлы в текущую или указанную папку, игнорируя записанную в архиве информацию об их путях. Она является эквивалентом командной строки команды "Извлечь в указанную папку" режима управления архивами, с включённым параметром "Извлечение без путей" окна "Пути и параметры извлечения".

Пример:

WinRAR e *.rar *.doc

В данном примере в текущую папку будут извлечены все файлы *.doc из всех имеющихся в текущей папке архивов RAR.


Команда F - обновить имеющиеся в архиве файлы

Команда F — обновить имеющиеся в архиве файлы

Обновляет файлы в архиве только в том случае, если они там уже есть, но имеют более старую дату, чем файлы с теми же именами на диске. Эта команда не добавляет новые файлы в архив. Она является эквивалентом командной строки команды "Добавить в архив" режима управления файлами, с выбранным методом обновления "Обновить существующие файлы" окна "Пути и параметры извлечения".

Эта команда неприменима к томам, так как изменение многотомных архивов невозможно.

См. также: команда A - добавить в архив


Команда I - найти строку в архивах

Команда I[i|c |h|t]=<строка> — найти строку в архивах

Поиск строки в архивах. Поддерживаются следующие необязательные параметры:

i — не различать прописные и строчные буквы (по умолчанию)

c — различать прописные и строчные буквы

h — поиск в шестнадцатеричном режиме

t — использовать таблицы символов ANSI, Юникода и OEM

Если ни один параметр не указан, вместо синтаксиса i=< строка> можно использовать более простую команду i<строка>.

Модификатор 't' допускается применять вместе с другими параметрами, например, ict=строка выполнит чувствительный к регистру букв поиск с использованием всех вышеупомянутых таблиц символов.

Из-за технических ограничений WinRAR на данный момент не поддерживает поиск в архивах ACE.

Примеры:

1) WinRAR "ic=FirSt leVel" -r c:\*.rar *.txt

Выполнить чувствительный к регистру букв поиск строки "FirSt leVel" в файлах *.txt, находящихся в архивах *.rar на диске C:.

2) WinRAR ih=f0e0aeaeab2d83e3a9 -r e:\texts\*.rar

Найти шестнадцатеричную строку f0 e0 ae ae ab 2d 83 e3 a9 в архивах RAR, расположенных в папке e:\texts.


Команда K - заблокировать архив

Команда K — заблокировать архив

После выполнения этой команды все дальнейшие изменения обработанного архива средствами WinRAR становятся невозможны. Эта команда является эквивалентом командной строки команды "Заблокировать архив" режима управления архивами.

Пример:

WinRAR k release


Команда M - переместить в архив файлы и папки

Команда M — переместить в архив файлы и папки

Аналогична команде A, но после успешного завершения архивации файлы и папки удаляются. Эта команда является эквивалентом командной строки команды "Добавить в архив" режима управления файлами с включённым параметром "Удалять файлы после архивации" в окне "Имя и параметры архива".

Так как изменение многотомных архивов невозможно, этой командой нельзя обновлять тома архивов, с её помощью можно их только создавать.


Команда R - исправить повреждённый архив

Команда R — исправить повреждённый архив

Восстановление архива состоит из двух этапов. Сначала в повреждённом архиве ищутся данные для восстановления (см. команду rr). Если в архиве есть эти ранее добавленные данные, а повреждённая часть информации непрерывна и её размер не превышает размера кода коррекции ошибок в данных для восстановления, то шансы на успешное восстановление высоки.

По завершении этого этапа создаётся новый архив с именем fixed.имя_архива.rar, где "имя_архива" — это имя исходного (повреждённого) архива.

Если в повреждённом архиве нет данных для восстановления или архив невозможно полностью восстановить с её помощью из-за слишком серьёзных повреждений, то выполняется второй этап восстановления. Во время этого этапа реконструируется только структура архива. Файлы с неверной контрольной суммой не восстанавливаются, но становится возможным восстановить неповреждённые файлы, которые ранее были недоступны из-за повреждения структуры архива. Как правило, этот этап даёт хороший процент восстановления простых архивов, в случае непрерывного архива обычно можно восстановить только неповреждённые файлы, расположенные в начале архива. Этот этап не выполняется для архивов с зашифрованными именами файлов. Такие архивы можно исправить лишь при наличии в них данных для восстановления.

По окончании этого этапа создаётся новый архив с именем rebuilt.имя_архива.rar, где 'имя_архива' — это имя исходного архива.

Во время выполнения операции восстановления WinRAR может спросить у пользователя, нужно ли добавлять в архив найденный элемент, считая его файлом:

Подозрительный элемент <возможное имя файла>. Добавить в архив: Да/Нет/Все

Ответьте "Да", чтобы добавить этот элемент в rebuilt.имя_архива.rar.

Эта команда — эквивалент командной строки команды "Восстановить архив" режима управления файлами.

Пример:

Починить архив buggy.rar и поместить результат в папку "c:\fixed"

WinRAR r buggy.rar c:\fixed\


Команда RC - воссоздать отсутствующие/повреждённые тома

Команда RC — воссоздать отсутствующие/повреждённые тома

Эта команда воссоздаёт отсутствующие тома многотомного архива, используя тома для восстановления (файлы .rev). В качестве имени архива нужно указать любой существующий архивный том, например:

WinRAR rc backup.part03.rar

Подробности о томах для восстановления см. здесь.


Команда RN - переименовать файлы в архиве

Команда RN — переименовать файлы в архиве

Эта команда переименовывает файлы в архивах RAR и ZIP. Синтаксис команды:

WinRAR rn <архив> <исходное_имя1> <результирующее_имя1> ... <исходное_имяN> <результирующее_имяN>

Например, следующая команда:

WinRAR rn data.rar readme.txt readme.bak info.txt info.bak

служит для переименования файла readme.txt в readme.bak и файла info.txt в info.bak в архиве data.rar.

Для простых преобразований имён, например изменения расширений файлов, в качестве исходного и результирующего имён допускается использовать символы подстановки (шаблоны). Например, команда:

WinRAR rn data.rar *.txt *.bak

переименует все файлы *.txt в файлы *.bak.

При переименовании RAR не проверяет, имеется ли в архиве файл с таким же именем, как указанное результирующее, поэтому будьте осторожны во избежание появления дублирующихся имён файлов. Особенно важно быть осмотрительным при использовании шаблонов. Такая команда потенциально опасна, поскольку при неправильном указании шаблона можно испортить имена всех файлов в архиве.


Команда RR[N] - добавить данные для восстановления

Команда RR[n ] — добавить данные для восстановления

При желании в архив RAR можно добавить данные для восстановления. Это увеличивает размер архива, но способно помочь при его восстановлении, если он будет повреждён в результате сбоя носителя или другой потери информации при условии, что повреждение не будет слишком серьёзным. Восстановление таких повреждений выполняется командой "r". Архивы ZIP данные для восстановления не поддерживают.

В архивах RAR 4.x и RAR 5.0 структура и алгоритмы данных для восстановления разные.

В RAR 4.x данные для восстановления основаны на алгоритме XOR. Их размер в версии 4.x можно указывать как число секторов для восстановления или как процент от размера архива. Чтобы указать число секторов, просто добавьте его сразу после "rr", например, для 1000 секторов это будет "rr1000". Чтобы указать процент, добавьте после числа процентов латинскую букву "p" или знак "%", например, для 5% это будет "rr5p" или "rr5%". Обратите внимание, что при вызове из пакетных файлов Windows (.bat и .cmd) вместо "rr5%" нужно использовать "rr5%%", поскольку командный процессор воспринимает одиночный знак "%" как начало параметра пакетного файла, поэтому в данном случае может быть предпочтительнее применять "p", а не "%".

В RAR 4.x размер каждого сектора для восстановления равен 512 байтам. Если повреждённая область занимает непрерывный участок, каждый сектор способен восстановить 512 байт повреждённой информации. При многочисленных повреждениях это значение может быть меньше. Максимальное количество секторов для восстановления — 524 288.

Размер данных для восстановления в архивах версии 4.x можно приблизительно определить по формуле:

<размер архива> / 256 + <число секторов для восстановления> * 512 байт

В архивах RAR 5.0 данные для восстановления используют коды Рида-Соломона. Возможности восстановления последовательно расположенной повреждённой информации у них примерно такие же, как в архивах RAR 4.x — с их помощью можно восстанавливать информацию чуть меньшего объёма, чем размер данных для восстановления. Но эти данные значительно эффективнее, чем в RAR 4.x, если повреждённых участков много.

В данных для восстановления RAR 5.0 не используются 512-байтовые сектора, указывать размер данных можно только как процент от размера архива. В формате RAR 5.0 даже если не указан модификатор "%" или "p", RAR считает значение как процент, поэтому и "rr5", и "rr5p" означают 5%. Из-за накладных расходов на хранение служебных данных действительный результирующий размер данных для восстановления лишь приблизительно совпадает с процентом, указываемым пользователем, особенно заметной разница может быть на маленьких архивах.

Размер данных для восстановления в RAR 5.0 не может превышать размера защищаемого архива, поэтому более 100% указывать нельзя. Чем больше данные для восстановления, тем медленнее они обрабатываются — как при их создании, так и при восстановлении информации.

Данные для восстановления версий 4.x и 5.0 наиболее эффективны, если вся информация в повреждённом архиве находится на своих исходных позициях, т.е. никуда не смещена. Если для копирования архива с повреждённого носителя вы используете какую-то особую программу, и она предлагает выбор — заполнять повреждённые участки нулями (или какими-либо другими данными) или вырезать их из копируемого файла, лучше выбрать заполнение нулями, чтобы были сохранены исходные позиции данных. Тем не менее, даже в неоптимальном режиме, когда информация в результате вставки или удаления смещена на разумную величину, данные для восстановления обеих версий всё равно пытаются восстановить повреждения. Данные для восстановления RAR 5.0 справляются с удалениями и вставками значительно лучше, чем в версии RAR 4.x.

Если команда "rr" используется без факультативного параметра, WinRAR по умолчанию устанавливает размер данных для восстановления равным 3% от размера архива.

Эта команда — эквивалент командной строки команды "Добавить данные для восстановления" в режиме управления архивами.

Примеры:

а) добавить данные для восстановления стандартного объёма в архив backup:

WinRAR rr backup

б) добавить в архив pictures данные для восстановления размером 5% от его общего объёма:

WinRAR rr5p pictures


Команда RV[N] - создать тома для восстановления

Команда RV[n ] — создать тома для восстановления

Эта команда создаёт тома для восстановления (файлы .rev), которые впоследствии можно использовать для воссоздания недостающих файлов в наборе томов многотомного архива.

Использование данной команды имеет смысл только для многотомных архивов RAR. В качестве имени архива нужно указывать имя первого тома в наборе. Например:

WinRAR rv3 data.part01.rar

Необязательный параметр <n> указывает, как много следует создать томов для восстановления; он должен быть меньше, чем общее количество томов в многотомном RAR-архиве. Допускается добавлять к этому параметру знак процента (%) или латинскую букву "p" – в этом случае число создаваемых файлов .rev будет равно проценту от общего количества томов RAR-архива. Например:

WinRAR rv15% data.part01.rar

Подробности о томах для восстановления см. здесь.


Команда S[имя] - преобразовать архив в самораспаковывающийся (SFX)

Команда S[имя ] — преобразовать архив в самораспаковывающийся (SFX)

С помощью этой команды можно создать самораспаковывающийся (SFX) архив, для извлечения файлов из которого нужно просто запустить его как обычную программу.

SFX-архив также можно создать из первого тома многотомного архива, но при этом следует учитывать, что размер данного тома увеличится на величину, равную размеру модуля SFX. Самораспаковывающиеся тома лучше создавать с помощью команды A с ключами -v[<размер>] -sfx. В этом случае вам не придётся следить за размером первого тома: он (как и все остальные) будет иметь правильный размер.

Эта команда — эквивалент командной строки команды "Преобразовать архив в SFX" режима управления архивами.

Пример:

WinRAR s diamant

По умолчанию WinRAR использует для RAR-архивов модуль Default.sfx (он должен находиться в той же папке, что и файл WinRAR.exe), а для ZIP-архивов — модуль Zip.sfx. В команде S можно указывать имя альтернативного SFX-модуля.

Например, чтобы использовать консольный SFX-модуль WinCon.sfx, выполните:

WinRAR sWinCon.sfx myinst


Команда S- - удалить из архива SFX-модуль

Команда S- — удалить из архива SFX-модуль

Эта команда удаляет модуль самораспаковки из уже существующего самораспаковывающегося (SFX) архива.

При использовании данной команды WinRAR создаёт новый архив без SFX-модуля, не удаляя исходный SFX-архив.

Пример:

WinRAR s- rarsetup.exe


Команда T - протестировать файлы в архиве

Команда T — протестировать файлы в архиве

Команда имитирует извлечение указанных файлов с целью их проверки, ничего не записывая в выходной поток. Это эквивалент командной строки команды "Протестировать файлы" режима управления архивами.

Пример:

WinRAR t -r \*.rar

В данном примере будут протестированы все архивы *.rar на текущем диске.


Команда U - обновить файлы в архиве

Команда U — обновить файлы в архиве

Данная команда, как и команда F, обновляет только те файлы в архиве, которые имеют более старые даты, чем у добавляемых файлов. Однако в отличие от команды F, в архив при этом также добавляются файлы, которых там ещё нет.

Это эквивалент командной строки команды "Добавить в архив" с выбранным методом обновления "Добавить с обновлением файлов" окна "Пути и параметры извлечения".

Эта команда неприменима к томам, так как изменение многотомных архивов невозможно.

См. также: команда A – добавить в архив


Команда X - извлечь файлы с полными путями

Команда X — извлечь файлы с полными путями

Извлечь файлы и папки с полными путями. При этом полностью восстанавливается сохранённая в архиве структура папок. Это эквивалент командной строки команды "Извлечь в указанную папку" режима управления архивами.

Данной командой (как и командой E) можно извлечь файлы как в текущую, так и в указанную пользователем папку.

Например, команда:

WinRAR x Fonts *.ttf

извлечёт все файлы *.ttf из архива Fonts в текущую папку, а команда:

WinRAR x Fonts *.ttf NewFonts\

извлечёт все файлы *.ttf из архива Fonts в папку NewFonts.

Чтобы указать папку, в которую нужно извлечь файлы из архива, добавьте после имени папки обратную косую черту (\), как это показано в примере выше.


Алфавитный список ключей

-- | Прервать дальнейший поиск ключей в командной строке
-@[+] | Запретить [разрешить] списки файлов
-ac | Снять атрибут "Архивный" после архивации или извлечения
-ad | Добавить к целевому пути имя архива
-af<тип> | Указать формат архива
-ag[формат] | Добавить к имени архива текущие дату и время
-ai | Игнорировать файловые атрибуты
-ao | Добавить файлы с установленным атрибутом "Архивный"
-ap<путь> | Указать путь внутри архива
-as | Синхронизировать содержимое архива
-cfg- | Игнорировать профиль по умолчанию и переменную окружения
-cl | Преобразовывать имена файлов в нижний регистр
-cp<имя> | Выбрать профиль архивации
-cu | Преобразовывать имена файлов в верхний регистр
-df | Удалить файлы после архивации
-dh | Открывать совместно используемые файлы
-dr | Удалить файлы в Корзину
-ds | Не сортировать файлы при добавлении в непрерывный архив
-dw | Уничтожить (затереть) файлы после архивации
-ed | Не добавлять пустые папки
-en | Не добавлять в архив блок "Конец архива"
-ep | Исключить пути из имён
-ep1 | Исключить базовую папку из имён
-ep2 | Сохранять полные пути файлов
-ep3 | Сохранять полные пути, включая буквы дисков
-e[+]<атр> | Задать исключение или включение файлов из/в обработку по маске атрибутов
-f | Обновить имеющиеся файлы
-hp[пароль] | Шифровать и данные, и заголовки файлов
-ht[b|c] | Выбрать тип хеша [BLAKE2, CRC32] для контрольных сумм
-iadm | Запрашивать административный доступ для SFX-архива
-ibck | Запустить WinRAR как фоновый процесс в области уведомлений (системном лотке)
-ieml[.][адрес] | Отправить архив по электронной почте
-iicon<имя> | Указать значок для SFX-модуля
-iimg<имя> | Указать логотип для SFX-модуля
-ilog[имя] | Записывать журнал ошибок в файл
-inul | Не показывать сообщения об ошибках
-ioff | Выключить компьютер по завершении операции
-k | Заблокировать архив
-kb | Сохранять на диске файлы, извлечённые с ошибками
-log[формат][=имя] | Записать имена в файл с журналом
-m<n> | Метод сжатия
-ma[4|5] | Версия формата архивирования (RAR4 или RAR5)
-mc<параметры> | Дополнительные параметры сжатия
-md<n> | Размер словаря
-me[параметры] | Параметры шифрования
-ms[список] | Расширения файлов для архивирования без сжатия
-mt<потоки> | Количество потоков
-n<файл> | Дополнительный фильтр файлов, включённых в обработку
-n@<файл-список> | Прочитать дополнительные маски фильтрации из файла-списке
-oc | Устанавливать NTFS-атрибут "Сжатый"
-oh | Сохранять жёсткие ссылки как ссылки, а не как файлы
-oi[-] | Сохранять идентичные файлы как ссылки
-ol | Сохранять символические ссылки как ссылки, а не как файлы
-or | Переименовывать файлы автоматически
-os | Сохранять потоки NTFS
-ow | Сохранять/восстанавливать информацию о правах доступа к файлам
-o[+|-] | Режим перезаписи
-p[пароль] | Указать пароль шифрования архива
-qo[-|+] | Добавить информацию для быстрого открытия архива [нет|принудительно]
-r | Включить в обработку вложенные папки
-r- | Запретить обработку вложенных папок
-r0 | Обрабатывать вложенные папки в соответствии с шаблоном
-ri | Приоритет процесса и время простоя
-rr[N] | Добавить данные для восстановления
-rv[N] | Создать тома для восстановления
-s | Создать непрерывный архив
-s<N> | Создать непрерывные группы, используя счётчик файлов
-sc<кодировка>[объекты] | Указать кодировку (и объекты)
-se | Создать непрерывные группы, используя расширения файлов
-sfx[имя] | Создать самораспаковывающийся архив
-sl<размер> | Обрабатывать файлы размером меньше указанного
-sm<размер> | Обрабатывать файлы размером больше указанного
-sv | Создать независимые непрерывные тома
-sv- | Создать зависимые непрерывные тома
-s- | Запретить создание непрерывных архивов
-t | Протестировать файлы после архивации
-ta<дата> | Обрабатывать файлы, изменённые после указанной даты
-tb<дата> | Обрабатывать файлы, изменённые до указанной даты
-tk | Сохранять исходное время архива
-tl | Устанавливать время архива по времени новейшего файла
-tn<время> | Обрабатывать файлы не старее, чем указанный период времени
-to<время> | Обрабатывать файлы более старые, чем указанный период времени
-ts[m|c|a][+|-|1] | Сохранять/восстанавливать время файлов (изменения, создания, доступа)
-u | Обновить файлы
-v<n>[k|b|f|m|M|g|G] | Создать многотомный архив
-vd | Удалять содержимое сменного диска перед созданием тома
-ver[n] | Управление версиями файлов
-vn | Старая схема именования томов
-vp | Пауза перед каждым томом
-w<путь> | Задать папку для временных файлов
-x<файл> | Не обрабатывать указанный файл или папку
-x@<файл-список> | Не обрабатывать файлы, указанные в файле-списке
-y | Подразумевать ответ "Да" на все запросы
-z<файл> | Прочитать комментарий архива из файла


Ключ -- - прервать дальнейший поиск ключей в командной строке

Ключ - - — прервать дальнейший поиск ключей в командной строке

Данный ключ указывает WinRAR, что в командной строке больше нет ключей. Это может быть полезно в тех случаях, когда с символа '- ' начинается имя архива или какого-либо файла. Без ключа '- - ' подобное имя будет трактоваться как ключ.

Пример:

WinRAR a -s - - -StrangeName

Эта команда добавит все файлы из текущей папки в непрерывный архив с именем -StrangeName.


Ключ -@[+] - запретить [разрешить] списки файлов

Ключ -@[+] — запретить [разрешить] списки файлов

Если при обработке командной строки WinRAR встречает символ '@', он считает, что далее указаны списки файлов. По умолчанию, если WinRAR обнаруживает параметр '@filename', он пытается прочитать файл 'filename', считая, что в нём находится список файлов. Однако если имеется файл с именем '@filename', то RAR считает параметр '@filename' именем файла вместо того, чтобы прочитать список файлов из файла 'filename'.

Ключ -@[+] позволяет избежать такой неопределённости, чётко определив, как нужно обрабатывать параметры, начинающиеся с символа '@'.

Если указать -@, то все параметры, обнаруженные после этого ключа, будут считаться именами файлов, а не файлами-списками.

Если указать -@+, то все параметры, обнаруженные после этого ключа, будут считаться файлами-списками, а не именами файлов.

Этот ключ не влияет на обработку параметров, которые указаны в командной строке до него.

Пример

Протестировать находящийся в архиве файл '@home':

WinRAR t -@ notes.rar @home


Ключ -AC - снять атрибут "Архивный"

Ключ -AC — снять атрибут "Архивный"

Этот ключ предназначен для резервного копирования. Если он используется при архивации, то по окончании операции у всех успешно упакованных файлов будет снят атрибут "Архивный". Если ключ используется при распаковке, то атрибут "Архивный" будет снят у извлечённых файлов. На атрибуты папок этот ключ не влияет.


Ключ -AD - добавить к целевому пути имя архива

Ключ -AD — добавить к целевому пути имя архива

Данный ключ может пригодиться при распаковке группы архивов. По умолчанию WinRAR извлекает файлы из всех архивов в одну и ту же папку, если же указать этот ключ, то файлы из каждого архива будут распакованы в отдельные папки.

Пример:

RAR x -ad *.rar data\

В этом примере WinRAR при извлечении будет создавать в папке 'data' вложенные папки для каждого распаковываемого архива.


Ключ -AF<тип> - указать формат архива

Ключ -AF<тип> — указать формат архива

С помощью этого ключа можно указывать в командной строке тип архива, который будет создавать WinRAR. Параметр <тип> может принимать значения 'rar' или 'zip'.

Пример:

WinRAR a -afzip arc

Эта команда создаст архив arc.zip.

Данный ключ поддерживается только в WinRAR. Консольная версия RAR создавать архивы ZIP не может.


Ключ -AG[формат] - добавить к имени архива текущие дату и время

Ключ -AG[формат] — добавить к имени архива текущие дату и время

Добавляет к имени архива текущие дату и время при создании или обработке архива. Полезно при регулярном создании резервных копий.

По умолчанию принимается формат "YYYYMMDDHHMMSS", но его можно переопределить с помощью параметра формат этого ключа. Допускается использовать следующие символы:

Y | Год
M | Месяц
MMM | Месяц в виде строки (Jan, Feb и т.д.)
W | Номер недели (неделя начинается с понедельника)
A | День недели (1 - понедельник, 7 - воскресенье)
D | Порядковый день месяца
E | Порядковый номер дня в году
H | Часы
M | Минуты (обрабатывается как минуты, если стоит после часов)
I | Минуты (обрабатывается как минуты вне зависимости от местоположения часов)
S | Секунды
N | Номер архива (числовое значение начиная с 1) При архивировании WinRAR ищет уже существующий архив со сгенерированным именем, и если таковой обнаруживается, то увеличивает номер архива, чтобы сгенерировать уникальное имя. Форматирующий символ 'N' не поддерживается при создании томов. При операциях, не связанных с архивированием (например при извлечении), WinRAR выбирает архив с именем, предшествующим первому неиспользуемому имени, либо устанавливает N в 1, если такого архива не существует.

Каждый из указанных выше символов форматирующих строк соответствует только одному символу, добавляемому к имени архива. Например, для двухсимвольного номера недели используйте WW, а для обозначения года из четырёх цифр — YYYY.

Если строка формата начинается с символа '+', то положения строки даты и базового имени архива меняются местами, т.е. дата будет предшествовать имени архива.

Строка формата может содержать необязательный текст, заключённый в фигурные скобки '{' и '}'. Этот текст будет вставлен в имя архива.

Все остальные символы добавляются к имени архива без изменений.

Будьте осторожны с ключом -ag при обработке уже существующих архивов. В зависимости от строки формата и времени, прошедшего с момента предыдущего использования ключа -ag, имена сгенерированного и имеющегося архивов могут оказаться разными. В этом случае WinRAR вместо обработки уже существующего архива создаст новый. Можно воспользоваться ключом -log, чтобы записать в файл сгенерированное имя архива, а затем прочитать его оттуда для дальнейшей обработки.

Примеры:

а) Использовать формат по умолчанию YYYYMMDDHHMMSS:

WinRAR a -ag backup

б) Использовать формат DD-MMM-YY:

WinRAR a -agDD-MMM-YY backup

в) Использовать формат YYYYMMDDHHMM, поместив дату до 'backup':

WinRAR a -ag+YYYYMMDDHHMM backup

г) Использовать формат YYYY-WW-A с полями описания:

WinRAR a -agYYYY{год}-WW{неделя}-A{день_недели} backup

д) Использовать формат YYYYMMDD и нумерацию архива. Это позволяет генерировать уникальные имена даже в том случае, если маска формата YYYYMMDD используется несколько раз в один и тот же день:

WinRAR a -agYYYYMMDD-NN backup


Ключ -AI - игнорировать файловые атрибуты

Ключ -AI — игнорировать файловые атрибуты

При извлечении этот ключ вынуждает WinRAR не устанавливать у извлекаемых файлов атрибуты, сохранённые в архиве. Вместо этого файлам назначаются атрибуты, которые ОС присваивает по умолчанию всем вновь создаваемым файлам. Это относится к атрибутам "архивный", "системный", "скрытый" и "только чтение".

Если этот ключ указан при архивировании, то вместо действительных атрибутов сохраняются предустановленные значения, типичные для файла и папки.

При извлечении применимо только для форматов RAR и ZIP, а при архивировании – только для формата RAR.


Ключ -AO - добавить файлы с установленным атрибутом "Архивный"

Ключ -AO — добавить файлы с установленным атрибутом "Архивный"

Этот ключ предназначен для резервного копирования. Если указать его при архивации, то в архив будут добавлены только файлы с установленным атрибутом "Архивный". Ключ не влияет на папки, поэтому все подходящие папки добавляются вне зависимости от их атрибутов. Если нужно исключить все записи о папках, используйте ключ -ed в командной строке.

Пример:

WinRAR a -r -ac -ao f:backup c:\*.*

В данном примере в архив f:backup добавляются все файлы с диска C:, имеющие атрибут "Архивный", после чего со всех добавленных файлов этот атрибут будет снят.


Ключ -AP<путь> - указать путь внутри архива

Ключ -AP<путь> — указать путь внутри архива

Определённый с помощью этого ключа путь добавляется к именам файлов при добавлении их в архив, и удаляется из имён, если ключ используется при извлечении файлов.

Например, если нужно добавить файл readme.txt в папку DOCS\ENG архива release, выполните:

WinRAR a -apDOCS\ENG release readme.txt

Если же вы хотите извлечь папку ENG в текущую папку, наберите:

WinRAR x -apDOCS release DOCS\ENG\*.*

Применимо только для форматов RAR и ZIP.


Ключ -AS - синхронизировать содержимое архива

Ключ -AS — синхронизировать содержимое архива

Если этот ключ используется при архивации, то файлы, которых нет среди добавляемых, будут удалены из архива. Этот ключ удобно использовать совместно с ключом -u для синхронизации содержимого архива и архивируемой папки.

Например, после команды:

WinRAR a -u -as backup sources\*.cpp

в архиве backup.rar останутся только файлы *.cpp из папки sources, а все остальные будут удалены. Это аналогично созданию нового архива, но за одним важным исключением: если после прошлой архивации файлы не изменялись, то операция будет выполнена значительно быстрее, чем создание нового архива.


Ключ -CFG- - игнорировать профиль по умолчанию и переменную окружения

Ключ -CFG- — игнорировать профиль по умолчанию и переменную окружения

Этот ключ запрещает WinRAR использовать параметры, указанные в принимаемом по умолчанию профиле архивации, переменной окружения RAR, а также папку по умолчанию для архивов и поля "Выбирать для архивов" в окне управления паролями.


Ключ -CL - преобразовывать имена файлов в нижний регистр

Ключ -CL — преобразовывать имена файлов в нижний регистр

При использовании этого ключа имена всех файлов, извлекаемых из архива, добавляемых в архив, изменяемых или обновляемых в архиве, будут преобразованы в нижний регистр. Иногда это может пригодиться при переносе архива с регистронезависимой на регистрозависимую операционную систему, например при извлечении в среде UNIX файлов из архива, созданного в среде DOS.

Пример:

WinRAR x -cl port

Эта команда извлечёт все файлы из port.rar, преобразовав имена в нижний регистр.


Ключ -CP<имя> - выбрать профиль архивации

Ключ -CP<имя> — выбрать профиль архивации

С помощью этого ключа можно загружать установки, сохранённые в профиле архивации WinRAR. В качестве параметра ключа необходимо указать имя профиля. Если в профиле сохранены выбранные имена файлов, WinRAR будет упаковывать как файлы с этими именами, так и файлы, указанные в командной строке. Если профиль содержит имя архива, то оно и будет использоваться при архивировании – в этом случае указывать в командной строке другое имя архива не нужно.

В имени профиля учитывается регистр букв. Указывайте имя профиля точно так, как при его сохранении.

Пример:

WinRAR a "-cpMy Texts" texts *.txt

Эта команда заархивирует файлы *.txt с использованием установок из профиля архивации "My Texts".


Ключ -CU - преобразовывать имена файлов в верхний регистр

Ключ -CU — преобразовывать имена файлов в верхний регистр

При использовании этого ключа имена всех файлов, извлекаемых из архива, добавляемых в архив, изменяемых или обновляемых в архиве, будут преобразованы в ВЕРХНИЙ регистр.

Пример:

WinRAR x -cu port

Эта команда извлечёт все файлы из port.rar, преобразовав их имена в верхний регистр.


Ключ -DF - удалить файлы после архивации

Ключ -DF — удалить файлы после архивации

Перемещает файлы в архив. При использовании вместе с командой A этот ключ выполняет то же действие, что и команда M.


Ключ -DH - открывать совместно используемые файлы

Ключ -DH — открывать совместно используемые файлы

Позволяет обрабатывать файлы, открытые для записи другими программами.

Это опасный ключ, так как он разрешает архивировать те файлы, которые в тот же момент могут быть изменены другой программой. Если при этом будет нарушена внутренняя структура заархивированного файла, то программа для его обработки после распаковки такого файла может его не открыть. Используйте этот ключ очень осторожно!

Если ключ -dh не указан, то обработка совместно используемых файлов зависит от установки параметра "Открывать совместно используемые файлы" в профиле архивации по умолчанию.

Пример:

WinRAR a -dh dbf *.dbf


Ключ -DR - удалить файлы в Корзину

Ключ -DR — удалить файлы в Корзину

Удалить файлы после архивирования и поместить их в Корзину.


Ключ -DS - не сортировать файлы при добавлении в непрерывный архив

Ключ -DS — не сортировать файлы при добавлении в непрерывный архив

Использование этого ключа имеет смысл только при работе с непрерывными архивами RAR. Степень сжатия в непрерывных архивах зависит от порядка следования в них файлов. По умолчанию при добавлении файлов в непрерывный архив WinRAR сортирует их по расширению. С помощью ключа -ds вы можете запретить эту сортировку и попробовать задать более подходящий, по вашему мнению, порядок следования файлов. В общем случае, файлы с похожими данными должны находиться в архиве как можно ближе друг к другу.

Пример:

WinRAR a -s -ds tools *.com *.exe *.doc *.txt *.*

В этом примере файлы будут добавляться в следующем порядке: *.com, *.exe, *.doc, *.txt, файлы всех остальных типов.

Примечание: для указания порядка следования файлов в непрерывном архиве также можно использовать файл rarfiles.lst.


Ключ -DW - уничтожить (затереть) файлы после архивации

Ключ -DW — уничтожить (затереть) файлы после архивации

Удалить файлы после архивирования. Перед удалением файла содержащиеся в нём данные перезаписываются нулевыми байтами, чтобы нельзя было восстановить удалённые файлы, файл усекается и ему даётся временное имя.

Имейте в виду, что эта функция разработана для обычных жёстких дисков. При использовании с твердотельными накопителями (SSD) перезапись исходных данных может не работать из-за применяемой в SSD-накопителях технологии Wear Leveling (перераспределения блоков при записи) и более сложной адресации данных.


Ключ -ED - не добавлять пустые папки

Ключ -ED — не добавлять пустые папки

Этот ключ запрещает сохранять в создаваемом архиве записи папок. При распаковке таких архивов WinRAR создаст непустые папки на основе путей к содержащимся в них файлам. Информация о пустых папках будет потеряна. Также будут потеряны все атрибуты непустых папок (права доступа, потоки и пр.) за исключением их имён, поэтому данный ключ следует применять только тогда, когда вам не нужно сохранять такую информацию.

При использовании ключа -ed совместно с командой m или с ключом -df, пустые папки удаляться не будут.


Ключ -EN - не добавлять в архив блок "Конец архива"

Ключ -EN — не добавлять в архив блок "Конец архива"

Не поддерживается в архивах RAR 5.0.

По умолчанию при создании или добавлении архива WinRAR добавляет в его конец блок "Конец архива". Это позволяет безопасно пропускать такие внешние данные, как, скажем, используемая другими утилитами электронная подпись, однако в особых случаях данную функцию бывает нужно отключить. Например, если архив передаётся между двумя системами по ненадёжной линии связи, и одновременно с этим отсылающая сторона добавляет в архив новые файлы, важна гарантия того, что уже принятая часть файла не будет изменена на другом конце между сессиями передачи данных.

Этот ключ нельзя использовать с архивными томами, так как блок конца архива содержит информацию, важную для правильной обработки томов.


Ключ -EP - исключить пути из имён

Ключ -EP — исключить пути из имён

При использовании этого ключа файлы добавляются в архив без информации об их путях. Учтите, что это может привести к тому, что в одной папке архива окажутся несколько файлов с одним и тем же именем.

Если этот ключ указан при распаковке, то у извлекаемых файлов игнорируются сохранённые в архиве пути, т.е. все файлы будут созданы в одной и той же папке назначения.

Пример:

WinRAR a -r -ep bsources \*.bas

Эта команда заархивирует без путей все файлы *.bas с текущего диска.


Ключ -EP1 - исключить базовую папку из имён

Ключ -EP1 — исключить базовую папку из имён

Не сохранять в архиве/не извлекать путь, введённый в командной строке.

Примеры

  1. Добавить все файлы и папки из папки 'tmp' в архив 'test', исключив 'tmp\' из сохраняемых в архиве путей:

WinRAR a -ep1 -r test tmp\*

 Это эквивалентно командам:

cd tmp

WinRAR a -r ..\test

cd ..

  2. Извлечь соответствующие маске images\* файлы в папку dest\, удалив 'images\' из путей создаваемых файлов:

WinRAR x -ep1 data images\* dest\


Ключ -EP2 - сохранять полные пути файлов

Ключ -EP2 — сохранять полные пути файлов

Сохранять при архивировании полные пути файлов, за исключением буквы диска и идущей в начале обратной косой черты ( \ ).


Ключ -EP3 - сохранять полные пути, включая буквы дисков

Ключ -EP3 — сохранять полные пути, включая буквы дисков

При архивировании этот ключ служит для сохранения полных путей добавляемых файлов, включая букву диска. Символ признака дисков (двоеточие) заменяется символом подчёркивания ( _ ).

Если ключ -ep3 указан при распаковке архива, символы подчёркивания снова заменяются двоеточиями, а извлекаемые файлы будут созданы в их исходных папках и дисках. Если при этом также указан путь назначения, он будет проигнорирован.

Кроме того, ключ преобразовывает UNC-пути из \\server\share в __server\share при архивировании и восстанавливает их в исходный вид при извлечении.

Данный ключ полезен для резервного копирования информации с нескольких дисков в один архив. Например, команда

WinRAR a -ep3 -r backup.rar c:\ d:\ e:\

создаст резервную копию дисков C:, D: и E:, а команда

WinRAR x -ep3 backup.rar

восстановит из неё все данные с абсолютными путями.

Однако соблюдайте осторожность: ключ -ep3 следует использовать только в тех случаях, когда вы уверены, что распаковываемый архив не содержит никаких "злонамеренных" файлов. Иными словами, используйте этот ключ только с архивами, созданными лично вами или теми людьми, которым вы всецело доверяете. Причина в том, что данный ключ позволяет перезаписать любой файл в любой папке вашего компьютера, включая важные системные файлы, поэтому его следует применять только в целях резервного копирования.


Ключ -E<атр> - исключить/включить в обработку файлы с указанными атрибутами

Ключ -E[+]<атрибут> — исключить/включить в обработку файлы с указанными атрибутами

Указывает маску атрибутов файлов, которые необходимо исключить из обработки или включить в неё. Здесь <атрибут> - это число в десятичном, восьмеричном (если начинается с '0') или шестнадцатеричном (если начинается с '0x') формате.

По умолчанию, без символа '+' перед <атрибут> этот ключ служит для определения маски исключения из обработки. Так, если результат побитового И (AND) между <атрибут> и атрибутами файла ненулевой, то файл не будет обработан.

Если символ '+' присутствует, он указывает, что будет использоваться маска включения в обработку. Т.е. обрабатываться будут только те файлы, которые имеют хотя бы один из указанных в маске атрибутов.

В версии RAR для Windows при указании атрибутов вместо цифровой маски можно также использовать буквы D, S, H, A и R, обозначающие, соответственно, “папка”, “системный”, “скрытый”, “архивный” и “только для чтения”. Порядок перечисления атрибутов не имеет значения.

Ключи -e<атрибут> и -e+<атрибут> допускается использовать одновременно в одной командной строке.

Примеры:

1) Заархивировать только имена папок, но не их содержимое:

WinRAR a -r -e+d папки

2) Не упаковывать файлы с атрибутами "системный" и "скрытый":

WinRAR a -esh файлы

3) Не извлекать файлы с атрибутом "только для чтения":

WinRAR x -er файлы


Ключ -F - обновить имеющиеся файлы

Ключ -F — обновить имеющиеся файлы

Можно использовать при добавлении в архив или извлечении из него. Командная строка a -f эквивалентна команде F. Этот ключ также допускается использовать с командой M.

Если ключ -f используется вместе с командами X или E, то из архива будут извлечены только те файлы, которые уже есть на диске, но имеют более старые даты, чем соответствующие им файлы в архиве. Если файлу из архива не соответствует ни один из файлов на диске, то такой файл не будет извлечён из архива.

Эквивалентом этого ключа в режиме оболочки являются пункты "Обновить существующие файлы" в окне "Имя и параметры архива" и одноимённый параметр в окне "Путь и параметры извлечения".

Поддерживается только для форматов RAR и ZIP.


Ключ -HP[пароль] - шифровать содержимое файлов и оглавление архива

Ключ -HP[пароль] — шифровать содержимое файлов и оглавление архива

Как и ключ -p[пароль], этот ключ включает режим шифрования архива, однако при этом шифруются не только содержащиеся в файлах данные, но и другая отображаемая информация, например имена файлов. При указании этого ключа шифруются все важные области архива, включая данные файлов, имена файлов, размеры, атрибуты, комментарии и другие блоки, благодаря чему обеспечивается более высокая степень защиты.

Архив, зашифрованный с ключом -hp, без пароля невозможно не только распаковать, но даже просмотреть список содержащихся в нём файлов.

Пример:

RAR a -hpfGzq5yKw secret report.txt

Эта команда добавит файл report.txt в зашифрованный архив secret.rar с использованием пароля 'fGzq5yKw'.


Ключ -HT[B|C] - выбрать тип хеша [BLAKE2|CRC32] для контрольных сумм

Ключ -HT[B|C] — выбрать тип хеша [BLAKE2|CRC32] для контрольных сумм

В архивах RAR целостность данных определяется по контрольным суммам, вычисляемым и сохраняемым для каждого файла в архиве.

Для вычисления контрольных сумм WinRAR по умолчанию использует функцию CRC32. В архивах формата RAR 5.0 вместо CRC32 можно использовать хеш-функцию BLAKE2.

Хеш BLAKE2 выбирается ключом -htb, а функция CRC32 — ключом -htc. Так как CRC32 это алгоритм, используемый по умолчанию, указывать ключ -htc нужно только тогда, когда требуется переопределить режим -htb в конфигурации WinRAR.

Длина вывода CRC32 составляет 32 бита. Возможностей CRC32 хватает для определения большинства непреднамеренных ошибок в данных, но их недостаточно для проверки подлинности файловых данных. Иными словами, если два файла имеют одну и ту же CRC32, нет гарантии, что у этих файлов одинаковое содержимое.

Длина вывода BLAKE2 равна 256 битам. Так как это криптостойкая хеш-функция, она практически полностью гарантирует, что если у двух файлов одинаковое значение BLAKE2, содержимое этих файлов также одинаково. Кроме того, у BLAKE2 надёжнее, чем у более короткого CRC32, определение ошибок.

Поскольку вывод BLAKE2 длиннее, при указании ключа -htb результирующий архив получается чуть большего объёма.

Если заголовки архива не зашифрованы (не указан ключ -hp), контрольные суммы зашифрованных файлов RAR 5.0 изменены с помощью особого, зависящего от пароля алгоритма, чтобы по контрольным суммам нельзя было угадать содержимое файлов. Поэтому не ждите, что контрольные суммы зашифрованных файлов совпадут с обычными значениями CRC32 и BLAKE2.

Этот ключ поддерживается только для формата RAR 5.0, поэтому он должен использоваться вместе с ключом -ma.

Ключ -htb это эквивалент командной строки параметра "Использовать контрольные суммы BLAKE2" в окне "Имя и параметры архива".

Пример

Добавить все файлы *.lst в архив lists.rar, используя контрольные суммы BLAKE2:

WinRAR a -ma -htb lists.rar *.lst


Ключ -IADM - запрос административного доступа для SFX-архива

Ключ -IADM — запрос административного доступа для SFX-архива

Ключ -iadm следует применять в тех случаях, когда необходимо создать SFX-архив, который будет требовать административного доступа при запуске в среде Windows Vista или более новых версиях Windows. На поведение SFX-архива в более старых версиях Windows данный ключ не влияет.

Этот ключ – эквивалент командной строки параметра "Запрос административного доступа" в окне дополнительных параметров SFX.

Пример

WinRAR a -sfx -iadm install.exe c:\data


Ключ -IBCK - запустить WinRAR как фоновый процесс в области уведомлений

Ключ -IBCK — запустить WinRAR как фоновый процесс в области уведомлений

Минимизирует WinRAR в область уведомлений в панели задач при запуске операции обработки архива.

Этот ключ эквивалентен параметрам "Архивировать в фоновом режиме" в окне "Имя и параметры архива" и "Извлекать в фоновом режиме" в окне извлечения.


Ключ -IEML [.][адрес] - отправить архив по электронной почте

Ключ -IEML [.][адрес] — отправить архив по электронной почте

Прикрепить к сообщению e-mail архив, созданный или обновлённый командой добавления файлов. Чтобы использовать этот ключ, на вашей машине должна быть установлена клиентская почтовая программа, совместимая с интерфейсом MAPI (этот интерфейс поддерживают большинство современных почтовых программ).

Вы можете указать адрес назначения непосредственно вместе с этим ключом или же вообще его не указывать. В последнем случае адрес будет запрошен почтовой программой. Кроме того, допускается указывать несколько адресов, разделяя их запятыми или точками с запятой.

Если следом за ключом -ieml добавить точку, то после успешного прикрепления архива к сообщению электронной почты он будет удалён.

Если этот ключ используется при создании многотомного архива, каждый том прикрепляется к отдельному электронному письму.


Ключ -IICON<имя> - указать значок для SFX-архива

Ключ -IICON<имя> — указать значок для SFX-архива

Этот ключ позволяет указать значок для создаваемого или обновляемого SFX-архива. Параметр <имя> означает имя файла со значком (.ico). При этом SFX-модуль не должен быть сжат с помощью какой-либо программы упаковки исполняемых файлов (например UPX).

Данный ключ – эквивалент командной строки для параметра "Загрузить значок SFX из файла" в окне "Дополнительные параметры SFX" на вкладке "Текст и значок".

Примеры:

1) Добавить содержимое папки c:\myfiles в SFX-архив setup.exe, используя в качестве значка файл c:\myicons\ver1.ico

WinRAR a -sfx -iiconc:\myicons\ver1.ico setup.exe c:\myfiles

2) Заменить значок на c:\myicons\ver2.ico в уже существующем SFX-архиве setup.exe

WinRAR s -iiconc:\myicons\ver2.ico setup.exe


Ключ -IIMG<имя> - указать логотип для SFX-архива

Ключ -IIMG<имя> — указать логотип для SFX-архива

Данный ключ позволяет указать для создаваемого или обновляемого SFX-архива графический файл с растровым изображением, которое будет отображаться как логотип. Параметр <имя> – это имя BMP-файла. Если вы собираетесь использовать ключ -iimg, то SFX-модуль не должен быть сжат с помощью какой-либо утилиты для упаковки исполняемых файлов (UPX, ASPack, MPRESS и др.).

Данный ключ – эквивалент командной строки для параметра "Загрузить логотип для SFX из файла" в окне "Дополнительные параметры SFX" на вкладке "Текст и значок".

Размер стандартного логотипа SFX – 93×302 пиксела. Рекомендуется использовать изображения с таким же или меньшим размером.

Примеры:

Добавить содержимое папки c:\myfiles в SFX-архив setup.exe, используя в качестве SFX-логотипа файл c:\pictures\logo1.bmp

WinRAR a -sfx -iimgc:\pictures\logo1.bmp setup.exe c:\myfiles

Заменить логотип в уже имеющемся SFX-архиве setup.exe файлом logo2.bmp, хранящимся в текущей папке

WinRAR s -iimglogo2.bmp setup.exe


Ключ -ILOG[имя] - записывать журнал ошибок в файл

Ключ -ILOG[имя] — записывать журнал ошибок в файл

Записывать сообщения произошедших при работе ошибок в файл rar.log, создаваемый в папке WinRAR. Вы можете просмотреть содержимое этого файла командой "Просмотр журнала" в меню "Параметры". Вместо принимаемого по умолчанию файла rar.log вы можете указать другое имя файла, например:

-ilogc:\log\backup.log

Если в указанном имени не содержится путь, файл с журналом будет создан в папке %APPDATA%\WinRAR.

Если в общих параметрах программы включён параметр "Записывать журнал ошибок", то сообщения об ошибках будут записываться в файл rar.log даже без указания ключа -ilog.

По умолчанию файл с журналом сохраняется в кодировке UTF-16 little-endian, но с помощью ключа -sc<кодировка>g можно указать другую кодировку. Например, ключ -scag задаёт 'родную' однобайтовую кодировку.


Ключ -INUL - не показывать сообщения об ошибках

Ключ -INUL — не показывать сообщения об ошибках

При указании этого ключа WinRAR не будет показывать сообщения об ошибках.


Ключ -IOFF - по окончании операции выключить компьютер

Ключ -IOFF — по окончании операции выключить компьютер

Завершить работу компьютера по завершении операции. Для работы этой функции требуется аппаратная поддержка отключения питания.


Ключ -K - заблокировать архив

Ключ -K — заблокировать архив

Этот ключ служит для блокирования архива, чтобы впоследствии его уже нельзя было изменить средствами WinRAR. С помощью этого ключа вы можете блокировать архив сразу же при его создании или обновлении.


Ключ -KB - не удалять файлы, извлечённые с ошибками

Ключ -KB — не удалять файлы, извлечённые с ошибками

Если при извлечении файла обнаруживается, что он повреждён, то по умолчанию такой файл удаляется с диска. При использовании ключа -kb повреждённые файлы будут сохраняться на диске, что иногда позволяет извлечь из них хоть какую-то полезную информацию.


Ключ -LOG[формат][=имя] - записать имена в файл с журналом

Ключ -LOG[формат][=имя] — записать имена в файл с журналом

Этот ключ позволяет записывать имена архива и файлов в указанный текстовый файл при использовании с командами архивирования, извлечения, удаления для формата RAR, и с командами архивирования для формата ZIP. Поведение ключа определяется строкой 'формат', которая может включать один или несколько следующих символов:

A | Записать в журнал имена архивов. Если WinRAR создаёт или обрабатывает тома, то в журнал записываются все имена томов.
F | Записать в журнал имена обработанных файлов. В их число входят файлы, добавляемые в архив, извлекаемые и удаляемые из архива, а также выдаваемые командой листинга содержания архива.
P | Если журнал с указанным именем существует, не создавать новый файл, а добавлять данные в уже имеющийся.
U | Записывать данные в кодировке Юникод.

Если не указаны ни 'A', ни 'F', то подразумевается 'A'.

Параметр 'имя' позволяет указать имя файла с журналом. Имя должно быть отделено от строки 'формат' символом '=' (без кавычек). Если 'имя' не указано, WinRAR будет использовать имя rarinfo.log, принимаемое по умолчанию.

В одной и той же командной строке разрешается указывать несколько ключей -log.

Этот ключ может быть особенно полезен, когда нужно обработать архив, созданный с ключами -ag или -v в пакетном сценарии. Вы можете указать -loga=arcname.txt при создании архива, а затем прочитать сгенерированное WinRAR имя архива из файла arcname.txt с помощью соответствующей команды в пакетном файле, например: set /p name=<arcname.txt.

Все функции этого ключа поддерживаются только для формата RAR. Для формата ZIP поддерживаются только операции архивирования. Для других форматов архивов этот ключ не поддерживается.

Примеры

  1. Записать имена созданных томов в файл vollist.txt

WinRAR a -v100m -loga=vollist.txt volume.rar c:\data

  2. Записать сгенерированное имя архива в файл backup.txt в кодировке Юникод

WinRAR a -ag -logau=backup.txt backup.rar myfiles\*

  3. Записать имена протестированных томов в файл vollist.txt, а имена протестированных заархивированных файлов внутри томов - в файл filelist.txt

WinRAR t -log=vollist.txt -logf=filelist.txt volume.part01.rar


Ключ -M<n> - метод сжатия

Ключ -M<n> — метод сжатия

С помощью параметра <n> от 0 до 5 можно указать желаемый метод сжатия.

-m0 | Без сжатия | Добавить файлы в архив без сжатия
-m1 | Скоростной | Самый быстрый метод (минимальное сжатие)
-m2 | Быстрый | Быстрый метод
-m3 | Обычный | Обычный метод сжатия (по умолчанию)
-m4 | Хороший | Хороший метод сжатия (более сильное сжатие)
-m5 | Максимальный | Наилучший метод сжатия (максимальное, но самое медленное сжатие)

Если этот ключ не указан, WinRAR использует метод -m3 ("обычное" сжатие).

Метод сжатия также можно выбрать из списка "Метод сжатия" в окне "Имя и параметры архива".


Ключ -MA[4|5] - версия формата архивирования

Ключ -MA[4|5] — версия формата архивирования

По умолчанию WinRAR создаёт архивы в формате RAR 5.x. Чтобы создавать архивы RAR 4.x, используйте ключ -ma4. Ключ -ma5 или просто -ma нужен для отмены действия -ma4, сохранённого в конфигурации, и принудительного использования формата RAR 5.0.

Этот ключ применяется только при создании нового архива. При обновлении уже существующего архива он игнорируется.

Пример

Создать непрерывный архив RAR 4.x и упаковать папку SrcDir, используя словарь размером 2 МБ:

WinRAR a -ma4 -md2m data SrcDir


Ключ -MC<параметры> - дополнительные параметры сжатия

Ключ -MC<параметры> — дополнительные параметры сжатия

Этот ключ предназначен преимущественно для испытаний и экспериментов, в реальной жизни обычно лучше позволить WinRAR самому автоматически выбирать оптимальные параметры архивирования. Обратите внимание, что неправильное применение этого ключа может привести к очень существенным потерям времени и сжатия, поэтому используйте его только в том случае, если чётко понимаете, что вы делаете.

Ключ имеет следующий синтаксис:

-mc[Параметр1][:Параметр2][модуль][+ или -]

где <модуль> — односимвольное поле, указывающее часть алгоритма сжатия, который должен быть сконфигурирован. Может принимать следующие значения:

A | Сжатие аудиоданных
C | Сжатие графических данных true color (RGB)
D | Дельта-сжатие
E | Сжатие исполняемых файлов Intel x86
I | Сжатие исполняемых файлов Intel Itanium
T | Сжатие текстов

Архивный формат RAR 5.0 поддерживает только значения 'D' и 'E'.

Знак '+' в конце ключа указывает, что выбранный алгоритмический модуль должен быть использован для всех обрабатываемых данных, а знак '-' отключает этот модуль совсем. Если не указан ни плюс, ни минус, WinRAR выбирает модули автоматически в зависимости от данных и текущего метода сжатия. Ключ -mc- запрещает использование всех дополнительных модулей и позволяет применять только общий алгоритм сжатия.

<Параметр1> и <Параметр2> зависят от конкретного модуля, ниже приведено их описание.

Сжатие аудиоданных, дельта-сжатие

<Параметр1> — число байтовых каналов (может принимать значения от 1 до 31).

WinRAR разделяет многобайтовые каналы на байты, например два 16-битовых аудиоканала WinRAR считает за четыре канала по одному байту каждый.

<Параметр2> не используется.

Сжатие исполняемых файлов Intel x86, сжатие исполняемых файлов Intel Itanium, сжатие графических данных true color (RGB)

<Параметр1> и <Параметр2> не используются.

Сжатие текста

Алгоритм сжатия текста обеспечивает заметно более высокую степень упаковки простых текстовых данных. Однако поскольку этот алгоритм не может эффективно использовать многоядерные процессоры, его скорость работы ниже, чем у основного алгоритма, в системах с многоядерными ЦП и несколькими ЦП. Кроме того, скорость распаковки у этого алгоритма значительно ниже, чем у основного, вне зависимости от числа ядер процессора. Поэтому алгоритм сжатия текста по умолчанию отключён. Если вы хотите, чтобы WinRAR автоматически использовал этот алгоритм при упаковке соответствующих данных, укажите ключ -mct. Ключ -mct+ принудительно включает текстовое сжатие для всех данных.

Ключ -mct может также содержать <Параметр1> и <Параметр2>, поэтому его полный синтаксис следующий: -mc[Параметр1][:Параметр2]t[+ или -].

<Параметр1> — порядок алгоритма PPM (может принимать значения от 2 до 63).

<Параметр2> — память для алгоритма PPM в мегабайтах (от 1 до 128).

Алгоритм PPM использует для распаковки такой же объём памяти, какой применялся при упаковке, поэтому если при создании архива выделить ему слишком много памяти, могут возникнуть проблемы с распаковкой такого архива на машине, оснащённой памятью меньшего объёма. Извлечение файлов будет возможно при помощи виртуальной памяти, но это может занять очень много времени.

Примеры:

1) Ключ -mc1a+ принудительно включает для всех данных 8-битовое сжатие монофонического звука.

2) Ключ -mc10:40t+ принудительно включает для всех данных использование алгоритма сжатия текста, устанавливая порядок сжатия 10 и выделяя 40 МБ памяти.

3) Ключ -mc12t устанавливает порядок сжатия текста в значение 12, если вступает в действие алгоритм сжатия текста, но оставляет WinRAR право решать, когда именно нужно его использовать.

4) Ключи -mct -mcd- разрешают WinRAR применять алгоритм сжатия текста для подходящих данных и отключать дельта-сжатие.


Ключ -MD<n>[k,m,g] - размер словаря

Ключ -MD<n>[k,m,g] — размер словаря

Скользящий словарь — это специальная область памяти, используемая алгоритмом сжатия. Если размер сжимаемого файла (в случае непрерывного архива — всех сжимаемых файлов) больше размера словаря, то увеличение размера словаря обычно приводит к улучшению степени сжатия, уменьшению скорости обработки и увеличению требований к объёму доступной памяти.

Для архивов формата RAR 4.x размер словаря может принимать следующие значения: 64/128/256/512 КБ, 1/2/4 МБ.

Для архивов формата RAR 5.0 размер словаря может принимать следующие значения: 128/256/512 КБ, 1/2/4/8/16/32/64/128/256/512 МБ, 1 ГБ.

Для указания размера в кило-, мега- и гигабайтах можно использовать модификаторы 'k', 'm' и 'g'. Например, ключ -md64m задаёт словарь размером 64 МБ. Если модификатор не указан, подразумеваются мегабайты, т.е. ключи -md64m и -md64 эквивалентны.

При архивировании WinRAR требует памяти в шесть раз больше, чем указанный размер словаря, поэтому размеры 512 МБ и 1 ГБ доступны только в 64-разрядной версии WinRAR. В среде Windows XP x86 максимальный размер словаря сжатия даже меньше и составляет 128 МБ. При распаковке расходуется памяти чуть больше, чем один размер словаря, так что обе версии — 32- и 64-разрядная — способны распаковывать архивы со словарями любого размера, включая 1 ГБ.

Если размер всех исходных файлов для непрерывного архива или размер наибольшего исходного файла для обычного (не непрерывного) архива хотя бы вдвое меньше заданного размера словаря, то RAR может уменьшить размер словаря. Это снижает требования к памяти, не ухудшая сжатие.

По умолчанию размер скользящего словаря для архивного формата RAR 4.x составляет 4 МБ, а для RAR 5.0 — 32 МБ.

При создании ZIP-архивов WinRAR всегда использует словарь размером 32 КБ.

Размер словаря выбирается в списке Размер словаря в окне "Имя и параметры архива".

Пример:

WinRAR a -md512 -m5 -s stuff

Эта команда создаёт непрерывный архив stuff, используя словарь размером 512 КБ и метод сжатия "максимальный".


Ключ -MS - расширения файлов для архивирования без сжатия

Ключ -MS[список] — расширения файлов для архивирования без сжатия

С помощью этого ключа можно указать файлы тех типов, которые нужно помещать в архив без использования сжатия. При правильном применении это может существенно повысить скорость архивирования без заметных потерь в степени сжатия всего архива.

Необязательный параметр <список> позволяет указать список расширений файлов; расширения должны быть перечислены через точку с запятой (;). Например, ключ -msrar;zip;jpg укажет WinRAR, что нужно помещать в архив без сжатия все архивы RAR и ZIP, а также изображения в формате JPG. В списке также допускается применять символы подстановки (шаблоны), поэтому ключ -ms*.rar;*.zip;*.jpg имеет точно такое же значение. Разрешается использовать несколько ключей -ms, например -msrar -mszip вместо -msrar;zip.

Если параметр <список> не указан, ключ -ms будет использовать стандартный набор расширений по умолчанию, включающий следующие типы файлов:

7z, ace, arj, bz2, cab, gz, jpeg, jpg, lha, lz, lzh, mp3, rar, taz, tgz, xz, z, zip, zipx


Ключ -MT<потоки> - количество потоков

Ключ -MT<потоки> — количество потоков

Параметр <потоки> может принимать значения от 1 до 32. Он определяет рекомендуемое максимальное число активных потоков для алгоритма сжатия, а также для других модулей WinRAR, которые могут запускать несколько потоков. WinRAR пытается следовать этой рекомендации, но иногда реальное количество потоков может быть больше указанного значения.

Изменение параметра <потоки> оказывает небольшое воздействие на степень сжатия, поэтому архивы, созданные с разными ключами -mt, будет иметь слегка различающиеся размеры, даже если все остальные параметры упаковки были одинаковые.

Если ключ -mt не указан, WinRAR попытается определить число доступных процессоров и автоматически выберет оптимальное количество потоков.


Ключ -N<файл> - дополнительный фильтр файлов, включённых в обработку

Ключ -N<файл> — дополнительный фильтр файлов, включённых в обработку

Применить маску как дополнительный фильтр к списку файлов, включённых в обработку. В качестве имени или частей имени допускается указывать шаблоны. Подробности о синтаксисе шаблонов см. в описании ключа -x.
Ключ -n разрешается указывать несколько раз в одной командной строке. Этот ключ не заменяет обычные маски файлов, которые по-прежнему должны вводиться в командной строке. Его назначение – в дополнительной фильтрации для ограничения обрабатываемых файлов теми, которые подходят под маску включения, определённую в ключе -n. Иногда такой способ помогает сократить длину командной строки.

Например, если нужно упаковать в архив text.rar все файлы *.txt и *.lst в папках Project и Info, можно ввести следующую команду:

WinRAR a -r text Project\*.txt Project\*.lst Info\*.txt Info\*.lst

или воспользоваться ключом -n:

WinRAR a -r -n*.txt -n*.lst text Project Info


Ключ -N@<файл-список> - прочитать дополнительные маски фильтрации из файла-списка

Ключ -N@<файл-список> — прочитать дополнительные маски фильтрации из файла-списка

Аналогичен ключу -n<файл>, но с тем отличием, что маски фильтрации считываются из файла-списка.

Этот ключ не заменяет обычные списки файлов или маски файлов, которые по-прежнему должны вводиться в командной строке. Это дополнительный фильтр, ограничивающий обработку только теми файлами, которые подходят под маску включения, определённую в ключе -n.

Пример:

WinRAR a -r -n@inclist.txt text Project Info @listfile.txt


Ключ -OC - устанавливать NTFS-атрибут "Сжатый"

Ключ -OC — устанавливать NTFS-атрибут "Сжатый"

Этот ключ позволяет восстанавливать у извлекаемых из архива файлов атрибут "сжатый", применяемый в файловой системе NTFS. При создании архивов WinRAR всегда сохраняет у файлов состояние атрибута "Сжатый", но не восстанавливает его при извлечении, если только не указан ключ -oc. При работе в режиме оболочки WinRAR эквивалентом этого ключа является параметр "Установить атрибут 'Сжатый'" в окне извлечения на вкладке "Дополнительно".

Ключ применим только к архивам RAR.


Ключ -OH - сохранять жёсткие ссылки как ссылки, а не как файлы

Ключ -OH — сохранять жёсткие ссылки как ссылки, а не как файлы

Если среди архивируемых файлов содержится несколько жёстких ссылок NTFS, то при указании этого ключа первая жёсткая ссылка добавляется в архив как обычный файл, а остальные жёсткие ссылки из того же набора — как ссылки на этот первый файл. При извлечении таких файлов WinRAR будет создавать жёсткие ссылки, а не обычные файлы.

После создания архива нельзя удалять или переименовывать первую жёсткую ссылку в архиве, иначе станет невозможным извлечение последующих ссылок. Если вы измените первую ссылку, последующие ссылки при извлечении также будут иметь изменённое содержимое. Для успешного извлечения последующих ссылок команда извлечения должна быть сначала вызвана для первой жёсткой ссылки. Поддерживается только в архивах RAR 5.0.

Этот ключ — эквивалент командной строки группы параметров "Сохранять жёсткие ссылки как ссылки" в окне "Имя и параметры архива".


Ключ -OI[-][:<мин_размер>] - сохранять идентичные файлы как ссылки

Ключ -OI[-][:<мин_размер>] — сохранять идентичные файлы как ссылки

Если указан этот ключ, WinRAR перед началом архивирования анализирует содержимое файлов. Если обнаруживаются несколько идентичных файлов размером более 64 КБ, первый файл из набора сохраняется как обычный файл, а все остальные файлы — как ссылки на этот первый файл. Это позволяет уменьшить размер архива, но накладывает некоторые ограничения на результирующий архив. Первый файл из набора идентичных файлов в созданном архиве нельзя удалять или переименовывать, потому что это сделает невозможным извлечение остальных ссылающихся на него файлов. Если изменить содержимое первого файла, то при извлечении изменёнными будут и все остальные ссылающиеся на него файлы. Команда извлечения должна применяться сначала к первому файлу, чтобы остальные файлы были успешно созданы.

Ключ -oi рекомендуется применять только при сжатии большого количества идентичных файлов и если архив в дальнейшем не предполагается изменять, а распаковывать его вы будете полностью, без необходимости извлекать или пропускать отдельные файлы. Если все идентичные файлы достаточно малы, чтобы уместиться в словаре сжатия, указываемом с помощью ключа -md<n>, то более гибкое решение, нежели ключ -oi, даёт ключ -s.

Необязательное значение <мин_размер> позволяет указывать порог минимального размера файлов. Файлы размером меньше заданного значения не анализируются и не считаются идентичными. Если данный параметр отсутствует, подразумевается принимаемое по умолчанию значение 64 КБ. Выбор слишком маленького значения <мин_размер> может привести к увеличению времени, необходимому для определения идентичных файлов.

Поддерживается только для архивов RAR 5.0.

Ключ -oi- служит для запрета обработки идентичных файлов, включённой в конфигурации WinRAR.

Этот ключ — эквивалент командной строки параметра "Сохранять идентичные файлы как ссылки" в окне "Имя и параметры архива".

Пример

Сохранить содержимое текущей папки в архиве archive.rar, добавляя идентичные файлы размером больше 1 000 000 байт как ссылки:

WinRAR a -oi:1000000 -ma archive


Ключ -OL[A] - обрабатывать символические ссылки как ссылки [с абсолютными путями]

Ключ -OL[A] — обрабатывать символические ссылки как ссылки [с абсолютными путями]

Хранить символические ссылки и точки соединения NTFS как ссылки, без архивирования содержимого файлов. При извлечении из архива такие элементы восстанавливаются как символические ссылки или как точки соединения. Поддерживается только в архивах RAR 5.0.

Чтобы можно было создавать символические ссылки при извлечении, нужно запускать WinRAR от имени администратора.

Если при архивировании указан ключ -ol, WinRAR добавляет все ссылки вне зависимости от их целевых объектов. При извлечении WinRAR по умолчанию пропускает символические ссылки, указывающие на папку вне папки назначения, с абсолютными путями, чрезмерным количеством элементов ".." в целевом объекте ссылки, либо с другими потенциально опасными параметрами ссылки. Если требуется извлекать такие ссылки, указывайте ключ -ola в командной строке.

Ссылки, указывающие на папки вне папки назначения, могут представлять угрозу безопасности. Разрешайте их извлечение, только если уверены в безопасности содержимого архива, например при распаковке ваших собственных резервных копий.

Ссылки, которые WinRAR считает безопасными, извлекаются всегда – вне зависимости от того, указан ли ключ -ol или -ola.

Ключ -ol – это эквивалент командной строки параметра "Сохранять символические ссылки как ссылки" в окне "Имя и параметры архива". Ключ -ola эквивалентен параметру "Разрешить абсолютные пути в символических ссылках" в окне извлечения.


Ключ -ONI - разрешить потенциально несовместимые имена

Ключ -ONI — разрешить потенциально несовместимые имена

Файловая система NTFS позволяет давать файлам имена с пробелами и точками в конце, однако множество Windows-программ не умеют корректно обращаться с такими именами. Если этот ключ не указан, то WinRAR при извлечении удаляет обнаруженные пробелы и точки в конце имён файлов. Указывайте этот ключ, только если требуется извлекать потенциально несовместимые имена такими, какие они есть.

Ключ -oni – это эквивалент командной строки параметру "Разрешить потенциально несовместимые имена" в окне извлечения.


Ключ -OR - переименовывать файлы автоматически

Ключ -OR — переименовывать файлы автоматически

Автоматически переименовывать извлекаемые файлы, если файл с таким же именем уже существует. Переименованный файл получает имя вида 'filename(N).txt', где 'filename.txt' – исходное имя файла, а 'N' – номер, начинающийся с 1, и увеличивающийся, если файл существует.


Ключ -OS - сохранять потоки NTFS

Ключ -OS — сохранять потоки NTFS

Данный параметр предназначен только для файловой системы NTFS. Он позволяет сохранить в архиве альтернативные потоки данных, связанные с файлами, расположенными на диске с файловой системой NTFS. Этот параметр может потребоваться включить, если вы пользуетесь какими-либо программами, хранящими данные в альтернативных потоках, и вам нужно сохранить эти потоки.

Для файлов с установленным NTFS-атрибутом "Зашифрованный" потоки не сохраняются.

Эквивалент этого ключа в режиме оболочки — параметр "Сохранять файловые потоки" в окне "Имя и параметры архива".

Этот ключ применим только к архивам RAR.


Ключ -OW - сохранять/восстанавливать информацию о правах доступа к файлам

Ключ -OW — сохранять/восстанавливать информацию о правах доступа к файлам

В среде Windows NT/2000/XP при использовании этого ключа WinRAR сохранит или восстановит информацию о владельце, группе, правах доступа и информацию аудита, если у вас для этого достаточно прав доступа. Обратите внимание, что файловую безопасность Windows NT поддерживают только разделы с NTFS.

Эквивалент этого ключа в режиме оболочки — параметр "Сохранять данные о правах доступа" в окне "Имя и параметры архива".

Этот ключ применим только к архивам RAR.


Ключ -O[+|-] - режим перезаписи

Ключ -O[+|-] — режим перезаписи

Этот ключ можно использовать как при извлечении, так и при обновлении файлов в архиве.

Доступные режимы:

-o | Выдавать запрос перед перезаписью (действие по умолчанию при извлечении файлов)
-o+ | Перезаписывать все (действие по умолчанию при обновлении файлов в архиве)
-o- | Пропускать существующие файлы


Ключ -P<пароль> - указать пароль шифрования архива

Ключ -P<пароль> — указать пароль шифрования архива

С помощью этого ключа можно установить <пароль> для шифрования файлов при архивации или для их расшифровки при извлечении. Регистр символов в пароле различается. Максимальная длина пароля составляет 127 символов. Если указан более длинный пароль, то он усекается до этой длины. Из соображений безопасности вы можете не указывать пароль в командной строке – в этом случае программа предложит его вам ввести.

В режиме оболочки пароль можно ввести с помощью окна "Ввод пароля по умолчанию" или в окне "Имя и параметры архива".

Пример:

WinRAR a -pZaBaToAd -r secret games\*.*

Эта команда добавит содержимое папки games в архив secret, используя пароль ZaBaToAd.

Примечания:

  1. Для обеспечения достаточно надёжной защиты пароль должен быть не короче восьми символов. Не следует применять легко угадываемые пароли.
  2. Храните свои пароли в надёжном месте, иначе если вы забудете или потеряете пароль, все ваши данные окажутся утраченными!


Ключ -QO[-|+] - добавить информацию для быстрого открытия архива [нет|принудительно]

Ключ -QO[-|+] — добавить информацию для быстрого открытия архива [нет|принудительно]

В RAR-архивах непосредственно перед данными каждого файла находится его заголовок, содержащий такие сведения, как имя файла, время, размер и атрибуты. Такой метод более устойчив к повреждениям, нежели хранение заголовков всех файлов в одном непрерывном блоке, разрушение или усечение которого способно повлечь уничтожение всего содержимого архива. Однако хотя такая реализация и более надёжна, у неё есть и недостаток: поскольку файловые заголовки рассредоточены по всему архиву, доступ к ним не столь быстрый, как при хранении заголовков в одном блоке, что может быть заметно, когда нужно быстро открыть содержание архива в таких графических оболочках, как, например, WinRAR.

Чтобы повысить скорость открытия архивов и вместе с тем не делать весь архив зависящим от повреждения одиночного блока, архивы RAR 5.0 могут содержать факультативную запись для быстрого открытия. Такая запись добавляется в конец архива и содержит копии имён файлов и другую информацию о находящихся в архиве файлах в одном непрерывном блоке в дополнение к обычным файловым заголовкам внутри архива. Поскольку блок непрерывный, его содержимое считывается быстро, без необходимости выполнять множество операций чтения с диска. Каждый файловый заголовок в таком блоке защищён контрольной суммой. Если WinRAR обнаруживает, что информация для быстрого открытия повреждена, он переходит к чтению индивидуальных заголовков внутри архива, поэтому устойчивость к повреждениям не понижается.

Информация для быстрого открытия содержит полную копию файлового заголовка, которая может занимать несколько десятков или сотен байт на файл, и на этот же объём увеличивается размер архива. Такое увеличение размера наиболее заметно, если архив содержит большое количество маленьких файлов, когда размер файловых данных сопоставим с размером файловых заголовков. Поэтому по умолчанию, если не указан ключ -qo или у него нет параметра, WinRAR сохраняет копии заголовков только для относительно больших файлов и продолжает использовать локальные заголовки для маленьких. Конкретный порог размера файлов зависит от версии WinRAR. Такой подход обеспечивает разумный компромисс между скоростью открытия и размером архива. Если предпочтительнее скорость открытия архива и неважен его размер, укажите ключ -qo+ для сохранения копий заголовков всех файлов. Если же нужно получить архив наименьшего размера, а скорость открытия его в других программах неважна, укажите ключ -qo-, чтобы полностью исключить информацию для быстрого открытия.

Если вы хотите оценить влияние этого ключа на производительность, удостоверьтесь, что содержимое архива не находится в дисковом кэше. Когда архивный файл находится в кэше, реальные операции поиска на диске не выполняются, так что доступ к файловым заголовкам будет быстрым даже без использования информации для быстрого открытия.

Этот ключ — эквивалент командной строки группы параметров "Информация для быстрого открытия" в окне "Имя и параметры архива".


Ключ -R - включить в обработку вложенные папки

Ключ -R — включить в обработку вложенные папки

Включает рекурсию вложенных папок (т.е. обработку текущей папки и всех её вложенных папок). Можно использовать вместе с командами: A, U, F, M, X, E, T, K, RR, C и S.

При использовании с командами A, U, F или M будут обработаны файлы не только в рабочей, но и во всех вложенных папках.

При использовании с командами X, E, T, K, RR, C или S будут обработаны архивы не только в рабочей, но и во всех вложенных папках.

Примеры:

1) Добавить содержимое диска C: в архив Backup:

WinRAR a -r Backup c:\*.*

2) Протестировать все архивы *.rar на текущем диске:

WinRAR t -r \*.rar


Ключ -R- - запретить обработку вложенных папок

Ключ -R- — запретить обработку вложенных папок

Запретить обработку вложенных папок (рекурсию).

Даже без указания ключа -r, в некоторых ситуациях WinRAR всё равно автоматически использует рекурсию. Ключ -r- позволяет её полностью запретить.

Если при архивировании указать имя каталога, и если в этом имени нет символов подстановки (шаблонов), WinRAR по умолчанию добавляет в архив содержимое этого каталога, даже если не указан ключ -r. Кроме того, WinRAR автоматически включает рекурсию, когда в качестве файловой маски указан корневой каталог диска без символов подстановки. Ключ -r- запрещает такое поведение.

Примеры:

Эта команда добавит в архив только пустую папку dirname, проигнорировав её содержимое:

WinRAR a -r- arc dirname

Следующая команда упакует только содержимое корневой папки диска C:, но не будет обрабатывать имеющиеся в ней вложенные папки:

WinRAR a -r- arc c:\


Ключ -R0 - обрабатывать вложенные папки в соответствии с шаблоном

Ключ -R0 — обрабатывать вложенные папки в соответствии с шаблоном

Аналогично ключу -r, но при использовании вместе с командами A, U, F и M файлы из вложенных папок будут добавляться только в том случае, если при указании масок файлов были использованы символы подстановки '*' и '?'.

Этот ключ работает только для имён файлов. На имена папок без части с именем файла (например 'foldername') ключ -r0 не влияет, и их содержимое добавляется в архив полностью, если только не был указан ключ -r-.

Пример

Добавить все файлы *.doc из текущей папки и её вложенных папок, а также файл readme.txt только из текущей папки в архив docs.rar. Если использовать обычный ключ -r, то WinRAR искал бы readme.txt и во вложенных папках.

WinRAR a -r0 docs.rar *.doc readme.txt


Ключ -RI<p>[:<s>] - приоритет процесса и время простоя

Ключ -RI<p>[:<s>] — приоритет процесса и время простоя

Этот ключ используется для управления степенью загрузки системы задачей WinRAR в многозадачной среде. Возможные приоритеты задачи, определяемые параметром <p> — от 0 до 15.

Если <p> равно 0, то используется приоритет по умолчанию, значение 1 соответствует минимальному приоритету, 15 — максимальному.

Время простоя <s> указывается в миллисекундах и может принимать значения от 0 до 1000. Это время, которое WinRAR будет отдавать системе после операций чтения или записи при архивации или извлечении файлов. Указывать время простоя, отличное от нуля, имеет смысл для большего уменьшения загрузки системы, чем этого можно добиться одним лишь параметром <p>.

Пример:

Запустить WinRAR с приоритетом по умолчанию и 10-миллисекундным временем простоя:

WinRAR a -ri0:10 backup *.*


Ключ -rr[N] - добавить данные для восстановления

Ключ -RR[n] — добавить данные для восстановления

Этот ключ используется только при создании или изменении архива RAR для добавления к нему данных для восстановления. При использовании формата RAR 4.x параметр 'N' может обозначать либо количество секторов для восстановления (n=1…524288), либо процент от размера архива, если после 'N' указан знак процента ( % ) или латинская буква 'p'. Для архивов RAR 5.0 параметр 'N' всегда означает процент от размера архива вне зависимости от наличия модификаторов 'p' или '%'.

Синтаксис этого ключа такой же, как у команды "RR[N]". См. подробности в описаниях команды RR[N] и данных для восстановления.

Эквивалент этого ключа в режиме оболочки — параметр "Добавить данные для восстановления" в окне "Имя и параметры архива".

Пример:

Добавить все файлы *.txt из текущей папки в архив Books и добавить данные для восстановления размером 3% от общего объёма архива:

WinRAR a -rr3p Books *.txt


Ключ -RV[N] - создать тома для восстановления

Ключ -RV[n] — создать тома для восстановления

Этот ключ используется при создании многотомного архива RAR для генерирования томов для восстановления. По синтаксису ключ аналогичен команде RV.


Ключ -S - создать непрерывный архив

Ключ -S — создать непрерывный архив

Непрерывный (solid) архив — это особый вид архива. При непрерывной архивации существенно улучшается степень сжатия, но обновление таких архивов происходит медленнее, чем обычных. Использование данного ключа имеет смысл только при создании новых архивов RAR.

Эквивалент этого ключа в режиме оболочки — параметр "Создать непрерывный архив" в окне "Имя и параметры архива".

Пример:

WinRAR a -s Sources *.c *.h

Эта команда добавит все файлы *.c и *.h из текущей папки в непрерывный архив Sources.

Более подробную информацию см. в разделе "Непрерывные архивы".


Ключ -S<N> - создать непрерывные группы, используя счётчик файлов

Ключ -S<n> — создать непрерывные группы, используя счётчик файлов

Аналогично ключу -s, но после сжатия <N> файлов происходит сброс статистики для непрерывного архива. Степень сжатия при этом обычно ухудшается, но вместе с тем уменьшается риск потери данных в случае повреждения непрерывного архива.


Ключ -SC<кодировка>[объекты] - указать кодировку символов (и объекты)

Ключ -SC<кодировка>[объекты] — указать кодировку символов (и объекты)

С помощью этого ключа можно указать кодировку (набор символов) для использования в файлах-списках, журналах и файлах с комментариями архивов.

Параметр 'кодировка' обязателен и может принимать одно из следующих значений:

U | Юникод UTF-16
F | Юникод UTF-8
A | 'Родная' однобайтовая кодировка, для Windows это ANSI
O | Кодировка OEM (DOS)

Порядок байтов в файлах с кодировкой UTF-16 (таких, как файлы-списки или комментарии) определяется по метке порядка байтов. Если такой метки нет, то подразумевается порядок little-endian.

Параметр 'объекты' указывать необязательно. Он может принимать одно из следующих значений:

G | Журналы, создаваемые ключом -ilog
L | Файлы-списки
C | Файлы с комментариями

Разрешается указывать более одного объекта, например: -scolc. Если параметр 'объекты' не указан, 'кодировка' будет применена ко всем объектам.

Этот ключ позволяет определять кодировку для файлов в ключе -z<файл>, файлов-списков и файлов с комментариями, записываемых командой cw.

Примеры

  1. Прочитать имена, содержащиеся в файле list с использованием OEM-кодировки:

WinRAR a -scol data @list

  2. Прочитать comment.txt как файл в кодировке Юникод:

WinRAR c -scuc -zcomment.txt data

  3. Записать comment.txt как файл в кодировке Юникод:

WinRAR cw -scuc data comment.txt


Ключ -SE - создать непрерывные группы, используя расширения файлов

Ключ -SE — создать непрерывные группы, используя расширения файлов

Аналогично ключу -s, но статистика для непрерывного архива сбрасывается при смене расширения файла. Степень сжатия обычно ухудшается, но снижается риск потери данных в случае повреждения непрерывного архива.


Ключ -SL<размер> - обрабатывать файлы размером меньше указанного

Ключ -SL<размер> — обрабатывать файлы размером меньше указанного

Включать в обработку только те файлы, размер которых меньше, чем указанный в параметре <размер> этого ключа. Параметр <размер> должен указываться в байтах.


Ключ -SM<размер> - обрабатывать файлы размером больше указанного

Ключ -SM<размер> — обрабатывать файлы размером больше указанного

Включать в обработку только те файлы, размер которых больше, чем указанный в параметре <размер> этого ключа. Параметр <размер> должен указываться в байтах.


Ключ -SV - создать независимые непрерывные тома

Ключ -SV — создать независимые непрерывные тома

По умолчанию WinRAR пытается сбросить статистику непрерывности как можно раньше после начала нового тома, но только если после предыдущего сброса было запаковано достаточно данных (хотя бы несколько мегабайт).

Данный ключ указывает WinRAR, что необходимо сбрасывать статистику для любого тома независимо от размера запакованных данных. Степень сжатия при этом уменьшается, но вместе с тем увеличивается вероятность успешного извлечения части данных, если один из томов с непрерывным архивированием будет утерян или повреждён.

Обратите внимание, что в некоторых случаях на сброс статистики не действует даже этот ключ. Например, невозможно сбросить статистику при сжатии одного большого файла, разделяемого по нескольким томам. WinRAR способен сбрасывать статистику непрерывности только между разными файлами, но не внутри одного файла.

Ключ игнорируется, если он указывается при создании обычных архивов (не многотомных).

Чтобы использовать этот ключ в оболочке WinRAR, его можно задать в переменной окружения RAR.


Ключ -SV- - создать зависимые непрерывные тома

Ключ -SV- — создать зависимые непрерывные тома

Данный ключ запрещает сброс статистики непрерывности между томами. Степень сжатия при этом незначительно улучшается, но вместе с тем существенно уменьшаются шансы на восстановление хотя бы части данных при повреждении или потере одного из томов непрерывного архива.

Ключ игнорируется, если он указывается при создании обычных архивов (не многотомных).

Этот ключ можно задать в переменной окружения RAR для использования в оболочке WinRAR.

См. также: ключ -SV — создать независимые непрерывные тома


Ключ -S- - запретить создание непрерывных архивов

Ключ -S- — запретить создание непрерывных архивов

Запрещает использование непрерывного архивирования, даже если оно включено в профиле архивации по умолчанию.


Ключ -SFX[имя] - создать самораспаковывающийся архив

Ключ -SFX[имя] — создать самораспаковывающийся архив

Если этот ключ используется при создании нового архива, то будет создан самораспаковывающийся (SFX) архив. По умолчанию WinRAR использует SFX-модуль Default.SFX для архивов RAR, и SFX-модуль Zip.SFX — для архивов ZIP. Эти модули должны находиться в той же папке, что и файл WinRAR.exe. После ключа -sfx может быть указан альтернативный модуль SFX.

Эквивалент этого ключа в режиме оболочки — параметр "Создать SFX-архив" в окне "Имя и параметры архива".

Примеры:

a) Создать самораспаковывающийся многотомный архив с непрерывным архивированием:

WinRAR a -sfx -v360 -s Games

б) Создать самораспаковывающийся архив с модулем WinCon.SFX:

WinRAR a -sfxWinCon.SFX Gift.rar

См. также: команда S[имя].


Ключ -T - протестировать файлы после архивации

Ключ -T — протестировать файлы после архивации

Проверка файлов после помещения их в архив. Этот ключ особенно полезен в сочетании с командой перемещения файлов в архив, поскольку файлы будут удалены с диска только в том случае, если их копии в архиве успешно прошли тестирование.


Ключ -TA<дата> - обрабатывать файлы, изменённые после указанной даты

Ключ -TA<дата> — обрабатывать файлы, изменённые после указанной даты

При указании этого ключа будут обрабатываться только файлы, модифицированные после указанной даты.

Дата указывается в следующем формате: ГГГГММДДЧЧММСС. В поле даты допускается вставлять символы-разделители ('-' или ': ') и не указывать оставшиеся поля. Например, следующий ключ будет правильным: -ta2001-11-20

Если говорить точнее, при внутренней обработке RAR будет трактовать вышеуказанный ключ как -ta20011120000000, что означает: "файлы, изменённые после 0 часа 0 минут 0 секунд 20 ноября 2001 года" (т.е. сама эта дата в заданный диапазон времени не входит).


Ключ -TB<дата> - обрабатывать файлы, изменённые до указанной даты

Ключ -TB<дата> — обрабатывать файлы, изменённые до указанной даты

При указании этого ключа будут обрабатываться только файлы, модифицированные до указанной даты.

Дата указывается в следующем формате: ГГГГММДДЧЧММСС. В поле даты допускается вставлять символы-разделители ('-' или ': ') и не указывать оставшиеся поля. Например, следующий ключ будет правильным: -tb2001-11-20

Если говорить точнее, при внутренней обработке RAR будет трактовать вышеуказанный ключ как -tb20011120000000, что означает: "файлы, изменённые до 0 часа 0 минут 0 секунд 20 ноября 2001 года" (т.е. сама эта дата в заданный диапазон времени не входит).


Ключ -TK - сохранять исходное время архива

Ключ -TK — сохранять исходное время архива

При обновлении архива будет сохраняться время его последней модификации.


Ключ -TL - устанавливать время архива по времени новейшего файла

Ключ -TL — устанавливать время архива по времени новейшего файла

При изменении архива у него будет установлено такое же время модификации, как у самого нового файла в архиве.


Ключ -TN<время> - обрабатывать файлы не старее указанного периода времени

Ключ -TN<время> — обрабатывать файлы не старее указанного периода времени

Используйте этот ключ, если нужно обработать только те файлы, дата изменения которых попадает в указанный период времени. Время указывается в следующем формате:

[<дни>d] [<часы>h] [ <минуты>m] [<секунды>s]

Например, для обработки файлов, изменённых менее 15 дней назад, используйте ключ -tn15d, а для обработки файлов, изменённых менее чем 2 часа 15 минут назад, используйте -tn2h15m.


Ключ -TO<время> - обрабатывать файлы старее указанного периода времени

Ключ -TO<время> — обрабатывать файлы старее указанного периода времени

Используйте этот ключ, если нужно обработать только те файлы, дата изменения которых не попадает в указанный период времени, т.е. они были созданы/изменены раньше, чем определяет параметр <время>. Время указывается в следующем формате:

[<дни>d] [<часы>h] [ <минуты>m] [<секунды>s]

Например, для обработки файлов, изменённых более 15 дней назад, используйте ключ -to15d, а для обработки файлов, изменённых более чем 2,5 часа назад, используйте -to2h30m.


Ключ -TS[m|c|a][+|-|1] - сохранять/восстанавливать время файлов (изменения, создания, доступа)

Ключ -TS[m|c|a][+|-|1] — сохранять/восстанавливать время файлов (изменения, создания, доступа)

Ключ -tsm служит для сохранения времени изменения файла, ключ -tsc сохраняет время создания, а -tsa — время последнего доступа. Допускается использовать сразу несколько ключей -ts, например -tsc -tsa. Если не указаны 'm', 'c' или 'a', то подразумеваются все три поля.

Добавьте '+' для сохранения времени файлов с максимально возможной точностью. Конкретное значение зависит от операционной и файловой систем и может быть равным 100 наносекундам в Windows и 1 наносекунде в UNIX. Добавьте '1', чтобы установить 1-секундную точность, или '-', чтобы не сохранять время файла. Если модификаторы '+', '-' или '1' отсутствуют, то подразумевается '+', таким образом, ключи -ts+ и -ts оба сохраняют все три времени с высокой точностью.

Архивы RAR 4.x всегда содержат время изменения, и для них ключ -tsm- по-прежнему сохраняет время изменения с наименьшей 2-секундной точностью. Два других времени могут быть отключены. В архивах RAR 5.0 можно исключать любое время файлов, в том числе время изменения, так что распаковываемые файлы будут иметь текущее системное время. Ключи -tsm- -tsc- -tsa или просто -ts- будут сохранять время изменения с наименьшей точностью для архивов RAR 4.x и не сохранять время файлов для RAR 5.0.

Если ключ -ts не указан, RAR сохраняет время изменения с высокой точностью и опускает два других времени.

Чтобы восстановить времена создания и доступа при распаковке, нужно указать ключи -tsc и -tsa. По умолчанию RAR устанавливает только время изменения, даже если в архиве сохранены и другие времена. Укажите ключ -tsm- или просто -ts- для того, чтобы распаковываемые файлы получали время изменения, равное текущему системному времени, а не сохранённому в архиве.

Windows позволяет устанавливать все три времени у извлекаемых из архива файлов. В UNIX можно устанавливать только время изменения и последнего доступа, но не время создания.

Все описанные выше режимы поддерживаются только для формата RAR. В архивах ZIP высокоточное время модификации хранится в той же структуре данных, что и времена создания и последнего доступа. При архивировании в ZIP все три времени контролируются ключами -ts или -tsm, а ключи -tsa и -tsc игнорируются. Чтобы сохранить все времена в высокоточном формате (режим ZIP по умолчанию), указывайте ключ -ts или -tsm. Чтобы сохранить только время модификации в формате с низкой точностью, указывайте ключ -ts- или -tsm-. При распаковке ZIP-архива ключи -tsm -tsc -tsa можно использовать индивидуально, чтобы управлять соответствующими временами так же, как в формате RAR.

Примеры:

1. Сохранить все времена файлов с максимально высокой точностью:

WinRAR a -ts backup

2. Восстановить у файлов времена модификации и последнего доступа. Ключ -tsm можно не указывать, так как RAR по умолчанию устанавливает время изменения. Если нужно восстановить только время последнего доступа, то следует использовать ключи -tsm- -tsa одновременно:

WinRAR x -tsa backup

3. Сохранить времена модификации и создания с низкой точностью:

WinRAR a -tsm1 -tsc1 backup


Ключ -U - обновить файлы

Ключ -U — обновить файлы

Данный ключ можно использовать как при добавлении файлов в архив, так и при извлечении из него. Командная строка a -u эквивалентна команде u. Вы также можете использовать этот ключ с командой m.

Если ключ -u применяется вместе с командами x или e, то из архива будут извлечены те файлы, которых нет на диске или копии которых на диске имеют более старые даты, чем в архиве. Отличие от ключа -f в том, что если для файла в архиве нет соответствующего файла на диске, то этот файл также будет извлечён.

Эквивалентом этого ключа в режиме оболочки являются пункт "Добавить с обновлением файлов" в окне "Имя и параметры архива" и параметр "Извлечь с обновлением файлов" в окне "Путь и параметры извлечения".

Поддерживается только для форматов RAR и ZIP.


Ключ -V<n>[k|b|f|m|M|g|G] - создать тома

Ключ -V<n>[k|b|f|m|M|g|G] — создать многотомный архив

Данный ключ создаёт многотомный архив с томами размером=<n>*1000.

По умолчанию параметр <n> считается в тысячах байт (т.е. число умножается на 1000, а не на 1024). Размер томов также можно указывать в килобайтах, байтах, мегабайтах и миллионах байт. Для этого нужно после числового значения поставить один из следующих буквенных модификаторов (все буквы латинские):

k | килобайты (множитель 1024)
b | байты (множитель 1)
m | мегабайты (1 МБ = 1 048 576 байт)
M | миллионы байт (множитель 1 000 000)
g | гигабайты (1 ГБ = 1 073 741 824 байта)
G | миллиарды байт (множитель 1 000 000 000)

Кроме того, можно ввести одно из предопределённых значений — 360, 720, 1200, 1440 или 2880 — добавив после него символ f, и тогда оно будет заменено точным размером соответствующей дискеты. Если размер тома не указан, то он определяется автоматически в зависимости от объёма свободного места на носителе.

Разрешается вводить десятичные дроби, разделяя целую и дробную части числа точкой. Например, ключ -v1.5g соответствует размеру 1,5 гигабайта.

Допускается указывать несколько ключей -v для того, чтобы задать разные размеры для разных томов. Например, команда:

RAR a -v100k -v200k -v300k arcname

устанавливает для первого тома размер 100 КБ, для второго — 200 КБ, а для всех последующих томов — 300 КБ.

Если тома создаются на сменном носителе, то после создания первого тома пользователю будет выдан запрос:

Создать следующий том? Да/Нет/Создать все

В этот момент вы должны сменить диск и ответить "Да". При ответе "Создать все" все последующие тома будут созданы без промежуточных пауз.

По умолчанию тома RAR получают имена вида 'volname.partNNN.rar', где NNN — номер тома. При использовании архивного формата RAR 4.x с помощью ключа -vn можно активизировать старую схему именования томов, основанную на изменении расширений файлов, при которой первый том в многотомном наборе получает расширение .rar, а последующие тома нумеруются от .r00 до .r99. В архивах RAR 5.0 ключ -vn и именование на основе изменения расширений файлов не поддерживаются.

При распаковке или тестировании многотомного архива нужно указывать только имя первого тома. Если следующего тома нет на диске, то пользователю будет выдан запрос:

Вставьте диск с <имя следующего тома>. OK/Отмена

Вставьте диск с указанным томом и нажмите OK.

Архивные тома нельзя изменять. С многотомными архивами не применяются команды D, F, U и S. Команду A можно использовать только для создания новых многотомных архивов.

Возможна (хотя и маловероятна) ситуация, при которой размер файла, находящегося в многотомном архиве, окажется больше, чем размер неупакованного файла. Это происходит из-за того, что при создании многотомных архивов не поддерживается метод упаковки "без сжатия" (т.е. помещение файла в архив в его исходном виде, если после сжатия размер файла увеличился).

Архивные тома могут быть непрерывными и/или самораспаковывающимися.

Эквивалентом этого ключа в режиме оболочки являются параметр "Размер тома" в окне "Имя и параметры архива".

Пример:

WinRAR a -v1200 -s -sfx bitmaps

В данном примере создаётся самораспаковывающийся непрерывный архив с томами размером 1 200 000 байт.


Ключ -VD - удалять содержимое сменного носителя перед созданием тома

Ключ -VD — удалять содержимое сменного носителя перед созданием тома

Если используется ключ -vd, то перед созданием архива с целевого носителя будут удалены все файлы и папки. При создании многотомного архива удаление будет выполняться перед созданием каждого тома, что позволяет архивировать данные на непустые сменные носители. При указании этого ключа убедитесь, что носители не содержат нужной информации.

Этот ключ применим только к сменным носителям, содержимое жёсткого диска им не удаляется.


Ключ -VER[n] - управление версиями файлов

Ключ -VER[n] — управление версиями файлов

Заставляет WinRAR сохранять предыдущие версии файлов при обновлении файлов в уже существующем архиве. Старые версии переименовываются в 'filename;n', где 'n' — номер версии. Применимо только к архивам RAR.

Если при распаковке архива не указан ключ -ver, будут извлечены только последние версии файлов, имена которых не содержат цифрового суффикса. Однако если указать точное имя файла, включая версию, он также будет извлечён. Например, команда 'rar x arcname' распакует только последние версии файлов, тогда как команда 'rar x arcname file.txt;5' извлечёт файл 'file.txt;5', если он имеется в данном архиве.

Если ключ -ver указан без параметра при распаковке, WinRAR извлечёт все версии всех файлов в соответствии с введённой маской файлов. В этом случае номера версий из имён распакованных файлов не удаляются. Вы также можете извлечь файл конкретной версии, указав её номер в качестве параметра ключа -ver. Такой ключ сообщит WinRAR, что нужно распаковать только файлы этой версии и удалить номер версии из имён. Например, команда 'rar x -ver5 arcname' извлечёт из архива только пятые версии файлов.

Если указать параметр 'n' при архивировании, он будет ограничивать сохраняемое в архиве максимальное число версий файлов. Старые версии файлов, превосходящие указанный предел, будут удалены.


Ключ -VN - старая схема именования томов

Ключ -VN — старая схема именования томов

По умолчанию тома многотомных архивов RAR получают имена вида 'volname.partNNN.rar', где NNN — номер тома. Для архивного формата RAR 4.x с помощью ключа -vn можно включить старую схему именования томов, при которой изменяются расширения файлов: первый том в многотомном наборе получает расширение .rar, а последующие тома нумеруются от .r00 до .r99.

В архивах RAR 5.0 ключ -vn и именование на основе изменения расширений файлов не поддерживаются.


Ключ -VP - пауза перед каждым томом

Ключ -VP — пауза перед каждым томом

По умолчанию WinRAR запрашивает подтверждение перед обработкой следующего тома только при архивировании на сменном носителе и только если объём свободного места на диске меньше, чем размер тома. При указании этого ключа WinRAR будет запрашивать такое подтверждение всегда при создании или распаковке томов. Например, это может быть полезно в случае, если вы хотите каждый созданный том сразу копировать на другой носитель.


Ключ -W<путь> - задать папку для временных файлов

Ключ -W<путь> — задать папку для временных файлов

При выполнении некоторых операций (например при изменении архива) WinRAR создаёт временные файлы и папки. По умолчанию он создаёт их в папке, указанной в поле "Папка для временных файлов" на вкладке Пути в окне настроек программы. При использовании WinRAR в режиме командной строки, этот параметр можно переопределить ключом -w<путь>.

Пример:

Использовать папку d:\tmp для временных файлов при добавлении нового комментария в архив info.rar

WinRAR c -wd:\tmp -zcomment.txt info.rar


Ключ -X<файл> - не обрабатывать указанный файл или папку

Ключ -X<файл> — не обрабатывать указанный файл или папку

Исключить из обработки указанный файл или папку. В имени и пути файла допускается использовать шаблоны. Этот ключ можно указать в командной строке несколько раз, чтобы определить в одной командной строке несколько масок исключения.

Если маска содержит шаблоны (символы подстановки), её действие распространяется на текущую и вложенные в неё папки. Без указания шаблонов действие ключа не рекурсивно, поэтому маска "filename" исключит из обработки файл 'filename' только в текущей папке при архивировании или в корневой папке архива при извлечении.

Используйте синтаксис "*\filename" для рекурсивного исключения "filename" во всех папках.

Если вам известен точный путь к файлу, то для исключения из обработки только этой копии файла "filename" используйте синтаксис "path\filename". Если используется синтаксис -xpath\filename при распаковке архива, то компонент "path" должен быть путём внутри архива, а не путём к файлу на диске после извлечения.

Маски, содержащие шаблоны (символы подстановки), по умолчанию применяются только к файлам. Если маску с шаблонами нужно применить к нескольким папкам, необходимо использовать особый синтаксис масок для исключения папок. Такие маски должны заканчиваться символом \ (обратная косая черта). Например, маска "*tmp*\" исключит из обработки все папки, подходящие под шаблон "*tmp*", а маска "*\tmp\" исключит все папки 'tmp'. Так как присутствуют символы подстановки, обе маски будут применены к содержимому текущей папки и всех её подпапок. Маски исключения папок работают только с архивами форматов RAR и ZIP.

Если нужно исключить из обработки только одну папку, укажите её точное имя, включая абсолютный или относительный путь без каких-либо символов подстановки. В этом случае добавлять к маске символ разделителя пути не нужно, он требуется лишь для масок исключения папок, содержащих символы подстановки, чтобы их можно было отличить от масок исключения файлов.

Если маска содержит шаблоны (символы подстановки), её действие распространяется на текущую и вложенные в неё папки. Без указания шаблонов действие ключа не рекурсивно, поэтому если требуется исключить из обработки какой-либо файл "имя_файла" во всех папках, нужно указать две маски: имя_файла для текущей папки и *\имя_файла для вложенных папок. Если вам известен точный путь к файлу, то для исключения из обработки только этой копии файла "имя_файла" допускается применять синтаксис Путь\имя_файла. Если использовать синтаксис -xПуть\имя_файла при распаковке архива, компонент "Путь" должен быть путём внутри архива, а не путём к файлу на диске после распаковки.

Примеры:

1) Добавить в архив rawfiles все файлы из текущей папки и вложенных в неё подпапок, за исключением файлов *.jpg и *.avi.

WinRAR a -r -x*.jpg -x*.avi rawfiles

2) Упаковать все файлы на диске C:, за исключением тех, которые находятся в папках temp, и файлов внутри папок temp:

WinRAR a -r -x*\temp\ SaveC c:\*

3) Извлечь из архива docs.rar все файлы, за исключением файлов *.txt:

WinRAR x -x*.txt docs


Ключ -X@<файл-список> - не обрабатывать файлы, указанные в файле-списке

Ключ -X@<файл-список> — не обрабатывать файлы, указанные в файле-списке

Исключить из обработки файлы, указанные в текстовом <файле-списке>.

Пример:

WinRAR a -x@list.txt bin *.exe

Эта команда добавит в архив bin все файлы *.exe, кроме перечисленных в файле list.txt.


Ключ -Y - отвечать "Да" на все запросы

Ключ -Y — подразумевать ответ "Да" на все запросы

Если указан этот ключ, то на все запросы будет автоматически даваться ответ "Да".


Ключ -Z<файл> - прочитать комментарий архива из файла

Ключ -Z<файл> — прочитать комментарий архива из файла

Если использовать этот ключ вместе с любой командой, изменяющей архив, то в архив будет добавлен архивный комментарий, прочитанный из указанного файла. Если требуется прочитать комментарий из текстового файла в кодировке Юникод, используйте этот ключ совместно с ключом -fcu.

Пример:

WinRAR a -zReceipts.diz -s Receipts

Эта команда добавит все файлы из текущей папки в непрерывный архив Receipts, прочитав комментарий для архива из файла Receipts.diz.


Коды возврата WinRAR

В случае успешного окончания операции WinRAR завершает работу с нулевым (0) кодом возврата. Если код возврата отличается от нулевого, это говорит о том, что произошла какая-то ошибка.

Код возврата | Описание
0 | Операция успешно завершена.
1 | Предупреждение. Некритические ошибки.
2 | Критическая ошибка.
3 | Неверная контрольная сумма. Данные повреждены.
4 | Попытка изменить заблокированный архив.
5 | Ошибка записи на диск.
6 | Ошибка открытия файла.
7 | Неверный параметр в командной строке.
8 | Недостаточно памяти для выполнения операции.
9 | Ошибка при создании файла.
10 | Нет параметров и файлов, удовлетворяющих указанной маске.
11 | Неверный пароль.
255 | Операция прервана пользователем.


Общие параметры

Окно установки общих параметров

Чтобы вызвать это окно, выберите команду "Установки..." из меню "Параметры" и перейдите на вкладку "Общие". Ниже описано содержимое окна.

Система

· Низкий приоритет

Этот параметр служит для управления загрузкой системы при работе WinRAR в многозадачной среде. Как правило, лучше использовать стандартный приоритет, т.е. не включать данный параметр, однако если вы часто запускаете WinRAR в фоновом режиме и одновременно работаете с другими программами, то имеет смысл установить низкий приоритет.

· Многопоточность

Если включено, WinRAR будет использовать многопоточную версию алгоритма сжатия RAR, обеспечивающую более высокую производительность на компьютерах с многопроцессорной или многоядерной архитектурой. По умолчанию данный параметр включён, если операционная система сообщает, что в компьютере имеется более одного процессора, однако его можно включить вручную даже в системе с одним процессором.

Этот параметр влияет не только на сжатие, но и на другие модули WinRAR, способные запускать несколько потоков. Как правило, предлагаемое WinRAR состояние по умолчанию даёт оптимальный результат, поэтому обычно его менять не нужно.

История

· Вести историю архивов

По умолчанию WinRAR сохраняет имена нескольких недавно открывавшихся архивов в меню "Файл", чтобы вы могли быстро открыть их снова. Если по каким-либо причинам (например из соображений секретности) вы не хотите, чтобы запоминались имена открывавшихся архивов, то данный параметр нужно выключить.

Кроме того, если включён этот параметр, WinRAR добавляет открываемые архивы в список недавних документов Windows. Если параметр "Вести историю архивов" выключен, Windows сама управляет списком недавних документов, и в этом случае — в зависимости от версии и настроек Windows — имена архивов могут быть в него как добавлены, так и не добавлены.

· История в полях ввода

Во многих окнах WinRAR поля ввода поддерживают списки ранее введённых строк, благодаря чему можно быстро восстановить уже использовавшиеся в предыдущих сеансах значения параметров (имя архива, результирующий путь и т.д.). С одной стороны, это может сэкономить время пользователю, но с другой, этот параметр (как и вышеуказанный) способен представлять опасность нарушения конфиденциальности, если за компьютером работают несколько человек. Поэтому если у вас многопользовательский компьютер, этот параметр имеет смысл отключить.

Панель инструментов

· Большие кнопки, Надписи на кнопках, Выбрать кнопки

Выбрать большие (48×36 пикселов) или маленькие (24×24) кнопки. Доступно только со стандартной темой интерфейса WinRAR.

· Надписи на кнопках

Этот параметр управляет отображением надписей на кнопках.

· Заблокировать панели

Запретить пользователю перемещать или изменять размер панелей инструментов. Этот параметр может пригодиться для того, чтобы исключить случайное изменение вида настроенных вами панелей.

· Панели…

Эта кнопка вызывает окно, в котором можно включить или выключить отображение главной панели инструментов WinRAR, дополнительной маленькой панели с кнопкой "Вверх на один уровень" и адресной строки с информацией о пути или архиве.

· Кнопки…

При нажатии этой кнопки открывается окно, в котором можно указать, какие именно кнопки должны присутствовать на панели инструментов.

Интерфейс

· При старте запускать мастера

Если включён этот параметр, WinRAR при запуске будет сразу переходить в режим мастера.

· Включить звуковые сигналы

Включает звуковую индикацию при возникновении ошибки или окончании длительного процесса.

· Показывать комментарий архива

Если в открываемом архиве есть комментарий, то WinRAR покажет его в окне справа.

· Открывать в одном окне

Если этот параметр включён и окно WinRAR уже открыто, то при попытке открыть архив с помощью команды "WinRAR <архив>" или щелчком по значку архива, этот архив будет открыт в существующем окне. Если же данный параметр выключен, то архив будет открыт в новом окне WinRAR.

· Всегда поверх других окон

Помещать окно WinRAR поверх окон всех остальных программ. Это может быть полезно, если вы часто перетаскиваете файлы в окно WinRAR.

· Полные пути в заголовке

Показывать в заголовке окна WinRAR полный путь к открытой папке или архиву.

· Индикаторы Windows

Этот параметр отвечает за вид индикаторов хода операции при архивировании и распаковке. Если параметр включён, WinRAR будет отображать стандартные индикаторы Windows, если же выключен, то будут использоваться собственные индикаторы WinRAR. В версиях Windows старее, чем Vista, имеет смысл держать этот параметр выключенным, а в Windows Vista и новее, где органы управления имеют более красивый вид — включённым. При этом нужно иметь в виду, что индикаторы Windows состоят всего из двух цветов, поэтому, в отличие от индикаторов WinRAR, они не показывают текущую степень сжатия. Чтобы компенсировать этот недостаток, на отдельной строке в окне хода операции также выводится числовое значение процента сжатия.

· Индикатор в панели задач

Если включён этот параметр, WinRAR будет отображать общий ход операции также на значке WinRAR в панели задач Windows. Эта функция работает только начиная с Windows 7, поэтому в более старых версиях Windows параметр "Индикатор в панели задач" недоступен.

Журнал

· Записывать журнал ошибок

Если этот параметр включён, то все сообщения об ошибках и информация о повреждении архива будут записаны в файл rar.log, находящийся в той же папке, что и WinRAR.exe, или в папке %APPDATA%\WinRAR. Эта возможность доступна только после регистрации. Для просмотра журнала служит команда "Просмотр журнала…" из меню "Параметры".

· Ограничить размер журнала до <nnn> КБ

Ограничивает размер создаваемого WinRAR файла rar.log. Значение размера файла (<nnn>) должно быть не менее 50 КБ.


Параметры архивации

Окно установки параметров архивации

Чтобы вызвать это окно, выберите команду "Установки..." в меню "Параметры" и перейдите на вкладку "Архивация". Ниже описано содержимое окна. Обратите внимание, что большинство параметров архивации можно задать с помощью кнопки "Профили архивации / Создать профиль по умолчанию".

Более подробную информацию о различных параметрах архивирования можно найти в разделе "Выбор оптимальных параметров архивации".

Профили архивации

· Создать профиль по умолчанию

В окне, отображаемом после нажатия этой кнопки, можно указать значения по умолчанию для большинства параметров архивации. Для всех параметров этого окна предусмотрены разделы в справочной системе, вызываемой кнопкой "Справка".

Параметры, введённые в этом окне, сохраняются в профиле архивации по умолчанию с именем "Профиль по умолчанию" и автоматически восстанавливаются перед каждой операцией архивации.

Некоторые параметры применяемого по умолчанию профиля архивации используются не только при добавлении файлов в архив, но и при других операциях, модифицирующих архив, например при удалении или переименовании файлов. В этом случае WinRAR считывает только те параметры, которые подходят для текущей операции. При извлечении никакие параметры из применяемого по умолчанию профиля архивации не используются.

· Упорядочить профили…

Открывает окно, в котором можно упорядочить профили архивации. В окне "Управление профилями" можно удалить существующие профили или изменить их параметры, например переименовать или сделать профилем по умолчанию.

Список размеров томов

· Определить размеры томов…

Эта кнопка вызывает окно "Определение размеров томов", в котором можно настроить список предопределённых размеров томов, отображаемый в поле "Разделить на тома размером" в окне имени и параметров архива.

Типы файлов, открываемых сначала как архивы

Здесь можно определить, как нужно обрабатывать нажатие Enter или двойной щелчок мышью на файлах с архивным содержимым, но имеющих отличное от архивов расширение в списке файлов WinRAR. На обработку обычных архивов с такими традиционными расширениями, как .rar или .zip, эта настройка не влияет.

Укажите одну или несколько масок файлов, разделяя их пробелами, чтобы выбрать файлы для данного параметра. Все файлы с не-архивными расширениями, не подпадающие под эти маски, будут либо запускаться, либо открываться в ассоциированных с ними программах, если таковые программы присутствуют. Например, если здесь не указана маска *.exe, а вы нажали Enter на самораспаковывающемся exe-архиве в списке файлов WinRAR, то этот SFX-архив будет запущен на выполнение, а не открыт в WinRAR.

Если файл соответствует любой маске, WinRAR будет сначала пытаться открыть его как архив, и только если он не архив, то будет обработан как обычный файл или пропущен – в зависимости от параметра "Никогда не запускать файлы этих типов".

Вне зависимости от этой настройки, можно просмотреть содержимое любого архивного файла, внутри или вне архива, со стандартным или нестандартным расширением, нажав Ctrl+PgDn на его имени в списке файлов WinRAR.


Параметры, путей;Установки, путей

Окно параметров путей

Чтобы вызвать это окно, выберите команду "Установки..." в меню "Параметры" и перейдите на вкладку "Пути". Ниже описано содержимое окна.

· Папка для временных файлов

WinRAR использует указанную папку для создания временных файлов. Если это поле пустое, то в зависимости от типа команды, временные файлы и папки будут создаваться либо в текущей папке, либо в папке для временных файлов Windows

Исходное состояние этого параметра – стандартная временная папка Windows. Если вы её изменили и хотите впоследствии вернуть временную папку Windows, введите переменную %temp% вместо имени папки, и тогда WinRAR перед созданием временных файлов будет её заменять именем временной папки Windows.

· Использовать только для сменных дисков

При работе с жёсткими дисками, как правило, быстрее всего создавать временный архив в текущей папке. Однако для медленных внешних дисков может быть эффективнее сначала создавать архив на жёстком диске, и лишь потом копировать его на внешний диск. Чтобы WinRAR архивировал данные именно таким образом, нужно задать папку для временных файлов и включить параметр "Использовать только для сменных дисков".

Параметр "Использовать только для сменных дисков" влияет только на те команды, которые изменяют архив. Прочие команды этот параметр не используют, игнорируя тип текущего диска.

· Папка запуска

Здесь можно ввести имя папки, в которую WinRAR будет переходить сразу после запуска. Обратите внимание, что если включён параметр "При запуске переходить в последнюю рабочую папку", то значение этого поля ни на что не влияет — WinRAR всегда будет переходить в ту папку, которая была активной во время его последнего сеанса работы.

· При запуске переходить в последнюю рабочую папку

Если этот параметр включён, то при запуске WinRAR перейдёт в папку, которая была активной во время предыдущего сеанса работы.

· Обзор

Нажмите эту кнопку для выбора папки запуска.

Папка по умолчанию для архивов

Если это поле не пустое и в имени создаваемого архива не задан полный путь, то архив будет создан в указанной папке по умолчанию. Например, если ввести в этом поле путь к рабочему столу Windows, то создаваемые WinRAR архивы будут появляться на рабочем столе.

Если это поле пустое и в имени архива не указан полный путь, то архивы будут создаваться в той же папке, где находятся архивируемые файлы.

В режиме командной строки ключ -cfg- запрещает большинство установок WinRAR, включая папку по умолчанию для архивов.

Папка по умолчанию для извлекаемых файлов

Здесь можно ввести имя папки, которая будет использоваться как базовая для конструирования папки назначения в командах "Извлечь без подтверждения" и "Извлечь в указанную папку". При использовании этих двух команд извлечения WinRAR создаёт путь назначения, добавляя имя архива к папке по умолчанию. Иногда здесь удобно ввести путь к рабочему столу Windows, чтобы все извлекаемые из архива данные сразу появлялись на рабочем столе.

В отличие от папки по умолчанию для архивов, папка по умолчанию для извлекаемых файлов не используется в режиме командной строки. В контекстных меню она задействуется только для команды "Извлечь файлы...".

· Добавлять к пути имя архива

Определяет, нужно ли добавлять имя архива к имени папки по умолчанию или папки, предлагаемой в окне извлечения файлов, при формировании пути назначения для извлекаемых файлов.

· Удалять избыточные папки из пути извлечения

Этот параметр работает только в контекстных меню, только для одного выбранного архива с одной папкой и без файлов в корневой папке архива и только для команды "Извлечь в DestName\", где 'DestName' это имя папки, предложенное WinRAR на основе имени архива. Если соблюдены все вышеуказанные условия, данный параметр удалит из пути извлечения на основе имени архива папку верхнего уровня.

Например, если архив Pictures.rar содержит все файлы в папке "Samples", и вы распаковываете его с помощью команды "Извлечь в Pictures\" в контекстном меню, то при выключенном параметре WinRAR поместит файлы в "Pictures\Samples", а если данный параметр включён, то в "Samples". Таким образом, экономится один щелчок мыши – не нужно открывать папку 'Pictures', в которой нет ничего, кроме 'Samples'.

Этот параметр вносит дополнительную задержку перед началом извлечения, так как WinRAR сначала должен просканировать архив и проанализировать структуру его папок. Обратите внимание, что в контекстном меню по-прежнему будет отображаться имя папки на основе имени архива, даже если оно будет удалено из пути при извлечении. Показ истинного имени папки сразу в контекстном меню вызывал бы потенциальные задержки между щелчком правой кнопкой мыши по архиву и появлением меню.


Параметры списка файлов

Окно настройки вида списка файлов

Чтобы вызвать это окно, выберите команду "Установки..." из меню "Параметры" и перейдите на вкладку "Список файлов". Ниже описано содержимое окна.

Тип списка (краткий / подробный)

Выберите Краткий вид (многоколоночный, отображаются только имена файлов) или Подробный (одна колонка, отображаются размер, дата и тип каждого файла). По умолчанию включён Подробный режим.

Стиль списка

· Показывать разделители

Показывать разделители колонок и строк в списке файлов.

· Курсор на всю строку

Если включено, то при использовании Подробного вида курсор будет выделять всю строку (с размером, временем и пр.), в противном случае — только имя файла.

Файлы

· Показывать архивы первыми

Показывать архивы в списке файлов перед всеми остальными файлами вне зависимости от текущего режима сортировки.

· Выделять цветом сжатые/зашифрованные NTFS-файлы

Если включено, то WinRAR будет отображать имена файлов, имеющих NTFS-атрибуты "Сжатый" и "Зашифрованный", теми же цветами, как в Проводнике Windows. По умолчанию для атрибута "Сжатый" используется синий цвет, а для атрибута "Зашифрованный" — зелёный.

· Объединять содержимое томов

Если включено, то при открытии первого тома многотомного архива WinRAR попытается также прочитать и отобразить содержимое всех остальных томов этого архива, находящихся в той же папке, что и первый том. Таким образом, будут показаны файлы, хранящиеся не только в первом томе, но и во всех остальных томах архива.

· Показывать секунды

Отображать секунды в датах у файлов в списке. Без этого параметра WinRAR показывает даты в списке файлов с точностью 1 мин.

· Шрифт…

Позволяет выбрать шрифт, используемый в списке файлов.

Выбор

В этой группе параметров можно определить разные стили выбора элементов списка мышью. Включите параметр "Открывать по одинарному щелчку", если вы привыкли к стилю выбора, обычного для Интернет-браузеров. В этом режиме можно также указать, как будут подчёркиваться имена файлов. По умолчанию в WinRAR используется режим "Открывать по двойному щелчку", как это принято в стандартной среде Windows 95.


Параметры, просмотра;Установки, просмотра

Окно параметров просмотра

Чтобы вызвать это окно, выберите команду "Установки..." в меню "Параметры" и перейдите на вкладку "Просмотр". Ниже описано содержимое окна.

Тип просмотра

Здесь выбирается стандартное действие, которое будет происходить при нажатии на файле клавиши <Enter>. Возможные действия:

Встроенное средство просмотра | Использовать встроенное средство просмотра WinRAR
Внешняя программа просмотра | Использовать внешнюю программу просмотра (она должна быть определена в поле "Внешняя программа просмотра")
Ассоциированная программа | Для просмотра использовать программу, связанную в Windows с данным типом файлов
Спросить | При нажатии <Enter> спрашивать у пользователя, какое из трёх вышеперечисленных действий следует выполнить

Для файлов некоторых типов эти параметры игнорируются. В режиме управления файлами они игнорируются для архивов и исполняемых файлов. По нажатию клавиши <Enter> WinRAR всегда пытается входить в архивы и запускать EXE-файлы. В режиме управления архивами эти параметры игнорируются для типов файлов, указанных в поле "Распаковывать весь архив для файлов" на вкладке "Просмотр" в окне настроек WinRAR. Если нажать <Enter> на таком файле, WinRAR извлечёт всё содержимое архива во временную папку, запустит этот файл, подождёт, пока тот закончит свою работу, в случае необходимости обновит архив и удалит временную папку со всеми файлами. Таким образом, можно легко устанавливать (инсталлировать) приложения непосредственно из архивов.

В отличие от нажатия клавиши <Enter>, команда "Просмотреть файл" всегда открывает файл во встроенной программе просмотра WinRAR.

Встроенное средство просмотра

· Использовать кодировку DOS

Если встроенное средство просмотра определяет, что содержимое файла — в юникод-кодировке UTF-8 или UTF-16 little-endian, эти кодировки выбираются автоматически. Все остальные файлы, которые не определены как юникодные, во встроенном средстве просмотра будут открываться либо в кодировке Windows (если данный параметр не включён), либо в кодировке DOS (если параметр включён). Во время просмотра кодировку можно поменять с помощью команд "Просмотр как…" в меню "Вид" встроенного средства просмотра.

· Просмотр в одном окне

Если этот параметр выключен, то при просмотре каждого файла WinRAR создаёт отдельное окно. Если же включён, то для просмотра будет использоваться только одно уже существующее окно, т.е. открывается только одна копия внутреннего средства просмотра.

· Перенос по словам

Переключает во встроенном средстве просмотра режимы заворота длинных строк и прокрутки. Этот параметр влияет только на вновь открываемые окна просмотра, уже открытые окна не изменяются.

Распаковывать весь архив для файлов

В этом поле можно указать маски для файлов в архиве, при нажатии <Enter> или двойном щелчке мышью на которых требуется распаковать содержимое всего архива. Маски должны быть разделены пробелами. Например, если это поле содержит "*.exe *.htm *.html", то весь архив будет распаковываться перед открытием заархивированных исполняемых файлов и файлов HTML. Данный параметр необходим для тех файлов, которым для выполнения или просмотра требуется доступ к другим находящимся в архиве файлам.

Для указанных в этом поле типов файлов WinRAR игнорирует установку в группе "Тип просмотра" и всегда открывает такие файлы в ассоциированной им программе.

Игнорировать изменения этих файлов

По умолчанию WinRAR пытается обновить архив, если программа просмотра изменила открытый файл или создала новые файлы, но такое поведение можно запретить. Введите в поле 'Игнорировать изменения этих файлов' одну или несколько масок файлов, разделяя их пробелами, и WinRAR не будет предлагать обновить архив, если созданный или изменённый программой просмотра файл подпадает под одну из этих масок.

Например, если это поле содержит *.doc *.txt, то любые файлы .doc и .txt, изменённые или созданные внешней или ассоциированной программой просмотра, будут игнорироваться, и все сделанные пользователем при просмотре изменения в этих файлах будут утеряны. Если вы хотите отключить обновление для любых просматриваемых файлов, используйте маску '*' (без кавычек).

Маски в этом параметре могут иметь более сложный синтаксис, сочетающий архивную и файловую маски, разделённые двумя символами обратной косой черты: arcmask\\filemask. Маски могут включать путь, ограничивающий архивы или файлы указанной папкой и её подпапками. В пути разрешается использовать переменные окружения. Если требуется выбрать все архивы или все файлы, то компоненты 'arcmask\\' или 'filemask' можно опустить.

Например, маска *.rar\\*.txt соответствует всем файлам .txt во всех архивах .rar, маска *\\temp\* или просто temp\* указывает на все файлы в папках 'temp' внутри архивов, а маска %temp%\*\\* или %temp%\*\\ сообщает программе просмотра о том, что не нужно обновлять никаких архивов во временной папке Windows.

Внешняя программа просмотра

Здесь нужно указать имя программы, которая должна использоваться для просмотра в случае, если выбран вариант "Внешняя программа просмотра". Имя просматриваемого файла передаётся программе как единственный параметр.


Параметры, безопасности;Установки, безопасности

Окно параметров безопасности

Чтобы вызвать это окно, выберите команду "Установки…" из меню "Параметры" и щёлкните на вкладке "Безопасность". Ниже приведено описание элементов этого окна.

Типы файлов, исключаемых из распаковки

Если включить этот параметр, то в расположенном ниже поле ввода можно указать список масок потенциально опасных файлов. Допускается вводить несколько масок, разделяя их пробелами. В этом случае при распаковке или открытии архивов WinRAR будет пропускать все файлы, удовлетворяющие указанным маскам.

Данный параметр может пригодиться для защиты пользователей от инфицированных вложений в сообщения электронной почты. Например, чтобы запретить пользователям распаковывать, просматривать и запускать с помощью WinRAR файлы .scr, .pif и .exe, в этом поле нужно указать:

*.scr *.pif *.exe

Уничтожение (затирание) временных файлов

Эта группа параметров управляет режимом удаления временных файлов во временной папке WinRAR, создаваемых при обработке уже существующих архивов. Это касается операций с внешней или внутренней программой просмотра, выполнения заархивированного файла и распаковки методом перетаскивания (drag and drop).

  • Не использовать

В этом режиме временные файлы удаляются с помощью стандартной системной функции удаления, поэтому их иногда можно восстановить с помощью специального ПО. Это самый быстрый, но наименее безопасный способ обращения с временными файлами.

  • Использовать всегда

В этом режиме временные файлы перед удалением перезаписываются нулевыми байтами, благодаря чему такие файлы уже невозможно восстановить. Это заметно медленнее, но более безопасно.

  • Использовать только для зашифрованных

При выборе данного варианта временные файлы удаляются с помощью надёжной и медленной функции затирания, если WinRAR определил, что эти файлы в архиве зашифрованы паролем. В противном случае применяется стандартное быстрое удаление.

Об уничтожении временных файлов

  • Функция уничтожения рассчитана на обычные жёсткие диски. При использовании с твердотельными накопителями (SSD) перезапись исходных данных может не работать из-за применяемой в SSD-накопителях технологии Wear Leveling (перераспределение блоков при записи) и более сложной адресации данных.
  • Если временные файлы всё ещё используются, WinRAR может не удалить их немедленно. Вместо этого все временные файлы, возраст которых превосходит один час, будут удалены или уничтожены при следующем запуске WinRAR. То же самое происходит, если WinRAR не может наверняка определить, продолжают ли использоваться временные файлы внешней программой.
  • Данный параметр работает только с временными файлами, созданными после операций извлечения. С другими временными файлами (например создаваемыми при изменении архива) он не работает. Такие файлы всегда удаляются с помощью стандартной быстрой функции удаления.

Предлагать выбор антивирусного сканера

Этот параметр влияет на поведение команды "Проверить архив на вирусы". По умолчанию данный параметр включён, поэтому при каждом вызове команды проверки на вирусы WinRAR предлагает выбрать антивирусный сканер и его параметры. Если вы пользуетесь только какой-то одной антивирусной программой, появление окна выбора сканера можно отменить, выключив этот параметр.


Параметры, интеграции

Окно параметров интеграции

Чтобы вызвать это окно из среды WinRAR, выберите команду "Установки..." из меню "Параметры" и перейдите на вкладку "Интеграция". Тот же набор параметров доступен во время установки WinRAR, поэтому описанные ниже параметры можно изменить как при установке, так и во время работы WinRAR.

Ассоциирование с файлами (архивами RAR, ZIP и др.)

Назначить WinRAR стандартной программой просмотра для файлов выбранных форматов. Лучше всего оставить данные параметры включёнными – это позволит открывать архивы в WinRAR простым нажатием <Enter> или двойным щелчком мыши на имени или значке архива в Проводнике или на рабочем столе. Кнопка "Переключить все" выбирает все форматы сразу или снимает с них выбор, если они уже выбраны.

Пользовательские расширения архивов

В этом поле можно указать дополнительные файловые расширения для архивных форматов, поддерживаемых WinRAR. Например, если ваши RAR-архивы имеют расширение ".dat", введите в этом поле "dat", чтобы ассоциировать WinRAR с такими файлами и добавить команды извлечения в контекстные меню, отображаемые в оболочке Windows для файлов "dat". Если требуется указать несколько расширений, разделяйте их пробелами.

Этот параметр доступен только в настройках WinRAR, но не в программе установки WinRAR.

Интерфейс

· Добавить значок WinRAR на рабочий стол

Поместить на рабочий стол значок WinRAR.

· Добавить значок WinRAR в меню "Пуск"

Поместить в меню "Пуск" пункт, вызывающий WinRAR.

Этот параметр добавляет значок WinRAR в верхний уровень классического меню "Пуск" в Windows XP. Начиная с Windows Vista, программам запрещено добавлять себя в верхний уровень меню "Пуск", поэтому данный параметр добавляет вызов WinRAR в список "Все программы". Если вы хотите добавить значок WinRAR в верхний уровень меню "Пуск" в Vista и более новых версиях Windows, то можете воспользоваться командой Windows "Закрепить в меню 'Пуск'".

· Создать программную группу WinRAR

Создать группу программ WinRAR в меню "Пуск/Программы".

Интеграция с оболочкой

· Встроить WinRAR в оболочку ОС (Проводник)

Позволяет использовать контекстные меню и технологию перетаскивания для обработки архивов, поддерживаемых WinRAR.

· Вложенные контекстные меню

Поместить все элементы, добавляемые WinRAR в контекстное меню, в отдельное подменю.

· Значки в контекстных меню

Показывать маленькие значки рядом с пунктами, добавляемыми WinRAR в контекстные меню файлов и архивов.

· Элементы в контекстном меню

Здесь вы можете выбрать элементы, которые будут отображаться в контекстных меню Проводника Windows.


Профили архивации

Профиль — это набор разных параметров архивации, который можно быстро установить перед началом архивации. Чтобы перед каждой архивацией не нужно было указывать тип архива, размер тома, метод сжатия и множество других параметров, можно создать несколько профилей для наиболее часто используемых вами сеансов архивации и в дальнейшем быстро загружать сразу все эти параметры, просто выбирая из меню соответствующий профиль.

У профилей архивации есть присвоенные пользователем имена, отображаемые в списке профилей. Рекомендуется давать профилям осмысленные имена, по которым можно было бы сразу понять назначение профиля. Чтобы воспользоваться профилем, нужно нажать кнопку "Профили" в окне "Имя и параметры архива" и выбрать в появившемся списке имя нужного вам профиля — все сохранённые в выбранном профиле параметры будут восстановлены. По умолчанию в WinRAR уже имеется несколько предопределённых профилей (например для создания вложений в электронные письма, для резервного копирования и др.), но при желании вы их можете удалить и создать свои.

Профили можно создавать двумя способами. Первый — открыть окно "Имя и параметры архива", выставить все параметры, нажать кнопку "Профили" и в появившемся меню выбрать пункт "Сохранить текущие параметры как новый профиль". В появившемся окне "Параметры профиля" можно указать имя профиля и его параметры, самый важный из которых — "Установить как профиль по умолчанию". Если установить этот параметр, данный профиль будет применяться перед каждым сеансом архивации и некоторыми операциями, модифицирующими архив. Другие параметры позволяют сохранить имя архива и список выбранных файлов, создать ярлык на рабочем столе и начать архивацию сразу после выбора данного профиля из меню. Более подробную информацию обо всех параметрах см. в разделе "Параметры профиля".

Второй способ создать профиль — нажать кнопку "Профили архивации / Создать профиль по умолчанию" в настройках WinRAR на вкладке "Архивация". В появившемся окне нужно выбрать все необходимые параметры и нажать кнопку OK. В результате будет создан новый используемый по умолчанию профиль с именем "Профиль по умолчанию". В отличие от первого метода, здесь вы не можете указать такие параметры профиля, как, например, сохранение имени архива и выбранных файлов, создание ярлыка. Если при определении профилей вам нужна большая гибкость, то следует использовать первый метод.

Сохранённые в профиле параметры архивации изменять нельзя. Однако вы можете изменять другие параметры профиля, например его имя, статус (используется он по умолчанию или нет) и др. Чтобы изменить параметры профиля или удалить существующие профили, используйте команду "Упорядочить профили", доступную как в меню профилей окна "Имя и параметры архива", так и в окне настроек WinRAR на вкладке "Архивация". С помощью этой команды вы можете присвоить любому профилю статус используемого по умолчанию или отменить этот статус у профиля.

В профиле можно сохранять пароль, однако имейте в виду, что пароль хранится в реестре в формате без надёжного шифрования. Поэтому узнать сохранённый пароль может любой пользователь, у которого есть доступ к вашему компьютеру.


Файл WinRAR.ini

По умолчанию WinRAR хранит свои настройки в реестре. Это удобно, когда WinRAR установлен и используется на одном и том же отдельном компьютере. Если же предполагается установить WinRAR на сменный носитель (например на USB-накопитель – "флэшку") для использования на разных ПК, то предпочтительнее не хранить относящуюся к WinRAR информацию в реестре этих компьютеров.

С этой целью предусмотрена возможность перенаправлять доступ WinRAR к реестру в текстовый файл. Если создать пустой файл WinRAR.ini либо в папке с WinRAR.exe, либо в %APPDATA%\WinRAR, то WinRAR будет перенаправлять доступ к ключам реестра HKEY_CURRENT_USER\Software\WinRAR и HKEY_LOCAL_MACHINE\Software\WinRAR в этот файл. Сначала WinRAR ищет этот файл в своей папке, а затем в %APPDATA%\WinRAR.

Используйте команду "Создать файл WinRAR.ini" в подменю "Импорт/экспорт", чтобы создать новый файл WinRAR.ini и скопировать в него из реестра имеющиеся установки WinRAR. Созданный этой командой файл нужно скопировать либо в собственную папку WinRAR, либо в %APPDATA%\WinRAR, чтобы сделать его активным.

Обычно текущие установки записываются в WinRAR.ini только при выходе, а до того момента они хранятся в памяти. Параметры сохраняются с учётом регистра символов как текстовые строки в кодировке UTF-16LE и имеют следующий формат:

<корневая ветвь>\<имя ключа>=значение

где <корневая ветвь> может быть HKCU для HKEY_CURRENT_USER, HKLM для HKEY_LOCAL_MACHINE и Global для глобальных установок, добавленных пользователем вручную. Строковые значения, заключённые в кавычки, и байтовые массивы имеют префикс "bin:".

Для управления поведением WinRAR.ini можно менять глобальные установки. Если запись в WinRAR.ini не запрещена, WinRAR автоматически создаёт указанные ниже строки, и чтобы изменить какую-либо установку, вам нужно отредактировать параметр после "=". Эти строки создаются в начале WinRAR.ini. Если вы собираетесь запретить запись в этот файл установкой у него атрибута "Только чтение", то потребуется добавить соответствующую строку в WinRAR.ini вручную перед установкой этого атрибута, по одной команде на строку. Все такие строки должны быть в кодировке UTF-16LE, и они чувствительны к регистру символов. Доступны следующие глобальные установки:

Global\AppData=0

Запрещает WinRAR доступ к папке APPDATA%\WinRAR. Если указан параметр Global\AppData=0, то все файлы, обычно хранящиеся в этой папке (например регистрационный ключ или темы интерфейса), следует хранить в папке с файлом WinRAR.exe. Укажите Global\AppData=1, чтобы разрешить доступ к APPDATA%\WinRAR.

Global\Integration=0

Хотя WinRAR перенаправляет свои ветви HKEY_CURRENT_USER и HKEY_LOCAL_MACHINE ключей реестра в WinRAR.ini, для правильной установки расширения оболочки и файловых ассоциаций по-прежнему требуется записывать данные в HKEY_CLASSES_ROOT и другие части реестра. Например, это происходит при использовании настроек интеграции. Если вы хотите полностью запретить все операции с реестром, добавьте в файл WinRAR.ini команду Global\Integration=0. После этого WinRAR не сможет изменять настройки интеграции в систему. Эта команда также запрещает создание или удаление ярлыка WinRAR на рабочем столе и программной группы WinRAR. Укажите Global\Integration=1, чтобы разрешить интеграцию в систему.

Global\SaveSettings=0

Запрещает запись текущих установок в WinRAR.ini, поэтому при выходе все изменения конфигурации, сделанные в текущей копии WinRAR, будут утеряны. Такого же результата можно добиться, включив у файла WinRAR.ini атрибут "только чтение". Таким образом, следует сначала настроить WinRAR так, как вы хотите, закрыть WinRAR, чтобы сохранить установки в файле, и только затем добавить команду Global\SaveSettings=0. Этот режим может также влиять на другие компоненты WinRAR, зависящие от WinRAR.ini, например встраивание в оболочку ОС не видит изменений в окне элементов контекстного меню. Укажите Global\SaveSettings=1, чтобы разрешить сохранение установок в WinRAR.ini.

Примечания

  • В отличие от других переменных в реестре, переменная "AppData" не перенаправляется в WinRAR.ini и всегда считывается из реестра. Данная переменная определяет местоположение папки %APPDATA%\WinRAR, а поскольку в этой папке может храниться файл WinRAR.ini, необходимо узнавать значение этой переменной до обращения к файлу WinRAR.ini.
  • Если в папке с инсталлятором WinRAR находится файл winrar.ini, то по окончании установки этот файл будет скопирован в программную папку WinRAR.


Переменная окружения RAR

Ключи, которые вы хотите использовать по умолчанию, можно определить с помощью переменной окружения Windows с именем RAR, задав её командой SET. Большинство определённых в этой переменной ключей будут применяться только при работе в режиме командной строки. Ключи -cl , -cu, -tk, -tl, -p используются как в режиме командной строки, так и в режиме оболочки.

Пример

SET RAR= -s -m5 -md1024

Эта команда указывает WinRAR, что при запуске из командной строки нужно создавать непрерывные архивы, используя режим максимального сжатия и словарь размером 1024 КБ.


Переменные в реестре

При работе в многопользовательской среде из соображений безопасности может потребоваться запретить доступ к некоторым функциям WinRAR. В этом случае вам нужно создать в системном реестре ключ:

HKEY_LOCAL_MACHINE\Software\WinRAR\Policy

или

HKEY_CURRENT_USER\Software\WinRAR\Policy

Ключ в HKEY_LOCAL_MACHINE имеет более высокий приоритет, чем ключ в HKEY_CURRENT_USER.

Этот ключ может содержать следующие значения:

Значение | Тип | Описание
Menu | DWORD | Если установлено в 0, отключает главное меню WinRAR.
Settings | DWORD | Если установлено в 0, отключает окно "Параметры", команды импорта/экспорта параметров и контекстное меню панели инструментов.
Password | DWORD | Если установлено в 0, запрещает изменение пароля архивирования (например чтобы избежать шифрования важных данных).
OrgPasswords | DWORD | Если установлено в 0, запрещает доступ к окну "Упорядочить пароли". При этом доступ к паролям, уже сохранённым в этом окне, остаётся, поэтому если необходимо, удалите их перед тем, как установить переменную OrgPasswords.
Shutdown | DWORD | Если установлено в 0, запрещает параметр "По окончании операции выключить компьютер", чтобы лишить пользователя возможности отключить компьютер.
Benchmark | DWORD | Если установлено в 0, запрещает команду "Тест быстродействия". В многопользовательском окружении эта команда может неблагоприятно влиять на совместные вычислительные ресурсы.

После смены политики может потребоваться перезапустить WinRAR. Ключ политики не влияет на консольную версию RAR (файл rar.exe), поэтому если при работе нескольких пользователей на одной машине вы хотите обезопасить себя в большей степени, имеет смысл удалить файл Rar.exe и оставить только WinRAR.exe.

Кроме того, можно переопределить расположение папки %APPDATA%\WinRAR, указав новый путь к дополнительным файлам WinRAR в строковом значении "AppData" в ключе реестра HKEY_CURRENT_USER\Software\WinRAR\Paths.


RARFILES.LST - порядок файлов в непрерывных архивах

RARFILES.LST — порядок файлов в непрерывных архивах

При помещении в непрерывные архивы файлы обычно сортируются по расширению, но можно задать и другой порядок сортировки, определив его в файле rarfiles.lst. Этот файл должен находиться в той же папке, что и WinRAR.exe, или в папке %APPDATA%\WinRAR. Такой файл входит в комплект поставки WinRAR, но вы можете настроить его сами под свои конкретные нужды. Это обычный текстовый файл, в котором записан порядок следования файлов при добавлении в непрерывный архив. Файл RARFILES.LST может содержать имена файлов, шаблоны и специальный элемент — $default. Данный элемент определяет место в списке для тех файлов, которые не соответствуют ни одному другому критерию, определённому в RARFILES.LST.

Советы по повышению степени сжатия и скорости выполнения операций:

· файлы с похожим содержимым должны быть сгруппированы в архиве максимально близко;

· файлы, к которым планируется обращаться чаще всего, должны находиться в начале архива.

Обычно маски следует располагать ближе к началу списка, чтобы они имели более высокий приоритет, однако из этого правила есть исключение. Если rarfiles.lst содержит такие две маски, для которых выполняется условие, что все файлы, подходящие под первую маску, также подходят и под другую, то маска, указывающая на меньшее подмножество, будет иметь более высокий приоритет вне зависимости от её расположения. Например, при указании масок *.cpp и f*.cpp более высокий приоритет будет у маски f*.cpp, поэтому расположение в архиве файла 'filename.cpp' будет выбрано в соответствии с 'f*.cpp', а не с '*.cpp'.

Пример файла RarFiles.lst:

file_id.diz
readme.*
*.doc
*.txt
*.hlp
*.inf
*.exe
*.dll
$default
*.rar


SFX-модули RAR и ZIP с графическим (GUI) интерфейсом (Default.SFX и Zip.SFX)

C помощью этих двух модулей можно создавать самораспаковывающиеся архивы с GUI (графическим интерфейсом) для Windows.

Для RAR-архивов используется модуль Default.SFX, для ZIP-архивов — Zip.SFX.

WinRAR x64 также включает 64-разрядные версии этих SFX-модулей — Default64.SFX и Zip64.SFX. По умолчанию WinRAR x64 использует 32-разрядные версии, но вы можете выбрать 64-разрядные модули явно в окне Дополнительные параметры SFX: Модуль. При этом результирующий 64-разрядный SFX-архив будет работать только в Windows x64.

Оба этих модуля поддерживают несложные команды создания инсталляционных пакетов и параметры командной строки. См. подробности в следующих темах:

  • SFX: команды создания инсталляторов
  • SFX: параметры командной строки

Примечания

  1. SFX-модули можно приспособить под свои конкретные нужды, отредактировав содержащиеся в них Windows-ресурсы. Например, допускается изменять размеры начального окна или добавлять туда свои рисунки. В комплект поставки WinRAR не входит ни редактор ресурсов, ни соответствующая документация. Редактирование ресурсов — процесс, требующий известной квалификации, и если вы собираетесь этим заниматься, то у вас наверняка уже есть нужный инструментарий и вы знаете, как с ним работать. Если же вас устраивает стандартное начальное окно SFX, то редактировать ресурсы не требуется. Кроме того, если нужно изменить только рисунок или значок в SFX-модуле, вы можете сделать это в окне дополнительных параметров SFX на вкладке "Текст и графика".
  2. Коды возврата, сообщаемые самораспаковывающимися архивами с графическим интерфейсом (GUI) при прекращении работы, по умолчанию такие же, как у WinRAR. Это поведение можно изменить с помощью команды SetupCode, чтобы SFX также сообщал коды возврата программы установки.


Графические SFX-модули: команды создания инсталляторов

SFX-модули WinRAR с графическим интерфейсом (GUI) поддерживают несложные команды для создания инсталляционных пакетов. Эти команды должны находиться в комментарии SFX-архива. Ниже приведён список команд. Щёлкните по названию команды, чтобы ознакомиться с её описанием.

Delete | Удалить файл перед извлечением
License | Показать экран с лицензионным соглашением
Overwrite | Выбор режима перезаписи файлов
Path | Установить предлагаемый по умолчанию путь для распаковки
Presetup | Выполнить указанную программу до начала распаковки
SavePath | Сохранить путь назначения
Setup | Выполнить указанную программу после успешной распаковки
SetupCode | Ждать завершения работы программы установки и установить её код возврата
Shortcut | Создать ярлык для распакованного файла
Silent | Не показывать начальное окно
TempMode | Распаковать архив во временную папку
Text | Добавить текст в окно SFX-архива
Title | Указать заголовок окна SFX-архива
Update | Выбор режима обновления файлов

SFX-модуль развёртывает переменные окружения в командных параметрах, поэтому можно использовать, например, такие команды:

Path=%temp%\myapp

Setup=mysetup.exe %sfxpar%

(см. описание переменной sfxpar для команды Setup).

Щёлкните здесь, чтобы ознакомиться с примером полного сценария установки.


SFX-модули с GUI: параметры командной строки

SFX-модули WinRAR с графическим интерфейсом (GUI) поддерживают перечисленные ниже параметры, указываемые в командной строке.

Параметр | Описание
-d<путь> | Указать результирующую папку для извлекаемых файлов.
-p<пароль> | Указать пароль для зашифрованного SFX-архива.
-s, -s1, -s2 | Режим подавления выводимых на экран сообщений. Ключ -s это сокращённая форма ключа -s1. Ключи -s и -s1 скрывают окно SFX и индикатор хода извлечения. Ключ -s1 также скрывает окно с лицензией. Ключ -s2 скрывает только начальное окно, но индикатор операции отображается.
-sp<параметры> | Если приложение, указанное в SFX-команде Setup, не содержит никаких параметров, вы можете использовать этот ключ для передачи параметров в такое приложение. Если в команде Setup параметры уже заданы, этот ключ игнорируется. Кроме того, программа установки может считывать полную командную строку SFX из переменной окружения sfxcmd, а переменная окружения sfxpar содержит только параметры командной строки SFX, без имени SFX-модуля в начале.

Если требуется вставить в параметр командной строки символ кавычки, укажите этот символ дважды.


Консольный SFX-модуль RAR (WinCon.SFX)

С помощью этого модуля можно создавать самораспаковывающиеся архивы, работающие в текстовом режиме в среде Windows. В среде MS-DOS модуль не функционирует.

WinRAR x64 также включает 64-разрядную версию этого SFX-модуля – WinCon64.SFX. По умолчанию WinRAR x64 использует 32-разрядную версию, но вы можете выбрать 64-разрядный модуль явно в окне Дополнительные параметры SFX: Модуль. При этом результирующий 64-разрядный SFX-архив будет работать только в Windows x64.

Модуль поддерживает следующие ключи командной строки:

-e Извлечь файлы из архива (действие по умолчанию)

-t Протестировать файлы в архиве

-v Показать подробное содержание архива

-? Показать справку

Коды возврата, сообщаемые консольными самораспаковывающимися архивами при прекращении работы, такие же, как у WinRAR.


Типичные вопросы

Список вопросов в этом разделе

Я хочу извлечь файлы из архива, но не знаю, как это сделать с помощью WinRAR.

RAR позволяет сжимать данные несколькими "методами". Какие преимущества и недостатки каждого из них, и каким вы советуете пользоваться ежедневно?

Мне часто доводилось слышать о "непрерывных" (solid) архивах. Что это такое и как их использовать?

Как пользователь моего сайта (электронной почты, FTP-сервера и т.д.) может извлекать файлы из архивов RAR, если RAR — условно-бесплатная программа, и пользователь должен зарегистрировать её после 40-дневного испытательного срока?

Где можно получить новейшие версии WinRAR?

При извлечении файлов программа выдаёт сообщение "Ошибка контрольной суммы". Что это означает?

Мне не удалось извлечь файлы из многотомного непрерывного архива RAR, потому что один из томов оказался повреждённым. Помогите!

Я забыл свой пароль! Помогите!

Почему WinRAR не удаляет свои временные файлы из папки временных файлов Windows?

Почему для моего архива WinRAR не использует словарь максимального размера?

Вопросы и ответы

? Я хочу извлечь файлы из архива, но не знаю, как это сделать с помощью WinRAR.

! Прочитайте раздел "Режимы оболочки и командной строки". В нём есть ссылки на разделы, описывающие несколько способов извлечения файлов.

AddType application/x-rar-compressed rar

Если файл .htaccess уже существует, то данную строку нужно просто добавить в этот файл.

? RAR позволяет сжимать данные несколькими "методами". Какие преимущества и недостатки каждого из них, и каким вы советуете пользоваться ежедневно?

! Ответ на этот вопрос см. в разделе "Выбор оптимальных параметров архивации".

? Мне часто доводилось слышать о "непрерывных" ("solid") архивах. Что это такое и как их использовать?

! Прочтите раздел "Непрерывные архивы".

? Как пользователь моей BBS (электронной почты, FTP-сервера и т.д.) может извлекать файлы из архивов RAR, если RAR — условно-бесплатная программа, и пользователь должен зарегистрировать её после 40-дневного испытательного срока?

! В комплект поставки WinRAR входит бесплатная программа UnRAR.exe, которой может пользоваться кто угодно для распаковки архивов RAR без отчисления лицензионного гонорара автору. Кроме того, на сайте WinRAR (www.rarlab.com) доступен переносимый на разные платформы исходный текст UnRAR. Обратите внимание, что алгоритм RAR является частной собственностью, поэтому использовать исходные тексты UnRAR для его восстановления запрещено.

? Где можно получить новейшие версии WinRAR?

! Посетите сайт WinRAR по адресу www.rarlab.com.

? При извлечении файлов программа выдаёт сообщение "Ошибка контрольной суммы". Что это означает?

! Извлечённые файлы испорчены из-за повреждения архива или каких-либо аппаратных проблем. Если архив повреждён, но в нём имеются данные для восстановления, можно попробовать его восстановить, в противном случае спасти повреждённые данные не удастся. Обратите также внимание, что если этот архив непрерывный, то все файлы, следующие за повреждённым, будут утеряны.

? Мне не удалось извлечь файлы из многотомного непрерывного архива RAR, потому что один из томов оказался повреждённым. Помогите!

! Если для архива есть тома для восстановления, поместите их в ту же папку, где находятся тома RAR, и дважды щёлкните по первому тому для восстановления (файлу REV), чтобы начать восстановление.
Если тома для восстановления недоступны или не помогли, попробуйте применить к повреждённому тому команду "Восстановить". Затем переименуйте восстановленный том (он будет назван fixed.имя_архива.rar или, если не удастся найти данные для восстановления, rebuilt.имя_архива.rar), дав ему настоящее имя тома, после чего попробуйте распаковать архив ещё раз, начав с первого тома.
Если вы хотите увеличить шансы на успешное восстановление многотомных RAR-архивов в случае повреждения информации, при их создании добавляйте к ним данные для восстановления и создавайте тома для восстановления. Кроме того, лучше избегать режима непрерывного архивирования, пусть даже это и приведёт к снижению степени сжатия.

Если повреждён том непрерывного архива, то попробуйте восстановить его. В этом помогают данные для восстановления (если они были добавлены при создании или изменении архива). Проверить наличие таких данных можно с помощью команды "Информация об архиве". Измените имя восстановленного тома с fixed.имя_архива.rar (или с rebuilt.имя_архива.rar, если данных о восстановлении в томе не было) на его исходное и попробуйте извлечь файлы из архива, начиная с первого тома.

? Я забыл свой пароль! Помогите!

! В схему шифрования WinRAR не встроено никаких потайных "лазеек". Если сами авторы WinRAR забудут пароль к любому из своих архивов, то извлечь файлы не смогут даже они. Пожалуйста, не обращайтесь к авторам за помощью в такой ситуации.

? Почему WinRAR не удаляет свои временные файлы в папке временных файлов Windows?

! Это происходит, если для извлечения файлов из архивов вы пользуетесь перетаскиванием (drag-and-drop) или открываете заархивированные файлы во внешней программе просмотра. В таких случаях эти файлы могут оставаться используемыми другой программой и после закрытия WinRAR, а надёжного способа определить, нужны внешней программе эти распакованные файлы или уже нет, не существует. Именно поэтому WinRAR и не удаляет такие файлы сразу. Вместо этого при следующем запуске WinRAR удаляет все свои временные файлы, оставшиеся после предыдущих сеансов работы, если они были извлечены более часа назад.

Если при извлечении файлов вы вообще не хотите задействовать папку для временных файлов, то пользуйтесь не перетаскиванием, а командой "Извлечь..." в оболочке WinRAR или "Извлечь в <имя_папки>"в контекстном меню Проводника.

? Почему для моего архива WinRAR не использует словарь максимального размера?

! Даже если при сжатии был указан максимальный размер словаря, WinRAR может автоматически уменьшить этот размер, если объём сжимаемых данных хотя бы вдвое меньше размера словаря. Это не ухудшает степень сжатия, но позволяет уменьшить требования к объёму доступной памяти.


Советы

Как установить программное приложение из архива

Вы можете установить или запустить программу прямо из архива. Для этого войдите в архив и нажмите <Enter> на программе установки, например setup.exe или install.exe. WinRAR извлечёт всё содержимое архива во временную папку, после чего запустит выделенный исполняемый файл. Далее WinRAR будет ждать окончания работы программы, после чего проверит время изменения извлечённых файлов и наличие новых, и при необходимости предложит обновить архив. После этого временная папка со всем её содержимым будет удалена.

Вы хотите использовать WinRAR для обработки архивов, но другая программа поменяла связи архивов

Некоторые программы могут регистрировать себя в Windows как стандартное средство обработки архивов, даже не спрашивая у вас разрешения. Если это произошло, а вы хотите снова закрепить за архивами программу WinRAR, выберите пункт "Установки..." в меню "Параметры", перейдите на вкладку "Интеграция", выберите форматы архивов, с которыми хотите связать WinRAR, и нажмите <Enter>.

Как установить WinRAR в неинтерактивном режиме

Если вам нужно установить WinRAR на большое количество компьютеров, то отвечать при каждой установке на одни и те же вопросы довольно утомительно. В этом случае можно установить WinRAR с параметрами по умолчанию, пропустив все вопросы. Для этого необходимо запустить дистрибутив WinRAR с ключом -s.


Лицензионное соглашение

Лицензионное соглашение с конечным пользователем

Нижеследующее Лицензионное соглашение, относящееся к архиватору RAR (и его версии для Windows - WinRAR), в дальнейшем именуемым "программой", заключается между компанией win.rar GmbH, в дальнейшем именуемой "лицензиаром", и любым лицом, в дальнейшем именуемым "пользователем", кто устанавливает программу, получает к ней доступ или использует её каким-либо иным способом.

1. Автором RAR и WinRAR и владельцем авторских прав на программу является Александр Л. Рошал. Лицензиаром и исключительным общемировым владельцем прав на использование программы, включая права на её воспроизведение, распространение и публикацию в любой форме, является компания win.rar GmbH, Marienstraße 12, 10117, Берлин, Германия.

2. Программа распространяется по принципу "попробуй перед тем, как купить". Это означает, что вы можете использовать программу бесплатно на протяжении испытательного периода длительностью не более 40 дней. По истечении этого периода пользователь обязан приобрести лицензию, чтобы продолжать использовать программу.

3. Пробную версию программы разрешается свободно распространять (кроме случаев, оговорённых ниже) лишь в том виде, в котором она поставляется, т.е. без каких бы то ни было изменений.

    1. Запрещается распространять отдельные части дистрибутива, за исключением компонентов UnRAR, без письменного разрешения владельца авторских прав.
    2. Запрещается распространять нелицензированную пробную версию программы в составе любого другого программного обеспечения без письменного разрешения владельца авторских прав. Предназначенная для загрузки программа должна оставаться в исходном немодифицированном установочном файле без каких-либо препятствий и условий для пользователя, например взимания платы за загрузку или требования от пользователя указывать свои контактные данные.
    3. Немодифицированный установочный файл WinRAR должен поставляться без каких-либо добавок. Любая его доукомплектация другими материалами запрещена. В частности, без письменного разрешения win.rar GmbH запрещается использовать любые программы для установки или загрузки комплектов ПО.
    4. При распространении пробной версии запрещается дополнять её программами для взлома, ключами и генераторами ключей, в том числе ссылками на них.
    5. Нарушение вышеуказанных условий немедленно и автоматически влечёт отмену разрешения на распространение программы.

4. Пробная версия программы может отображать напоминание о регистрации с предложением пользователю приобрести лицензию. В зависимости от версии и конфигурации программы, такое напоминание может содержать либо заранее сформированный текст и ссылки, загружаемые локально, либо веб-страницу, загружаемую из Интернета. Такая веб-страница может содержать инструкции о приобретении лицензии и другие материалы в соответствии с выбором лицензиара, в том числе рекламу. При открытии веб-страницы программа передаёт только те параметры, которые технически необходимы протоколу HTTP для открытия веб-страницы в обозревателе Интернета (браузере).

5. Программа распространяется по принципу "как есть". Никаких гарантий, явных или подразумеваемых, не предусматривается. Вы используете программу на свой собственный риск. Ни автор, ни лицензиар, ни его уполномоченные агенты не несут ответственности за потери данных, повреждения, убытки или любые другие виды потерь, связанные с правильным или неправильным использованием этой программы.

6. Предусмотрено два основных типа лицензий на использование программы:

    1. Однопользовательская лицензия. Пользователь приобретает одну лицензию на использование программы на одном компьютере.
      Домашние пользователи, купившие такую лицензию, могут использовать её на всех принадлежащих им компьютерах и мобильных устройствах (USB-накопителях, внешних жёстких дисках и т.п.).
      Корпоративные пользователи должны иметь по одной лицензии на каждый компьютер или мобильное устройство, где установлена программа.
    2. Многопользовательская лицензия. Приобретение определённого количества лицензий даёт право использовать программу покупателю или его наёмному работнику на таком же количестве компьютеров.
      При работе в сетевом окружении (сервер/клиент) вы обязаны приобрести копию лицензии на каждый отдельный клиент (рабочую станцию), где программа установлена, используется, или к ней осуществляется доступ. Отдельная копия лицензии на каждый клиент (рабочую станцию) требуется вне зависимости от того, используется программа на этих станциях одновременно или в разное время. Например, если требуется, чтобы доступ к программе в сети имели девять разных клиентов (рабочих станций), необходимо приобрести девять копий лицензии.

      Пользователь, купивший лицензию, получает неэксклюзивное право на использование программы в любых легальных целях на том количестве компьютеров, на которое приобретена лицензия.

7. Кроме стоимости лицензии не предусматривается никаких дополнительных лицензионных отчислений, связанных с созданием и распространением архивов RAR, томов, самораспаковывающихся архивов и самораспаковывающихся томов. Легальные владельцы лицензии могут использовать свои копии программы для создания архивов и самораспаковывающихся архивов и распространения этих архивов без дополнительных авторских отчислений.

8. Лицензированная копия программы не может быть сдана в аренду или дана напрокат, но может быть навсегда передана в полном комплекте другому лицу, если получатель согласен со всеми условиями этого Лицензионного соглашения.

9. Информация о покупке лицензии находится в файле order.htm.

10. Запрещается использовать, копировать, эмулировать, клонировать, сдавать в аренду, давать напрокат, продавать, изменять, декомпилировать, дизассемблировать, передавать лицензированную программу или её часть иначе, чем это описано в данном Лицензионном соглашении. Любое подобное неавторизованное использование приводит к немедленному и автоматическому прекращению действия этого Лицензионного соглашения и может повлечь за собой уголовное и/или гражданское преследование.

Без письменного разрешения запрещается использовать двоичный код RAR, двоичный код WinRAR, исходные тексты UnRAR и двоичный код UnRAR для реконструирования алгоритма сжатия RAR, который является собственностью автора.

Программа может использовать компоненты, разработанные другими компаниями, или авторское право на которые принадлежит другим компаниям. Подробности указаны в разделе "Благодарности" в справочном руководстве WinRAR или в текстовом файле acknow.txt в комплекте других версий RAR.

11. Данное Лицензионное соглашение целиком и полностью соответствует закону Германии. Если вы коммерсант, исключительная юрисдикция по поводу любых диспутов, связанных с этим Лицензионным соглашением или его правомерностью, принадлежит судам по месту регистрации офиса win.rar GmbH в Берлине/Германия.

12. Установка и использование программы свидетельствует о вашем согласии с условиями данного Лицензионного соглашения. Если вы не согласны с условиями Лицензионного соглашения, то должны удалить все файлы программы со своих устройств хранения информации и отказаться от дальнейшего использования программы.


О покупке

О покупке программы

Если вы хотите использовать WinRAR и RAR по окончании 40-дневного испытательного периода, вам необходимо приобрести лицензию у одного из региональных распространителей. Зарегистрироваться в онлайн-режиме или ознакомиться с новейшим списком распространителей можно на сайте WinRAR.

После получения от вас оплаты мы вышлем вам регистрационный ключевой файл, соответствующий указанной вами регистрационной строке. Пожалуйста, указывайте при покупке лицензии действующий адрес электронной почты, так как он будет использован для отправки вам ключа.

В письме с подтверждением регистрации вы найдёте все необходимые инструкции, поэтому просто следуйте им. Ниже изложено краткое описание процедуры регистрации, однако инструкции в письме более свежие, и их следует принимать во внимание в первую очередь.

Если вы используете WinRAR, скопируйте ключевой файл (rarreg.key) в папку с WinRAR или в папку %APPDATA%\WinRAR. По умолчанию папка с WinRAR это "C:\Program Files\WinRAR", но в вашей системе путь может быть иным (если он был изменён при установке WinRAR). Кроме того, для регистрации можно перетащить ключевой файл на окно WinRAR.

Если ключ заархивирован (находится внутри файла .rar или .zip), перед копированием извлеките файл rarreg.key из архива. Если имя архива – rarkey.rar, то есть другой способ установить ключевой файл: нужно открыть такой архив в WinRAR и ответить "Да" на запрос.


Добавить ярлык

Здесь вы можете указать параметры нового ярлыка, который будет создан SFX-архивом после распаковки. Это окно содержит следующие поля:

Место создания ярлыка

· На рабочем столе

Ярлык будет создан на рабочем столе Windows.

· В меню "Пуск"

Ярлык будет создан в меню кнопки "Пуск".

· В меню "Пуск/Программы"

Ярлык будет создан в меню кнопки "Пуск" в пункте "Программы".

· В папке "Автозагрузка"

Ярлык будет создан в папке автозагрузки Windows.

Параметры ярлыка

· Имя файла, для которого будет создан ярлык

Имя извлекаемого из архива файла, для которого нужно создать ярлык.

· Папка, в которую будет помещён ярлык

Папка, в которой должен быть создан ярлык. Если указанная папка не существует, то она будет создана SFX-архивом.

· Описание ярлыка

Текст, описывающий создаваемый ярлык.

· Имя ярлыка

Имя файла .LNK (ярлыка), создаваемого SFX-архивом.

Значок ярлыка

Имя файла со значком, ассоциированным с ярлыком. Если оставить пустым, то будет использоваться стандартный значок. Если имя файла со значком не содержит полный путь, SFX-архив будет искать значок в папке с распакованными файлами.

Обязательно требуется указывать только место создания ярлыка и имя файла, для которого будет создан ярлык. Остальные параметры факультативные.


Папка %APPDATA%\WinRAR

Старые версии WinRAR хранили свои дополнительные файлы (регистрационный ключ, файл экспортированных настроек settings.reg, темы, файл с отчётом) в той же папке, что и исполняемый файл WinRAR. В Windows Vista и последующих версиях Windows хранить такие данные в папке программы не рекомендуется. При попытке сделать это возможен даже сбой в работе программы. Программные данные рекомендуется располагать во вложенных папках в так называемой папке %APPDATA%.

Путь к %APPDATA% зависит от версии Windows. Чтобы открыть папку %APPDATA%, сделайте следующее: запустите Проводник Windows или откройте окно "Мой компьютер", введите в строке адреса %APPDATA% и нажмите Enter. Дополнительные файлы WinRAR хранятся во вложенной папке "WinRAR" в %APPDATA%. Для непосредственного перехода в папку данных WinRAR можно ввести в адресной строке Проводника %APPDATA%\WinRAR.

Ситуации, когда требуется вручную обращаться к папке %APPDATA%\WinRAR, встречаются нечасто. Например, это может понадобиться для копирования файла settings.reg на другой компьютер или для просмотра файла с отчётом с помощью какой-либо внешней программы.

Обратите внимание, что WinRAR пытается найти регистрационный ключ и файл settings.reg как в %APPDATA%\WinRAR, так и программной папке WinRAR, но первой в очереди стоит %APPDATA%\WinRAR.

Если вам требуется изменить расположение папки %APPDATA%\WinRAR, добавьте строковый параметр "AppData" с новым путём к дополнительным файлам WinRAR в ключ реестра HKEY_CURRENT_USER\Software\WinRAR\Paths.


Типы архивов

RAR или ZIP?

Архивный формат RAR 5.0

Поддержка архивов других форматов

Непрерывные архивы

Самораспаковывающиеся (SFX) архивы

Архивы из нескольких частей (многотомные)

Тома для восстановления

Шифрование

Комментарий архива

Защита архивов от повреждений

Блокировка архивов

Выбор оптимальных параметров архивации


Архивирование с паролем

В этом окне можно ввести пароль для архива, который вы собираетесь сейчас создать. Введённый пароль будет действовать только в течение одной текущей операции архивирования. Если вместо этого вы хотите задать глобальный пароль, то воспользуйтесь для этого командой "Установить пароль по умолчанию" в меню "Файл".

Если параметр "Отображать пароль при вводе" выключен, то придётся ввести пароль дважды, чтобы гарантировать правильность ввода.

Если включён параметр “Шифровать имена файлов”, то WinRAR зашифрует не только содержимое файлов, но и другие значимые области архива (имена, размеры, атрибуты, комментарии и другие блоки), что повышает степень защиты информации. Если архив сжат с использованием этого параметра, то без пароля невозможно даже просмотреть список файлов в архиве. Этот параметр доступен только для архивов формата RAR и не поддерживается для архивов ZIP.

Если вы уже сохраняли какие-то пароли, доступ к ним можно получить либо с помощью выпадающего списка, связанного с полем ввода пароля, либо воспользовавшись функцией автозавершения. Нажмите кнопку "Упорядочить пароли...", чтобы открыть окно управления паролями, в котором можно сохранять свои часто используемые пароли.

Если сохранённые пароли защищены главным паролем, то для доступа к ним нужно ввести главный пароль и нажать OK. Если введённый пароль отличается от главного пароля, то WinRAR будет считать его обычным паролем для операций с архивами.


Окно "Параметры операции"

Это окно позволяет "на лету", т.е. не прерывая архивирования, извлечения или тестирования, изменять состояние параметра "По окончании выключить компьютер".

Кроме того, при операциях архивирования здесь можно изменить режим сжатия на отличный от того, который был использован при запуске архивирования. Исключение составляет режим "Без сжатия": если архивирование было начато в этом режиме, переключиться на любой другой не удастся, равно как не удастся переключиться с любого другого режима на режим "Без сжатия", если архивирование было начато с использованием сжатия данных.


Дополнительные параметры сжатия

Как правило, изменять параметры в этом окне нет необходимости, безопаснее будет предоставить WinRAR возможность автоматически выбирать оптимальные настойки сжатия. Имейте в виду, что неправильное использование параметров в этом окне может привести к значительному снижению скорости работы архиватора и ухудшению степени сжатия, поэтому изменяйте здесь что-либо только в том случае, если чётко понимаете, что вы делаете.

Большинство указанных ниже параметров поддерживаются только в архивах формата RAR 4.x. Ни одна из этих настроек недоступна для формата ZIP. Для архивов RAR 5.0 можно включать только дельта-сжатие и сжатие 32-разрядных исполняемых файлов.

Это окно содержит следующие параметры.

Сжатие текста

· Автовыбор / Принудительно / Запретить

Алгоритм сжатия текста позволяет улучшить степень сжатия обычных текстовых данных, однако в скорости упаковки и распаковки, а также в возможности использовать несколько процессорных ядер он существенно уступает общему алгоритму сжатия. Поэтому по умолчанию для данного параметра выбрано значение "Запретить". Если изменить значение на "Автовыбор", то WinRAR будет выбирать алгоритм сжатия текста автоматически для данных соответствующего типа. При выборе значения "Принудительно" алгоритм сжатия текста будет применяться ко всем данным, но в этом случае вы должны быть готовы к более низкой скорости упаковки и распаковки.

· Порядок предсказания

Здесь можно установить порядок предсказания для алгоритма PPM (ядра текстового сжатия в RAR). Допустимый диапазон значений — от 2 до 63. Более высокое значение обычно слегка улучшает степень сжатия избыточных данных, но только в том случае, если имеется достаточно памяти для PPM. Если же памяти не хватает, результат может быть отрицательным. Чем выше значение порядка, тем медленнее сжатие и распаковка. Если установлено значение 0 (ноль), WinRAR выбирает порядок автоматически.

· Используемая память, МБ

Память в мегабайтах, выделяемая для алгоритма PPM. Допустимый диапазон значений — от 1 до 128. Более высокое значение может улучшить степень сжатия, однако учтите, что для распаковки PPM требуется столько же памяти, сколько использовалось при упаковке. Поэтому если вы выделите слишком много памяти при создании архива, то могут возникнуть сложности с его распаковкой на другом компьютере с меньшим объёмом памяти. Если установлено значение 0 (ноль), WinRAR выбирает объём памяти автоматически.

Сжатие аудио

· Автовыбор / Принудительно / Запретить

В режиме "Автовыбор" WinRAR анализирует обрабатываемые данные и в зависимости от них решает, когда следует использовать алгоритм сжатия аудио, причём только в том случае, если выбран "Обычный", "Хороший" или "Максимальный" метод сжатия. При выборе параметра "Принудительно" алгоритм сжатия аудио будет применяться ко всем обрабатываемым данным. Включать принудительное сжатие аудио имеет смысл только в том случае, если вы уверены, что все упаковываемые файлы целиком состоят из необработанных аудиоданных. Параметр "Запретить" полностью отключает алгоритм сжатия аудио.

Алгоритм сжатия аудио предназначен для упаковки необработанных аудиоданных (например несжатых WAV-файлов). Он не оказывает влияния на степень уплотнения уже сжатых аудиофайлов (MP3, FLAC и т.п.).

· Байтовые каналы

Количество байтовых каналов. Допустимый диапазон значений — от 1 до 31.

WinRAR разделяет многобайтовые каналы на байты, например два 16-битовых аудиоканала WinRAR будет считать за четыре канала по одному байту каждый. Если установлено значение 0 (ноль), WinRAR выбирает количество каналов автоматически.

Сжатие полноцветной графики

· Автовыбор / Принудительно / Запретить

В режиме "Автовыбор" WinRAR анализирует обрабатываемые данные и в зависимости от них решает, когда следует использовать алгоритм сжатия графики true color, причём только в том случае, если выбран "Обычный", "Хороший" или "Максимальный" метод сжатия. При выборе параметра "Принудительно" алгоритм сжатия полноцветной графики будет применяться ко всем обрабатываемым данным. Включать принудительное сжатие полноцветной графики имеет смысл только в том случае, если вы уверены, что все упаковываемые файлы целиком состоят из данных true color (RGB). Параметр "Запретить" полностью отключает алгоритм сжатия полноцветной графики.

Алгоритм сжатия полноцветной графики предназначен для упаковки необработанных данных с RGB-представлением цвета (например 24-битовых файлов BMP). Он не оказывает влияния на степень уплотнения уже сжатых графических файлов (например JPG).

Алгоритм сжатия исполняемых файлов x86

Позволяет достигать более плотного сжатия исполняемых файлов архитектуры Intel x86 путём применения специально оптимизированного для таких данных алгоритма. Может быть эффективным как для 32-, так и для 64-разрядных исполняемых файлов x86.

Алгоритм сжатия исполняемых файлов Itanium

Позволяет достигать более плотного сжатия исполняемых файлов архитектуры Intel Itanium путём применения специально оптимизированного для таких данных алгоритма.

Алгоритм дельта-сжатия

Позволяет достигать более плотного сжатия структурированных табличных данных путём применения специально оптимизированного для таких данных алгоритма.

Кнопка "По умолчанию" возвращает все параметры этого окна в стандартные значения.


Элементы контекстного меню

Группа параметров "Пункты, отображаемые в контекстном меню Проводника", позволяет выбрать элементы, добавляемые в контекстные меню Проводника Windows. Эти элементы выводятся в меню при щелчке правой кнопкой мыши на файле или значке архива в Проводнике или на рабочем столе.

Параметры в группе "Контекстное меню при перетаскивании" позволяют удалять команды команды архивирования и распаковки WinRAR из контекстного меню, отображаемого при перетаскивании файлов с нажатой правой кнопкой мыши. По умолчанию эти параметры включены, и WinRAR при перетаскивании с нажатой ПКМ предлагает упаковывать файлы и распаковывать архивы, используя результирующую папку как место назначения.

Параметры в группе "Место обнаружения SFX-архивов" влияют на обработку SFX-архивов в контекстных меню. Проверка содержимого исполняемого файла и выяснение, является ли он самораспаковывающимся (SFX) архивом, вызывает некоторую задержку при щелчке правой кнопкой мыши на любом файле с расширением ".exe", так как WinRAR должен прочитать и проанализировать данные файла, чтобы определить, SFX это или нет. Для быстрых локальных жёстких дисков эта задержка пренебрежимо мала, но на медленных сетевых дисках она может быть заметна. Параметры в этой группе позволяют разрешить или запретить проверку EXE-файлов на SFX индивидуально для локальных жёстких дисков, сетевых дисков и других носителей вроде CD и USB. Если эти параметры выключены, то при щелчке правой кнопкой мыши на SFX-архиве в контекстном меню не будет никаких пунктов, относящихся к SFX-архивам. Поэтому отключайте данные параметры только в том случае, если у вас в самом деле возникают задержки при вызове контекстного меню на EXE-файлах.


Окно "Определение размеров томов"

Это окно позволяет настроить список предварительно установленных размеров томов, связанный с полем "Разделить на тома размером" в окне имени и параметров архива.

В группе "Предустановленные размеры" можно указать, какие значения будет отображаться в списке. Если нужного вам значения нет среди предложенных в группе "Предустановленные размеры", вы можете указать до четырёх дополнительных элементов в группе "Пользовательские размеры". Просто введите для каждого элемента название и размер. Название – это любая короткая строка текста, а размер – число в байтах. При желании название можно не указывать.

Параметр "Строка 'Автоопределение'" в группе "Другие элементы" позволяет включать/выключать вывод в списке элемента "Автоопределение". Если при архивировании на сменные носители вы никогда не прибегаете к автоматическому определению размеров томов, то данный параметр можно отключить, чтобы сделать выпадающий список короче.

Параметр "Элементов в истории" определяет количество элементов, ранее указанных пользователем, которые выводятся в верхней части списка. Если запоминать введённые вручную размеры томов не нужно вообще, установите этот параметр в ноль. Запоминается максимум девять элементов.


Ввод пароля по умолчанию

В этом окне можно ввести пароль по умолчанию, который будет применяться в операциях добавления, извлечения, тестирования и просмотра. Если параметр "Отображать пароль при вводе" выключен и для операции архивирования необходимо ввести пароль, вам потребуется указать тот же пароль ещё раз в поле подтверждения, чтобы гарантировать правильность набора.

Если включён параметр "Шифровать имена файлов", WinRAR будет шифровать не только находящиеся в файлах данные, но и другие значимые области архива: имена файлов, размеры, атрибуты, комментарии и другие блоки, благодаря чему достигается более высокая степень защиты от несанкционированного доступа. Если архив зашифрован с этим параметром, то без указания пароля не удастся просмотреть даже список содержащихся в нём файлов. Шифрование имён файлов действует только при упаковке файлов в архивы RAR, параметр игнорируется при распаковке данных с помощью пароля по умолчанию, или когда упаковка выполняется в архив ZIP.

Параметр "Традиционное (устаревшее) шифрование ZIP" доступен только при добавлении файлов в архив ZIP. Включите, чтобы использовать устаревший алгоритм шифрования ZIP. Если этот параметр выключен, то архивы ZIP шифруются с помощью алгоритма AES-256, который значительно более надёжен, но может быть несовместим со старыми программами распаковки ZIP.

Если в окне ввода пароля вы включили параметр "Использовать для всех архивов" и указали в качестве пароля пустую строку, команды извлечения и тестирования будут пропускать все зашифрованные файлы и архивы. Кроме того, пока этот параметр не будет выключен, все попытки открыть зашифрованные файлы и архивы будут блокироваться. Данный режим может пригодиться, если вы собираетесь распаковать группу архивов без вмешательства пользователя и хотите избежать запросов пароля. Для непустых паролей параметр "Использовать для всех архивов" недоступен, так как непустые пароли по умолчанию применяются ко всем архивам автоматически, без необходимости в дополнительных настройках.

Если вы уже сохраняли какие-то пароли, доступ к ним можно получить либо с помощью выпадающего списка, связанного с полем ввода пароля, либо воспользовавшись функцией автозавершения. Нажмите кнопку "Упорядочить пароли...", чтобы открыть окно управления паролями, в котором можно сохранять свои часто используемые пароли.

Если сохранённые пароли защищены главным паролем, то для доступа к ним нужно ввести главный пароль и нажать OK. Если введённый пароль отличается от главного пароля, то WinRAR будет считать его обычным паролем для операций с архивами.


Выполнение операции с архивом

Сейчас выполняется операция с архивом. Дождитесь её завершения или нажмите кнопку "Отмена" для немедленного прекращения операции. Во время архивирования или извлечения вы можете также воспользоваться кнопками "Фоновый режим" и "Пауза". Кнопка "Фоновый режим" сворачивает WinRAR в область уведомлений (системный лоток). По окончании текущей операции окно WinRAR восстановится автоматически, но его можно восстановить и принудительно, щёлкнув мышью по значку WinRAR в области уведомлений. Кнопка "Пауза" приостанавливает текущую операцию; для того чтобы её возобновить, нажмите кнопку "Продолжить".

При архивировании и извлечении в верхней части командного окна выводится индикатор хода выполнения операции, показывающий степень обработки текущего файла.

При архивировании ниже отображается ещё один индикатор. Его вид зависит от состояния параметра "Индикаторы Windows" в окне настроек WinRAR. Если этот параметр выключен, а WinRAR выполняет архивирование файлов, то индикатор будет трёхцветным. Сжатые данные отображаются жёлтым цветом, а прочитанные — светло-серым, что позволяет наглядно оценить текущую степень сжатия файлов. Если же параметр "Индикаторы Windows" включён, то индикаторы будут двухцветными, но в любом случае общая степень сжатия выводится на отдельной строке этого окна.

Во время архивирования, извлечения или тестирования можно нажать кнопку "Параметры операции…", чтобы "на лету" изменить состояние параметра "По окончании выключить компьютер". При операциях архивирования здесь также можно изменить метод сжатия (за исключением режима "Без сжатия": переключиться на этот режим или выйти из него, если он был выбран при запуске архивации, нельзя).


Окно установки пути и параметров извлечения: Дополнительно

Здесь доступны следующие параметры:

Время файлов

· Восстанавливать время изменения/создания/последнего доступа

Файловые системы Windows сохраняют три разных поля времени для каждого файла: время последнего изменения, создания и последнего обращения к файлу. По умолчанию WinRAR сохраняет только время последнего изменения, однако с помощью параметров времён файлов на вкладке "Время" в окне архивирования можно включить сохранение времени создания и последнего обращения. Следует иметь в виду, что даже когда в архиве присутствует нужное вам поле времени, в окне извлечения необходимо выбрать соответствующий параметр, если нужно, чтобы это время было восстановлено у файлов при распаковке. Наличие этих параметров зависит от формата архива, некоторые форматы их не поддерживают.

Атрибуты

· Снимать у файлов атрибут "Архивный"

У всех извлечённых файлов будет снят атрибут "Архивный". Этот параметр предназначен для использования в операциях резервного копирования данных.

· Восстанавливать права доступа

Этот параметр имеет значение только для файловой системы NTFS и позволяет восстанавливать информацию о владельце файла, группе, контроле доступа и аудите, если такие сведения были предварительно сохранены в архиве. Для сохранения такой информации нужно при создании архива включить параметр "Сохранять данные о правах доступа" на вкладке "Дополнительно" в окне архивирования. Чтобы воспользоваться этой возможностью, вы должны обладать соответствующими системными привилегиями. Обработка информации о правах доступа может замедлить операцию архивирования, поэтому включайте данный параметр только в том случае, если вы понимаете его назначение и вам это действительно необходимо. Для домашних пользователей обработка данных о правах доступа в большинстве случаев не нужна.

Данная функция поддерживается только для архивов RAR.

· Восстанавливать атрибут "Сжатый"

Этот параметр позволяет восстанавливать NTFS-атрибут "Сжатый" у извлекаемых из архива файлов. WinRAR всегда сохраняет данный атрибут при создании архива, но не восстанавливает его при распаковке, если только не указан этот параметр.

Данная функция поддерживается только для архивов RAR.

Пути файлов

· Извлекать с относительными путями

Этот режим используется по умолчанию. Если вы находитесь в какой-либо вложенной папке в архиве, открытом в WinRAR, часть пути к этой папке, включая её имя, будет удалено из извлекаемых путей файлов. Например, если вы, находясь в архивной папке "Backup\MyData", извлечёте имеющуюся там папку "Images", то она будет извлечена как "Images", а не как "Backup\MyData\Images".

Если вы находитесь в корневой папке архива или начинаете извлечение из контекстного меню, данный режим работает точно так же, как Извлекать с полными путями.

· Извлекать с полными путями

Содержимое архива будет извлечено в папку назначения вместе с сохранённой в архиве информацией о путях. В отличие от режима Извлекать с относительными путями, информация о путях извлекается полностью, вне зависимости от того, в какой из архивных папок вы находитесь.

· Извлекать файлы без путей

Выбранные файлы из корневой папки архива и его выбранных вложенных папок будут извлечены в папку назначения без учёта информации о путях.

· Извлекать с абсолютными путями

Если при создании архива был использован режим "Сохранять полные пути, включая букву диска", выбираемый в окне архивирования на вкладке "Файлы", и вы включили параметр "Извлекать с абсолютными путями", WinRAR запишет распакованные файлы в их исходные папки и диски. Будьте осторожны! Не включайте этот параметр, если не вполне уверены, что в архиве нет "злонамеренных" файлов. Более подробную информацию о потенциальных преимуществах и опасностях, присущих режиму "Извлекать с абсолютными путями", см. в описании ключа -ep3, являющегося эквивалентом этого параметра WinRAR для командной строки.

Данная функция поддерживается только для архивов RAR и ZIP.

Удаление архива

· Не удалять

Не удалять архив после распаковки.

· Запрашивать подтверждение

Выдавать пользователю запрос на подтверждение удаления архива после распаковки.

· Удалять всегда

После распаковки удалять архив без предупреждения.

WinRAR удаляет архив только в том случае, если он был распакован без ошибок и если для извлечения были выбраны все находящиеся в нём файлы. При успешной распаковке многотомного архива удаляются все его тома.

Обратите внимание, что вы можете сохранить значение этого параметра как используемое по умолчанию, нажав кнопку "Сохранить установки" на вкладке "Общие" окна извлечения, и это также повлияет на работу в режиме командной строки и на команды извлечения в контекстных меню. Поэтому во избежание утери данных из-за удаления архива после распаковки следует с осторожностью использовать режимы "Запрашивать подтверждение" и особенно "Удалять всегда".

Разное

· Извлекать в фоновом режиме

Сворачивать WinRAR в область уведомлений при запуске извлечения.

· Ждать, если работает другая копия WinRAR

Если в данный момент в системе запущена ещё одна копия WinRAR, создающая, модифицирующая или распаковывающая какой-либо архив, и включён этот параметр, то операция будет начата, только когда другая копия WinRAR завершит свою работу или будет приостановлена. В случае, когда требуется выполнять серию операций по архивированию или распаковке данных, такое последовательное выполнение способно снизить нагрузку на диски и повысить общую производительность.

Отменить этот параметр для текущей операции можно нажатием кнопки "Продолжить" в окне хода операции. При нажатии этой кнопки WinRAR выходит из состояния ожидания вне зависимости от того, работают сейчас другие копии WinRAR или нет.

Этот параметр не поддерживается для архивов 7z.

Разрешить абсолютные пути в символических ссылках

Если этот параметр выключен, команда извлечения пропускает символические ссылки, которые указывают на объекты вне папки назначения, содержат абсолютные пути, чрезмерное количество элементов ".." в целевом объекте или другие потенциально опасные параметры ссылки. Ссылки, указывающие на папки вне целевой папки извлечения, могут представлять угрозу безопасности. Разрешайте их извлечение, только если уверены, что содержимое архива безопасно, например когда это созданная вами же резервная копия данных.

Ссылки, которые WinRAR считает безопасными, извлекаются всегда – вне зависимости от того, включён этот параметр или нет.

Разрешить потенциально несовместимые имена

Файловая система NTFS позволяет давать файлам имена с пробелами и точками в конце, однако множество Windows-программ не умеют корректно обращаться с такими именами. Если этот параметр выключен, то WinRAR при извлечении удаляет обнаруженные пробелы и точки в конце имён файлов.


Окно установки пути и параметров извлечения: Общие

Эта часть окна распаковки позволяет выбрать папку назначения и параметры для извлечения файлов. По умолчанию папка получает то же имя, что и архив (без расширения) и размещается в текущей папке, но вы можете изменить это в окне "Параметры архивации". В поле "Путь для извлечения" следует ввести нужный путь (если его ещё не существует, то он будет создан) или выбрать папку в панели дерева папок.

В этом окне по мере ввода имени папки WinRAR пытается автоматически открывать подходящую папку в дереве папок, но с небольшой задержкой (около полсекунды), если вводимый путь начинается с буквы диска и если такой автоматический выбор длится не слишком долго. Если папки не существует, то будет выбрана родительская папка или другая папка, наиболее похожая на указанную. Кроме того, можно принудительно начать поиск введённого имени папки нажатием кнопки "Показать", что бывает нужно, когда имя было автоматически подставлено программой при открытии окна, либо автоматический выбор был прерван из-за низкой скорости.

С помощью кнопки "Создать папку" можно создать новую папку. Она будет создана в папке, выбранной в окне с деревом или указанной в поле "Путь для извлечения", в зависимости от того, что вы изменили последним. Клавиша F2 позволяет переименовывать папки в окне с деревом, Del - удалять их, а F5 - обновлять содержимое этого окна.

Окне извлечения допускает изменение размеров. Чтобы увеличить область со списком папок, перетащите мышью границу окна до нужного вам размера. Новые размеры этого окна WinRAR запомнит и будет использовать в дальнейшем.

В этом окне также доступно несколько дополнительных параметров:

Режим обновления

· Извлечь и заменить файлы (действие по умолчанию)

Извлекаются все выбранные файлы.

· Извлечь и обновить файлы

Извлекаются только те из выбранных файлов, которых нет в папке назначения или копии которых в архиве новее, чем файлы на диске.

· Обновить только существующие файлы

Извлекаются только те из выбранных файлов, которые имеются в папке назначения, но их копии в архиве новее, чем файлы на диске. Файлы, которых нет на диске, извлекаться не будут.

Режим перезаписи

· Выдавать запрос перед перезаписи (действие по умолчанию)

Перед попыткой перезаписи файла будет выдаваться запрос.

· Перезаписывать все файлы без запроса

Файлы перезаписываются без запроса.

· Пропускать существующие файлы

Уже имеющиеся на диске файлы перезаписываться не будут.

· Переименовывать автоматически

Автоматически переименовывать извлекаемые файлы, если файл с таким же именем уже существует. При переименовании файлы получают имена вида 'filename(N).txt', где 'filename.txt' – исходное имя файла, а 'N' – номер.

Разное

· Распаковать архивы во вложенные папки

Этот параметр доступен только при распаковке сразу нескольких архивов. Распакованное содержимое каждого архива будет помещаться в отдельную вложенную папку, имя которой будет сгенерировано на основании имени архива.

· Не удалять файлы, извлечённые с ошибками

Если включено, WinRAR не будет удалять с диска файлы, извлечённые с ошибками (по умолчанию эти файлы удаляются). Такие файлы могут возникнуть, например, из-за повреждения архива. С помощью данного параметра вы можете попытаться получить из повреждённого файла хоть какую-то часть полезной информации.

· Показать файлы в Проводнике

По окончании распаковки WinRAR откроет окно Проводника Windows с содержимым папки, в которую были извлечены файлы.

· Сохранить установки

Нажмите эту кнопку, если вы хотите сохранить текущее состояние обеих частей окна извлечения (вкладки "Общие" и "Дополнительно"). В этом случае при следующем вызове окна извлечения сохранённое состояние будет восстановлено как используемое по умолчанию. Запоминаются все параметры, за исключением пути назначения. Если требуется указать путь назначения, принимаемый по умолчанию, воспользуйтесь окном параметров сжатия.


Ввод пароля для извлекаемого файла

Вы пытаетесь извлечь зашифрованный файл или просмотреть содержание зашифрованного архива. Введите пароль или откажитесь от выполнения операции.

При распаковке сразу нескольких архивов можно включить параметр "Для всех архивов", чтобы применить указанный пароль ко всем архивам. Если обрабатывается только один архив, этот параметр недоступен. Ещё одно применение данного параметра – пропуск зашифрованных архивов. Просто укажите в качестве пароля пустую строку и включите параметр "Для всех архивов".

Если вы уже сохраняли какие-то пароли, доступ к ним можно получить либо с помощью выпадающего списка, связанного с полем ввода пароля, либо воспользовавшись функцией автозавершения. Нажмите кнопку "Упорядочить пароли...", чтобы открыть окно управления паролями, в котором можно сохранять свои часто используемые пароли.

Если сохранённые пароли защищены главным паролем, то для доступа к ним нужно ввести главный пароль и нажать OK. Если введённый пароль отличается от главного пароля, то WinRAR будет считать его обычным паролем для операций с архивами.


Имя и параметры архива: Дополнительные параметры

NTFS

· Сохранять данные о правах доступа

Этот параметр предназначен только для файловой системы NTFS. Он позволяет сохранять данные о владельце, группе, правах доступа и аудит-информацию, если вы обладаете для этого достаточными правами доступа. Обработка данных о правах доступа может снизить скорость работы, поэтому параметр следует включать лишь тогда, когда это действительно необходимо (так, домашние пользователи в этом обычно не нуждаются). Обратите внимание, что файловая безопасность Windows NT имеется только в разделах с NTFS.

Поддерживается только для архивов RAR.

· Сохранять файловые потоки

Параметр предназначен только для файловой системы NTFS. Он позволяет сохранить в архиве альтернативные потоки данных, связанные с файлами, расположенными на диске с NTFS. Этот параметр может потребоваться включить, если вы пользуетесь какими-либо программами, хранящими данные в альтернативных потоках, и вам нужно сохранить эти потоки. Для файлов с установленным NTFS-атрибутом "Зашифрованный" потоки не сохраняются.

Поддерживается только для архивов RAR.

Сохранять символические ссылки как ссылки

Хранить символические ссылки и точки соединения NTFS как ссылки, не архивируя содержимое файлов. При извлечении из архива такие элементы восстанавливаются как символические ссылки или как точки соединения. Чтобы можно было создавать символические ссылки при извлечении, нужно запускать WinRAR от имени администратора. Символические ссылки, которые указывают на объекты вне целевой папки, содержат абсолютные пути, чрезмерное количество элементов ".." в объекте назначения или другие потенциально опасные параметры ссылки, могут представлять угрозу безопасности. Поэтому они извлекаются, только если включён параметр "Разрешить абсолютные пути в символических ссылках" в окне извлечения или в командной строке указан ключ -ola.

Поддерживается только для архивов RAR 5.0.

Сохранять жёсткие ссылки как ссылки

Если среди архивируемых файлов содержится несколько жёстких ссылок NTFS, первая жёсткая ссылка добавляется в архив как обычный файл, а остальные ссылки из того же набора — как ссылки на этот первый файл. При извлечении таких файлов WinRAR будет создавать жёсткие ссылки, а не обычные файлы.

После создания архива нельзя удалять или переименовывать первую жёсткую ссылку в архиве, иначе станет невозможным извлечение последующих ссылок. Если вы измените первую ссылку, последующие ссылки при извлечении также будут иметь изменённое содержимое. Для успешного извлечения последующих ссылок команда извлечения должна быть сначала вызвана для первой жёсткой ссылки.

Поддерживается только для архивов RAR 5.0.

Тома

· Пауза после каждого тома

По умолчанию WinRAR запрашивает подтверждение на создание или распаковку тома только при использовании съёмных носителей. Если включить данный параметр, то запросы на подтверждение будут выдаваться всегда. Это может пригодиться при недостатке места на диске, когда каждый созданный архивный том нужно сразу же вручную копировать на другое устройство.

Поддерживается только для томов RAR.

· Старый стиль именования томов

По умолчанию архивные тома RAR получают имена вида 'volname.partNNN.rar', где NNN — номер тома. Для формата архива RAR 4.x этот параметр даёт возможность выбирать старую схему именования томов на основе изменения расширений файлов: первый том получает расширение .rar, а все последующие тома нумеруются от .r00 до .r99. Архивы RAR 5.0 не поддерживают ни этот параметр, ни именование на основе изменения расширений файлов.

· Томов для восстановления

Это поле доступно только при создании многотомного архива RAR. В этом случае вы можете просто указать, сколько для этого архива требуется создать томов для восстановления. К числовому значению допускается добавлять знак процента (%), и тогда количество создаваемых файлов .rev будет вычисляться как указанный процент от общего числа томов многотомного RAR-архива. С помощью каждого тома для восстановления можно воссоздать любой один отсутствующий архивный том. Подробнее об этой функции см. здесь.

Система

· Архивировать в фоновом режиме

Если включено, WinRAR при запуске архивации будет сворачиваться в область уведомлений панели задач (в системный лоток рядом с часами).

· По окончании операции выключить компьютер

Если выбрано, то по завершении операции компьютер будет отключён (разумеется, он должен аппаратно поддерживать отключение питания).

· Ждать, если работает другая копия WinRAR

Если в данный момент в системе выполняется ещё одна копия WinRAR, которая создаёт, модифицирует или распаковывает какой-либо архив, и включён этот параметр, то операция будет начата, только когда другая копия WinRAR завершит свою работу или будет приостановлена. В случае, когда требуется выполнять серию операций по архивированию или распаковке данных, такое последовательное выполнение способно снизить нагрузку на диски и повысить общую производительность.

Отменить этот параметр для текущей операции можно нажатием кнопки "Продолжить" в окне хода операции. При нажатии этой кнопки WinRAR выходит из состояния ожидания вне зависимости от того, работают сейчас другие копии WinRAR или нет.

Данные для восстановления

Здесь можно указать объём данных для восстановления в процентах от общего размера архива. Чем больше размер таких данных, тем более серьёзные повреждения архива могут быть устранены с их помощью, но и тем сильнее увеличиваются размер архива и время на обработку, поэтому в большинстве случаев оптимальным будет 3–10%. Это значение используется только при включённом параметре "Добавлять данные для восстановления" на вкладке "Общие" этого окна. Нулевое значение установить нельзя. Вместо этого, если вам не нужны данные для восстановления, выключите параметр "Добавлять данные для восстановления".

Параметры сжатия…

Открывает окно "Дополнительные параметры сжатия", в котором можно настроить различные алгоритмы сжатия. Имейте в виду, что неправильные установки в этом окне способны значительно ухудшить работу архиватора, поэтому используйте их осторожно.

Параметры SFX…

Позволяет выбрать модуль самораспаковки и настроить ряд дополнительных параметров SFX, например путь назначения или заголовок окна. Обратите внимание, что параметры SFX можно задавать только для Windows-модулей с графическим интерфейсом (GUI), консольные и не-Windows модули SFX их не поддерживают. Кнопка "Параметры SFX" доступна только при включённом параметре "Создать SFX-архив" на вкладке "Общие" этого окна.

Сделанные настройки параметров SFX можно сохранить в профиле архивации; WinRAR поместит команды, описывающие параметры SFX, в комментарий архива.


Имя и параметры архива: Резервные копии

Параметры для резервного копирования

· Очищать сменный носитель перед архивацией на него

Перед созданием архива с целевого носителя будут удалены все файлы и папки. Если вы создаёте тома, то удаление будет осуществляться перед созданием нового тома, что даёт возможность архивировать на непустые сменные носители. При использовании этого режима вы должны быть уверены, что на целевых носителях нет нужной вам информации. Этот параметр применим только к сменным носителям, содержимое жёсткого диска им не удаляется.

· Добавлять только файлы с установленным атрибутом "Архивный"

Если включено, в архив будут добавлены только файлы с установленным атрибутом "Архивный". Папки добавляются вне зависимости от их атрибутов. Этот параметр полезен при резервном копировании.

· Снимать у файлов атрибут "Архивный" после упаковки

После успешной упаковки файлов у них будет снят атрибут "Архивный".

· Открывать совместно используемые файлы

Включать в обработку файлы, открытые для записи другими программами. Это опасный параметр, так как он позволяет заархивировать те файлы, которые в тот же момент могут быть изменены другой программой. Пользуйтесь этим параметром осторожно!

· Добавлять к имени архива окончание по маске

При создании архива добавляет к его имени строку с текущей датой. Это удобно при периодическом снятии резервных копий. Формат добавляемой строки задаётся маской. Подробности см. в разделе о ключе -ag.

· Сохранять предыдущие версии файлов

Этот параметр включает режим сохранения в уже созданном архиве предыдущих версий файлов при добавлении в архив файлов более новых версий. Старые версии получают имена вида 'filename;n', где 'n' — номер версии. Применимо только для архивов RAR.


Имя и параметры архива: Комментарий

Здесь можно указать комментарий для нового или обновляемого архива. Добавить комментарий можно двумя способами: указать имя файла, содержащего текст комментария, в поле "Загрузить комментарий из файла", либо ввести комментарий самостоятельно в расположенном ниже окне.


Имя и параметры архива: Файлы

Добавляемые файлы

Имена файлов и папок, добавляемых в архив. Это поле автоматически заполняется списком файлов, выделенных в окне файлов WinRAR, но вы можете изменить этот список самостоятельно или нажать кнопку "Добавить", чтобы выбрать дополнительные файлы.

Здесь допускается использовать маски-шаблоны — в этом случае WinRAR будет искать файлы, соответствующие маске, в текущей и вложенных папках. Если нужно указать несколько масок, разделяйте их пробелами. Если в маске содержатся пробелы, то она должна быть заключена в кавычки. Например, для добавления в архив всех файлов .txt и .doc можно ввести:

*.txt *.doc "set 1.*"

Файлы, исключаемые из обработки

В этом поле можно указать маски и имена файлов, которые должны быть исключены из операции архивирования. Маски допускается указывать и в именах файлов, и в их путях. Если нужно указать несколько масок, разделяйте их пробелами. Если в маске содержатся пробелы, то она должна быть заключена в кавычки. Например, чтобы исключить из обработки файл c:\temp\info.txt, все файлы .bak и .tmp, все папки temp и все файлы в папках temp, введите:

c:\temp\info.txt *.bak *.tmp *\temp\

Вы можете вводить имена файлов вручную или воспользоваться кнопкой "Добавить", чтобы выбрать их в дереве папок.

Подробная информация о синтаксисе масок исключения приведена в описании ключа -x. Этот ключ использует тот же формат масок исключения, что и поле "Файлы, исключаемые из обработки".

Файлы, добавляемые в архив без сжатия

В этом поле можно указать маски и имена файлов, которые должны помещаться в архив без сжатия. Это может быть полезно для того, чтобы не тратить попусту время на попытку сжать уже сжатые файлы. Тем самым можно добиться увеличения скорости создания/обновления архивов, практически не принося в жертву общую степень сжатия. Если нужно указать несколько масок, разделяйте их пробелами. Если в маске содержатся пробелы, то она должна быть заключена в кавычки. Например, чтобы упаковать без сжатия все архивы RAR и ZIP, а также графические файлы JPG, введите:

*.rar *.zip *.jpg

Сохранение путей файлов при добавлении в архив

Выбрать метод хранения в архиве путей файлов. WinRAR способен сохранять пути относительно текущей папки (по умолчанию), полные пути без буквы диска и идущего в начале символа обратной косой черты, сохранять только имена файлов без путей, а также сохранять полные пути, включая букву диска.

При сохранении имён без путей возможна ситуация, когда в архиве окажутся несколько файлов с одним и тем же именем, поэтому используйте параметр "Не сохранять пути" с осторожностью.

В режиме сохранения полных путей с буквой диска WinRAR заменяет разделители дисков (двоеточия) символами подчёркивания. Если в окне распаковки архива на вкладке "Дополнительно" выбрать параметр "Извлекать с абсолютными путями", WinRAR заменит эти символы подчёркивания на двоеточия и создаст извлечённые из архива файлы в их исходных папках и дисках. Более подробные сведения о потенциальных преимуществах и опасностях режима "Сохранять полные пути, включая букву диска", см. в описании ключа -ep3, являющегося эквивалентом данного параметра WinRAR для командной строки.

Архив

· Помещать каждый файл в отдельный архив

Каждый выбранный файл или папка будут помещены в отдельные архивы. Если включить этот параметр, то введённое имя архива станет трактоваться только как путь назначения для новых архивов (если это не папка, то часть, обозначающая имя, игнорируется), а имена создаваемых архивов будут генерироваться на основе имён файлов.

· Отправить архив по электронной почте на адрес [<адрес>] [после чего удалить]

Данный параметр позволяет прикрепить созданный архив к сообщению электронной почты. При этом требуется, чтобы в системе была установлена почтовая программа, совместимая с интерфейсом MAPI (этот интерфейс поддерживают большинство современных почтовых клиентов). Указывать здесь адрес электронной почты необязательно: если оставить поле пустым, то он будет запрошен почтовой программой. Также допускается указывать несколько адресов, разделяя их запятыми или точками с запятой. Если отметить пункт "после чего удалить", то после того как архив будет успешно прикреплён к электронному сообщению, он удаляется.

Если параметр "Отправить архив по электронной почте" используется при создании многотомного архива, то каждый том будет прикреплён к отдельному электронному письму.


Имя и параметры архива: Общие параметры

Это окно содержит следующие элементы:

Имя архива

Введите имя вручную или нажмите кнопку "Обзор" для выбора архива на диске. Можно ввести имя, содержащее букву диска или полный путь к архиву.

Кнопка "Профили..."

Открывает меню, позволяющее создать новый профиль, упорядочить существующие и выбрать один из профилей архивации. Профили позволяют быстро восстановить ранее сохранённые параметры архивации или указать параметры по умолчанию для данного окна. После инсталляции в WinRAR доступно несколько предопределённых стилей (например для создания вложений в электронные письма, резервного копирования и др.). Имя текущего активного профиля отображается над кнопкой "Профили...". Более подробную информацию см. в разделе "Профили архивации".

Формат архива (RAR, RAR4, ZIP)

Выбор формата создаваемого архива. Доступны следующие варианты: RAR — новейший формат RAR 5.0, RAR4 — формат, совместимый с WinRAR 4.x, и формат ZIP. В зависимости от выбранного архивного формата, некоторые расширенные параметры могут быть недоступны. При обновлении имеющегося архива данный параметр игнорируется, так как в этом случае WinRAR использует формат обновляемого архива.

Метод сжатия

Выбор одного из следующих методов упаковки: "Без сжатия", "Скоростной", "Быстрый", "Обычный", "Хороший" и "Максимальный". Метод "Без сжатия" помещает файлы в архив с максимально возможной скоростью без использования сжатия. Остальные методы сжимают данные — чем сильнее сжатие, тем ниже скорость архивирования.

Размер словаря

Здесь выбирается размер области памяти, используемый для поиска и сжатия повторяющихся элементов в обрабатываемых данных. Увеличение размера словаря иногда позволяет улучшить степень сжатия крупных файлов, особенно при создании непрерывного архива. Вместе с тем, увеличение размера словаря снижает скорость сжатия и повышает потребление памяти. Для сжатия нужно памяти примерно в шесть раз больше, чем размер словаря. При распаковке требуется память объёмом чуть больше однократного размера словаря. Если нужно, чтобы архив RAR 5.0 можно было распаковать на любых компьютерах, в том числе с малым количеством памяти, лучше избегать больших размеров словаря, выбирая что-то посередине, например 32 или 64 МБ.

Максимальный размер словаря для архивов RAR 4.x равен 4 МБ. В формате RAR 5.0 можно создавать архивы со словарём размером до 1 ГБ в 64-разрядной версии WinRAR, и до 256 МБ — в 32-разрядной версии (в Windows XP x86 – до 128 МБ). Распаковка требует меньше памяти, чем упаковка, поэтому обе версии WinRAR — 32- и 64-разрядная — способны распаковывать архивы с любым размером словаря, включая 1 ГБ, при условии, что в компьютере не менее 1 ГБ доступной памяти. Для формата ZIP размер словаря фиксированный и составляет 32 КБ.

Если размер всех исходных файлов для непрерывного архива или размер наибольшего исходного файла для обычного (не непрерывного) архива хотя бы вдвое меньше заданного размера словаря, то RAR может уменьшить размер словаря. Это снижает требования к памяти, не ухудшая сжатие.

Разделить на тома размером…

Если вы хотите создать многотомный архив, то введите здесь размер тома. В расположенном правее выпадающем списке можно выбрать единицу измерения. В этом списке "байт" означает байты, "КБ" — килобайты, "МБ" — мегабайты, "ГБ" — гигабайты.

Разрешается вводить десятичные дроби, разделяя целую и дробную части числа символом, определённым в региональных настройках Windows.

Объём томов также можно указывать добавлением одного или двух буквенных идентификаторов (все буквы латинские) после числового значения.

k | килобайты (множитель 1024)
K | тысячи байт (множитель 1000)
m | мегабайты (1 МБ = 1 048 576 байт)
M | миллионы байт (множитель 1 000 000)
g | гигабайты (1 ГБ = 1 073 741 824 байт)
G | миллиарды байт (множитель 1 000 000 000)

"KB", "MB" и "GB" всегда означают килобайты, мегабайты и гигабайты вне зависимости от регистра букв.

Поле ввода размера тома имеет выпадающий список, содержащий ранее вводившиеся, предустановленные и заданные пользователем значения. Этот список ускоряет выбор нужного размера. Список можно настроить в окне "Определение размеров томов", вызываемом кнопкой "Определить размеры томов…" в окне параметров сжатия.

Если вы создаёте многотомный архив на сменных дисках и используете формат RAR, то лучше выбрать пункт "Автоопределение" — в этом случае WinRAR будет подбирать размер каждого нового тома так, чтобы максимально заполнить имеющееся на диске свободное пространство.

Метод обновления

· Добавить с заменой файлов (действие по умолчанию)

Всегда заменять файлы в архиве одноимёнными добавляемыми файлами. Всегда добавлять файлы, которых ещё нет в архиве.

· Добавить с обновлением файлов

Заменять файлы в архиве только в том случае, если одноимённый добавляемый файл более новый. Всегда добавлять файлы, которых ещё нет в архиве.

· Обновить существующие файлы

Заменять файлы в архиве только в том случае, если одноимённый добавляемый файл – более новый. Не добавлять файлы, которых нет в архиве.

· Запрос перед перезаписью

Запрашивать подтверждение перед перезаписью файлов в архиве, имеющих те же имена, что и добавляемые файлы. Всегда добавлять файлы, которых нет в архиве.

· Пропускать существующие файлы

Не заменять файлы в архиве, имеющие те же имена, что и добавляемые файлы. Всегда добавлять файлы, которых нет в архиве.

· Синхронизировать содержимое архива

Заменять файлы в архиве только в том случае, если одноимённый добавляемый файл более новый. Всегда добавлять файлы, которых ещё нет в архиве. Удалять из архива те файлы, которых нет среди добавляемых. Это похоже на создание нового архива, но за одним важным исключением: если после прошлой архивации файлы не изменялись, то операция будет выполнена значительно быстрее, чем создание нового архива.

Параметры архивации

· Удалить файлы после упаковки

После архивации успешно упакованные исходные файлы удаляются.

· Создать SFX-архив

Будет создан не обычный архив, а самораспаковывающийся (SFX) в виде EXE-файла, для распаковки которого не требуется никаких дополнительных программ. В окне "Дополнительные параметры" можно выбрать тип SFX-модуля и задать несколько других параметров самораспаковки, например папку назначения.

· Создать непрерывный архив

Этот параметр включает режим непрерывного архивирования. Непрерывные (solid) архивы, как правило, получаются более компактными, чем обычные, однако при этом следует учитывать некоторые их ограничения. Подробности см. в разделе о непрерывном архивировании.

· Добавить данные для восстановления

В архив будут добавлены данные для восстановления, которые могут помочь восстановить архив в случае его повреждения. В окне "Дополнительные параметры" можно указать размер данных для восстановления (по умолчанию он составляет 3% от общего размера архива).

· Протестировать файлы после упаковки

После помещения файлов в архив они будут там протестированы, что особенно полезно в сочетании с включённым параметром "Удалить файлы после упаковки", так как исходные файлы будут удалены с диска только в том случае, если после их добавления в архив он успешно прошёл тестирование.

· Заблокировать архив

Заблокированный архив нельзя изменить средствами WinRAR. Блокирование может быть полезно для важных архивов, чтобы предотвратить их случайную модификацию.

Установить пароль…

Эта кнопка позволяет установить пароль для шифрования файлов. Заданный здесь пароль действует только в течение одной операции архивирования и имеет более высокий приоритет, чем пароль по умолчанию, указываемый в меню "Файл". После сеанса архивации введённый пароль не сохраняется; и текущим становится пароль по умолчанию (если же пароля по умолчанию не было, то по окончании архивации его тоже не будет).


Окно указания имени и параметров архива

Это окно отображается при выполнении команды "Добавить в архив" непосредственно перед добавлением файлов в архив.

Параметры в этом окне поделены на несколько групп:

Общие

Дополнительно

Опции

Файлы

Резервные копии

Время

Комментарий


Имя и параметры архива: Опции

Режим удаления

Все указанные ниже опции удаления изменяют поведение параметра "Удалить файлы после упаковки" на вкладке Общие. Любая из этих опций действует только при включённом параметре "Удалить файлы после упаковки". Любую из опций можно включить в профиль архивации по умолчанию, чтобы изменить стандартное поведение параметра "Удалить файлы после упаковки".

· Удалить файлы

Удалить файлы обычным образом. Файлы удаляются окончательно, но без гарантии уничтожения информации, поэтому в некоторых случаях данные можно восстановить с помощью специального ПО.

· Переместить файлы в Корзину

Удалённые файлы помещаются в Корзину Windows.

· Уничтожить (затереть) файлы

Перед удалением файла содержащиеся в нём данные перезаписываются нулевыми байтами, чтобы нельзя было восстановить удалённые файлы, файл усекается и ему даётся временное имя.

Имейте в виду, что эта функция разработана для обычных жёстких дисков. При использовании с твердотельными накопителями (SSD) перезапись исходных данных может не работать из-за применяемой в SSD-накопителях технологии Wear Leveling (перераспределения блоков при записи) и более сложной адресации данных.

· Уничтожать файлы, если задан пароль

Если включён этот параметр, а файлы заархивированы с паролем, режим уничтожения (затирания) файлов используется вне зависимости от значений других параметров в группе "Режим удаления".

Применять этот параметр непосредственно в окне архивирования особого смысла нет, поскольку вместо этого можно просто включить параметр "Уничтожить (затереть) файлы". Поэтому данный параметр рассчитан на применение в профилях архивации. Если вы хотите, чтобы зашифрованные файлы всегда удалялись без возможности восстановления, то включите параметр "Уничтожать файлы, если задан пароль" в профиле архивации по умолчанию.

Особенности архива

Использовать контрольные суммы BLAKE2

Сохранять для файлов контрольные суммы BLAKE2. Доступно только для архивного формата RAR 5.0.

В архивах RAR целостность данных определяется по контрольным суммам, вычисляемым и сохраняемым для каждого файла в архиве. Для вычисления контрольных сумм WinRAR по умолчанию использует функцию CRC32. Для формата RAR 5.0 вместо CRC32 можно выбрать версию BLAKE2sp хеш-функции BLAKE2.

Длина вывода CRC32 составляет 32 бита. Возможностей CRC32 хватает для определения большинства непреднамеренных ошибок в данных, но их недостаточно для проверки подлинности файловых данных. Иными словами, если два файла имеют одну и ту же CRC32, нет гарантии, что у этих файлов одинаковое содержимое.

Длина вывода BLAKE2 равна 256 битам. Так как это криптостойкая хеш-функция, она практически гарантирует, что если у двух файлов одинаковое значение BLAKE2, содержимое этих файлов также одинаково. Кроме того, у BLAKE2 надёжнее, чем у более короткого CRC32, определение ошибок.

Поскольку вывод BLAKE2 длиннее, при выборе данного параметра результирующий архив получается чуть большего объёма.

Если заголовки архива не зашифрованы (не выбран параметр Шифровать имена файлов), контрольные суммы зашифрованных файлов RAR 5.0 изменены с помощью особого, зависящего от пароля алгоритма, чтобы по контрольным суммам нельзя было угадать содержимое файлов. Поэтому не ждите, что контрольные суммы зашифрованных файлов совпадут с обычными значениями CRC32 и BLAKE2.

Сохранять идентичные файлы как ссылки

Если выбран этот параметр, WinRAR перед началом архивирования анализирует содержимое файлов. Если обнаруживаются несколько идентичных файлов размером более 64 КБ, первый файл из набора сохраняется как обычный файл, а все остальные файлы — как ссылки на этот первый файл. Это позволяет уменьшить размер архива, но накладывает некоторые ограничения на результирующий архив. Первый файл из набора идентичных файлов в созданном архиве нельзя удалять или переименовывать, потому что это сделает невозможным извлечение остальных ссылающихся на него файлов. Если изменить содержимое первого файла, то при извлечении изменёнными будут и все остальные ссылающиеся на него файлы. Команда извлечения должна применяться сначала к первому файлу, чтобы остальные файлы были успешно созданы.

Данный параметр рекомендуется применять только при сжатии большого количества идентичных файлов и если архив в дальнейшем не предполагается изменять, а распаковывать его вы будете полностью, без необходимости извлекать или пропускать отдельные файлы. Если все идентичные файлы достаточно малы, чтобы уместиться в словаре сжатия, то более гибкое решение, нежели данный параметр, даёт непрерывное (solid) архивирование.

Поддерживается только в архивах RAR 5.0.

Информация для быстрого открытия архива

В RAR-архивах непосредственно перед данными каждого файла находится его заголовок, содержащий такие сведения, как имя файла, время, размер и атрибуты. Такой метод более устойчив к повреждениям, нежели хранение заголовков всех файлов в одном непрерывном блоке, разрушение или усечение которого способно повлечь уничтожение всего содержимого архива. Однако хотя такая реализация и более надёжна, у неё есть и недостаток: поскольку файловые заголовки рассредоточены по всему архиву, доступ к ним не столь быстрый, как при хранении заголовков в одном блоке, что может быть заметно, когда нужно быстро открыть содержание архива в таких графических оболочках, как, например, WinRAR.

Чтобы повысить скорость открытия архивов и вместе с тем не делать весь архив зависящим от повреждения одиночного блока, архивы RAR 5.0 могут содержать факультативную запись для быстрого открытия. Такая запись добавляется в конец архива и содержит копии имён файлов и другую информацию о находящихся в архиве файлах в одном непрерывном блоке в дополнение к обычным файловым заголовкам внутри архива. Поскольку блок непрерывный, его содержимое считывается быстро, без необходимости выполнять множество операций чтения с диска. Каждый файловый заголовок в таком блоке защищён контрольной суммой. Если WinRAR обнаруживает, что информация для быстрого открытия повреждена, он переходит к чтению индивидуальных заголовков внутри архива, поэтому устойчивость к повреждениям не понижается.

Запись для быстрого открытия содержит полную копию файлового заголовка, которая может занимать несколько десятков или сотен байт на файл, и на этот же объём увеличивается размер архива. Такое увеличение размера наиболее заметно, если архив содержит большое количество маленьких файлов, когда размер файловых данных сопоставим с размером файловых заголовков. Поэтому по умолчанию, в режиме "Добавлять для крупных файлов", WinRAR сохраняет копии заголовков только для относительно больших файлов и продолжает использовать локальные заголовки для маленьких. Конкретный порог размера файлов зависит от версии WinRAR. Такой подход обеспечивает разумный компромисс между скоростью открытия и размером архива. Если предпочтительнее скорость открытия архива вне зависимости от его размера, выберите параметр "Добавлять для всех файлов", чтобы сохранять копии заголовков всех файлов. Если же нужно получить архив наименьшего размера, а скорость открытия его в других программах неважна, выберите параметр "Не добавлять", чтобы полностью исключить информацию для быстрого открытия.

Если вы хотите оценить влияние этой настройки на производительность, удостоверьтесь, что содержимое архива не находится в дисковом кэше. Когда архивный файл находится в кэше, реальных операций поиска на диске не выполняется, так что доступ к файловым заголовкам будет быстрым даже без использования информации для быстрого открытия.


Имя и параметры архива: Время

· Сохранять время изменения, создания, последнего доступа к файлам

Разрешить сохранение в архиве времени изменения, создания, последнего доступа к файлам. Поддерживается только в архивах RAR. Отключить хранение времени изменения файлов можно только в архивах формата RAR 5.0. Если какое-то из этих времён не сохранено в архиве, то при извлечении оно будет таким же, как текущее время в системе.

Чтобы восстановить время создания и последнего доступа у извлекаемых файлов, нужно включить параметры "Установить время создания" и "Установить время последнего доступа" на вкладке "Дополнительно" в окне извлечения. Восстановление времени изменения включено по умолчанию.

· Формат времени высокой точности

Если данный параметр выключен, время последнего изменения файлов сохраняется с двухсекундной точностью для архивов RAR 4.x и ZIP, и с секундной точностью для архивов RAR 5.x. Активизация этого параметра может слегка увеличить размер архива, однако при этом WinRAR будет сохранять время файла с точностью 0,0000001 секунды.

Если включить этот параметр при архивировании в ZIP, то WinRAR будет записывать в результирующий архив с высокой точностью все три времени. В отличие от формата RAR, мы не можем сохранять в ZIP с высокой точностью только какое-то одно время.

· Обрабатывать файлы: с любым временем / старше, чем / новее, чем / изменённые до / изменённые после

По умолчанию у этого параметра принимается значение "с любым временем", т.е. WinRAR будет архивировать все выбранные файлы независимо от их времени. При выборе значения "старше, чем" или "новее, чем " WinRAR будет архивировать только те файлы, у которых время модификации старше или младше указанного количества дней, часов и минут. Например, это может оказаться полезным, когда требуется заархивировать только файлы, которые изменялись за последние три дня. Варианты "изменённые до" и "изменённые после" позволяют выбрать только те файлы, у которых время модификации старше или моложе конкретной указанной даты.

· Установить время архива по: текущему системному времени / времени исходного архива / времени самого нового файла

По умолчанию у этого параметра принимается значение "по текущему системному времени", т.е. каждому создаваемому или изменяемому архиву присваивается текущее системное время как время модификации. Если вы хотите, чтобы при изменении архива у него не изменялась метка времени, выберите вариант "по времени исходного архива". При указании значения "по времени самого нового файла" архив получит такое же время модификации, как у содержащегося в нём самого нового файла.


Brian Gladman's AES implementation

Реализация AES Брайана Гладмана (Brian Gladman)

Применяемые в WinRAR алгоритмы шифрования и дешифрования используют части кода реализации AES Брайана Гладмана (Brian Gladman), лицензированной на следующих условиях:

Copyright (c) 2002, Dr Brian Gladman < >, Вустер, Великобритания.

Все права защищены.

ЛИЦЕНЗИОННОЕ СОГЛАШЕНИЕ

Разрешается свободное распространение и использование этого программного обеспечения как его исходного кода, так и в бинарном виде (с изменениями или без таковых) при условии, что:

  1. распространение исходного кода включает вышеуказанные сведения об авторских правах, данный список условий и нижеследующий отказ от гарантий;
  2. распространение в бинарном виде включает вышеуказанные сведения об авторских правах, данный список условий и нижеследующий отказ от гарантий в документации и/или сопутствующих материалах;
  3. имя держателя авторских прав не используется для подтверждения/рекомендации продуктов, созданных с использованием данного ПО, без письменного на то разрешения.

В КАЧЕСТВЕ АЛЬТЕРНАТИВЫ, если это примечание остаётся в неизменном полном виде, данный продукт может распространяться в соответствии с условиями общедоступной лицензии (GPL) проекта по свободному распространению ПО (GNU). В этом случае условия GPL применяются ВМЕСТО тех, что указаны выше.

ОТКАЗ ОТ ГАРАНТИЙ

Данное программное обеспечение предоставляется по принципу 'как есть', без каких-либо явных или подразумеваемых гарантий его свойств, включая (но не ограничиваясь этим) его функциональность и/или пригодность.

Исходный код данного пакета, как и прочие ссылки, относящиеся к другим криптографическим технологиям и вычислительным проектам, доступны на сайте Брайана Гладмана.


Окно параметров архива

В этом окне содержатся команды для защиты архива от повреждений, создания томов для восстановления и блокировки архива. Все они поддерживаются только в архивах формата RAR.

Защита архива может помочь восстановить его в случае незначительного физического повреждения файла архива. Если вы хотите защитить архив от повреждений, то необходимо указать размер данных для восстановления в процентах от общего размера архива. Максимально допустимое значение — 100%. Если вы укажете 0 (ноль), то данных для восстановления в архиве не будет. Чем больше размер таких данных, тем более серьёзные повреждения могут быть восстановлены, однако вместе с тем увеличивается и размер всего архива, поэтому в большинстве случаев оптимальным значением будет 3—5%.

Особый случай защиты архива — создание томов для восстановления (файлов с расширением .rev). Это возможно, только если открытый архив – это первый файл в наборе томов многотомного архива, и тогда вам нужно просто указать количество создаваемых REV-файлов. К числовому значению в этом параметре также можно добавить знак процента (%), и тогда количество создаваемых файлов .rev будет вычисляться как указанный процент от общего числа томов RAR-архива. Каждый том для восстановления позволяет воссоздать один отсутствующий архивный том. Подробнее об этой функции см. здесь.

Если включить параметр "Заблокировать архив", то архив будет заблокирован. Это означает, что впоследствии содержимое данного архива уже нельзя будет изменить средствами WinRAR. Обычно данная функция применяется для защиты важных архивов от случайного изменения.

Тома для восстановления имеют более высокий приоритет, чем остальные параметры, и не могут использоваться совместно с ними. Если указать отличное от нуля количество файлов .rev, то WinRAR будет игнорировать параметры данных для восстановления и блокировки архива и станет создавать тома для восстановления.


Исходный код Info-ZIP

WinRAR включает в себя исходный код группы Info-ZIP, используемый для работы с архивами ZIP. Оригинальный исходный код Info-ZIP свободно доступен на ftp://ftp.info-zip.org/pub/infozip/ и www.info-zip.org.

Лицензия Info-Zip

Это версия лицензии Info-ZIP от 02 января 2009 г. Окончательная версия данного документа должна быть неограниченно доступна на странице ftp://ftp.info-zip.org/pub/infozip/license.html, а её копия - на странице http://www.info-zip.org/pub/infozip/license.html.

Copyright (c) 1990-2009 Info-ZIP. All rights reserved.

For the purposes of this copyright and license, "Info-ZIP" is defined as the following set of individuals:

Mark Adler, John Bush, Karl Davis, Harald Denker, Jean-Michel Dubois, Jean-loup Gailly, Hunter Goatley, Ed Gordon, Ian Gorman, Chris Herborth, Dirk Haase, Greg Hartwig, Robert Heath, Jonathan Hudson, Paul Kienitz, David Kirschbaum, Johnny Lee, Onno van der Linden, Igor Mandrichenko, Steve P. Miller, Sergio Monesi, Keith Owens, George Petrov, Greg Roelofs, Kai Uwe Rommel, Steve Salisbury, Dave Smith, Steven M. Schweda, Christian Spieler, Cosmin Truta, Antoine Verheijen, Paul von Behren, Rich Wales, Mike White.

This software is provided "as is," without warranty of any kind, express or implied. In no event shall Info-ZIP or its contributors be held liable for any direct, indirect, incidental, special or consequential damages arising out of the use of or inability to use this software.

Permission is granted to anyone to use this software for any purpose, including commercial applications, and to alter it and redistribute it freely, subject to the above disclaimer and the following restrictions:

  1. Redistributions of source code (in whole or in part) must retain the above copyright notice, definition, disclaimer, and this list of conditions.

  2. Redistributions in binary form (compiled executables and libraries) must reproduce the above copyright notice, definition, disclaimer, and this list of conditions in documentation and/or other materials provided with the distribution. Additional documentation is not needed for executables where a command line license option provides these and a note regarding this option is in the executable's startup banner. The sole exception to this condition is redistribution of a standard UnZipSFX binary (including SFXWiz) as part of a self-extracting archive; that is permitted without inclusion of this license, as long as the normal SFX banner has not been removed from the binary or disabled.

  3. Altered versions--including, but not limited to, ports to new operating systems, existing ports with new graphical interfaces, versions with modified or added functionality, and dynamic, shared, or static library versions not from Info-ZIP--must be plainly marked as such and must not be misrepresented as being the original source or, if binaries, compiled from the original source. Such altered versions also must not be misrepresented as being Info-ZIP releases--including, but not limited to, labeling of the altered versions with the names "Info-ZIP" (or any variation thereof, including, but not limited to, different capitalizations), "Pocket UnZip," "WiZ" or "MacZip" without the explicit permission of Info-ZIP. Such altered versions are further prohibited from misrepresentative use of the Zip-Bugs or Info-ZIP e-mail addresses or the Info-ZIP URL(s), such as to imply Info-ZIP will provide support for the altered versions.

  4. Info-ZIP retains the right to use the names "Info-ZIP," "Zip," "UnZip," "UnZipSFX," "WiZ," "Pocket UnZip," "Pocket Zip," and "MacZip" for its own source and binary releases.


CRC32-алгоритм Intel Slicing-by-8

WinRAR использует функцию вычисления контрольных сумм CRC32 на основе алгоритма Intel Slicing-by-8.

Исходный код Intel Slicing-by-8 доступен на странице sourceforge.net/projects/slicing-by-8 и лицензирован по лицензии BSD, доступной на странице http://www.opensource.org/licenses/bsd-license.html. Ниже приведён текст лицензии BSD:

Copyright (c) 2004-2006 Intel Corporation.
All Rights Reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  • Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  • Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.


Лицензия и информация о покупке

Выберите один из следующих разделов:

Лицензия на использование WinRAR

Информация о покупке


Ввод главного пароля

Введите главный пароль, чтобы зашифровать записи о паролях в реестре, защитив их таким образом от несанкционированного доступа. После этого для доступа к паролям вам потребуется вводить в окне запроса главный пароль. Будучи однажды введённым, главный пароль действует до закрытия WinRAR. Чтобы посмотреть, как работает защита, после указания главного пароля закройте WinRAR и откройте его снова. Чтобы удалить шифрование ранее защищённых паролей, введите пустой пароль.

В действительности шифрование происходит после нажатия OK в родительском окне "Управление паролями", а не сразу после закрытия этого запроса главного пароля.


Хранение пароля в профиле упаковки

Хранение пароля в профиле архивации

Если не задан главный пароль, сохранённые в профилях архивации пароли не шифруются и потому их может увидеть каждый, у кого есть доступ к вашему компьютеру. Чтобы зашифровать хранящиеся в реестре парольные данные, защитив их от неавторизованного доступа, нужно задать главный пароль. После этого, чтобы получить доступ к такому профилю архивации, нужно будет при запросе пароля вводить главный пароль.

Вы можете использовать тот же пароль, что и в органайзере паролей, либо выбрать другой. Допускается даже присваивать разные главные пароли разным профилям архивации, хотя это может быть и неудобным в работе.

Будучи введённым, главный пароль остаётся действительным при последующем чтении профилей до закрытия WinRAR или до выбора профиля с другим главным паролем. Если вы хотите посмотреть, как работает защита, после указания главного пароля закройте WinRAR и откройте его снова.


Кодировка имён

Меню "Кодировка имён" находится в меню "Параметры", либо его можно быстро вызвать сочетанием клавиш <Ctrl+E>. Оно позволяет выбрать кодировку для имён файлов в архиве. Этот выбор влияет на просмотр содержимого архива и команды извлечения. Обычно следует предпочесть пункт "По умолчанию", чтобы WinRAR выбирал кодировку сам на основании языковых установок Windows и знаний о типичных параметрах формата архива. Однако если выбор "По умолчанию" даёт неудовлетворительный результат, то в этом меню можно указать другую кодовую страницу.

Сделанный пользователем выбор действует до закрытия WinRAR, либо пока не будет выбран другой пункт в этом меню. Если нужно сохранить текущую выбранную кодировку, чтобы она применялась постоянно, выберите пункт "Сохранить текущую". Делать это следует только в случае, когда приходится обрабатывать множество архивов с одной и той же кодовой страницей, которую WinRAR не распознаёт автоматически, иначе лучше выбрать пункт "По умолчанию". Вариант "По умолчанию" можно вернуть, указав его в меню, а затем выбрав "Сохранить текущую".

Если архив содержит имена файлов в Юникоде, и WinRAR может это достоверно определить, то выбранное в данном меню значение игнорируется и используется Юникод. Меню "Кодировка имён" применяется, если нет имён в Юникоде, либо когда не удаётся уверенно определить кодировку. Хотя это меню доступно как вне, так и внутри архивов, выбор кодовой страницы влияет только на имена файлов в архивах и игнорируется для обычных (не архивированных) файлов.


Окно "Управление профилями";Управление профилями;Профили, управление

Окно "Управление профилями"

В этом окне можно исправить некоторые параметры уже существующего профиля архивации или удалить его. Создать новый профиль здесь нельзя, для этого нужно воспользоваться способами, описанными в разделе "Профили архивации".

Для изменения параметров профиля необходимо выбрать профиль, нажать кнопку "Изменить" и в появившемся окне "Параметры профиля" установить необходимые параметры. Обратите внимание, что параметры архивации, сохранённые в профиле, изменить нельзя. Можно откорректировать только несколько параметров, непосредственно связанных с профилем, например его имя или значение параметра, разрешающего использовать этот профиль по умолчанию. Если необходимо изменить параметры архивации, то следует создать новый профиль с таким же именем, как у уже существующего.

Для удаления профиля выберите его в списке и нажмите кнопку "Удалить".

Чтобы переместить в списке профиль под курсором, используйте кнопки "Выше" и "Ниже".

Профиль, который используется по умолчанию, обозначается в списке профилей значком WinRAR ("стопка книг") слева от его имени.


Окно "Управление темами"

Это окно позволяет манипулировать интерфейсными темами WinRAR.

Нажмите кнопку "Выбрать", чтобы сделать активной тему, на которой стоит курсор. С помощью кнопки "Добавить" можно установить файл с новой темой. Кнопка "Удалить" не только убирает из списка тему, на которой стоит курсор, но и удаляет с диска все относящиеся к этой теме файлы, поэтому вы уже не сможете выбрать её снова.

Параметр "Применить к значкам архивов" относится ко всем темам. Если этот параметр выключен, темы модифицируют только графический интерфейс WinRAR, но не изменяют значки, которыми обозначаются в системе RAR, ZIP и др. архивные файлы. Если же параметр включён, то подвергаются изменению и графика WinRAR, и значки архивов. В отличие от остальных команд в этом окне, для подтверждения изменения состояния параметра "Применить к значкам архивов" необходимо нажать кнопку OK.


Управление паролями

Окно управления паролями служит для сохранения часто используемых паролей и быстрого к ним доступа в дальнейшем. Оно содержит список сохранённых пользователем записей о паролях. Обычно в этом списке содержатся метки паролей и маски архивов, но если если метка не была задана, вместо неё в колонке "Метка" отображается сам пароль.

Окно управления паролями вызывается из обычного окна ввода пароля WinRAR. Просто нажмите кнопку "Упорядочить пароли..." при вводе пароля по умолчанию или когда WinRAR потребует ввести пароль для зашифрованного файла или архива.

Нажмите кнопку "Добавить", чтобы внести новый пароль в список в позиции ниже курсора. Откроется окно "Информация о пароле", в котором можно указать текст пароля, метку и архивную маску. Более подробные сведения приведены в разделе "Окно информации о пароле".

Кнопка "Удалить" в окне управления паролями позволяет удалить все выбранные записи. Кнопка "Изменить" служит для изменения параметров записи под курсором. Кнопки "Выше" и "Ниже" изменяют расположение выбранных паролей в списке.

Нажмите кнопку "Установить главный пароль", введите главный пароль и затем нажмите OK в окне "Управление паролями", если хотите зашифровать записи о паролях, защитив их таким образом от несанкционированного доступа. После этого для получения к ним доступа потребуется вводить главный пароль в окне запроса. Будучи введённым, главный пароль остаётся действительным до закрытия WinRAR. Если вы хотите посмотреть, как работает защита, то после задания главного пароля закройте WinRAR и запустите его снова. Чтобы удалить шифрование с ранее защищённых записей о паролях, введите пустой пароль.

Если не задан главный пароль, пароли хранятся в системном реестре в незащищённом формате. Это означает, что их может увидеть любой, у кого есть доступ к вашему компьютеру. Если вам часто приходится использовать пароли, то органайзер паролей может упростить работу с ними, однако при этом нужно тщательно взвесить связанные с этим риски. Если защищаемая паролями информация – особо важная и конфиденциальная, то либо не пользуйтесь органайзером паролей, либо применяйте его только в компьютере, к которому ни у кого нет неавторизованного доступа, либо установите главный пароль.

Параметр "Автозавершение" позволяет использовать в окне ввода пароля функцию автозавершения паролей. Достаточно ввести только первые буквы пароля или метки пароля, и если эти пароль или метка имеются в списке сохранённых паролей, WinRAR предложит их полный текст. Функция автозавершения работает, только если в окне ввода пароля включён параметр "Отображать пароль при вводе". Если пароли скрыты, автозавершение отключено. Если для сохранённого пароля задана метка, автозавершение будет работать только для метки, но не для текста пароля.

Когда все изменения в списке паролей в окне управления паролями будут выполнены, необходимо нажать кнопку "OK", чтобы сохранить их.

Сохранённые пароли в окне ввода пароля доступны в выпадающем списке поля "Введите пароль" и как результат действия функции автозавершения.


Подтверждение перезаписи файла

Файл уже существует. Вы можете перезаписать его (кнопка "Да"), пропустить (кнопка "Нет"), переименовать (кнопка "Переименовать"), переименовать все (кнопка "Переименовать все"), перезаписать все файлы (кнопка "Да для всех"), пропустить все существующие файлы (кнопка "Нет для всех"), либо прервать текущую операцию (кнопка "Отмена").

При выборе режима "Переименовать все" переименованные файлы получают имена вида 'filename(N).txt', где 'filename.txt' – исходное имя файла, а 'N' – номер.


Окно "Параметры профиля";Параметры профиля;Профиль, параметры

Окно "Параметры профиля"

В этом окне можно описать новый профиль архивации или исправить параметры уже существующего профиля. Здесь доступны следующие элементы:

Имя профиля

Имя профиля — это текстовая строка, описывающая профиль. В имени могут содержаться пробелы, например вполне допустимо имя "Создать вложение в e-mail". Лучше давать профилям понятные имена, так как это значительно облегчит их идентификацию и управление. Данное поле должно быть заполнено.

Сохранить имя архива

Если этот параметр включён, то указанное ниже имя архива включается в профиль и будет восстанавливаться всякий раз при выборе профиля. Если же параметр выключен, то WinRAR будет предлагать имя архива как обычно.

Сохранить имена выделенных файлов

Если этот параметр включён, то в расположенной ниже строке можно указать имена файлов, которые будут записаны в архив. Если вы позднее выберете этот профиль, то WinRAR поместит в архив файлы, указанные в профиле, а не выбранные до загрузки профиля.

Вначале это поле содержит имена файлов, выбранных в списке файлов WinRAR, но вы можете ввести в этой строке другие имена. Допускается указывать имена папок и шаблоны. Например, можно создать профиль, у которого в поле "Сохранить имена выделенных файлов" будет "C:\". После вызова данного профиля будет заархивирован весь диск C:.

Если этот параметр выключен, то WinRAR заархивирует только выбранные файлы.

Сделать профилем по умолчанию

Если указано, что данный профиль — это профиль по умолчанию, то его параметры будут восстановлены при открытии окна "Имя и параметры архива" до начала любых операций. В профиле по умолчанию имеет смысл указывать параметры, которыми вы пользуетесь чаще всего, чтобы не устанавливать их каждый раз заново. Профилем по умолчанию может быть только один профиль. Если ни один профиль не назначен профилем по умолчанию, то в окне архивации используются значения по умолчанию.

Некоторые параметры применяемого по умолчанию профиля архивации используются не только при добавлении файлов в архив, но и при других операциях, модифицирующих архив, например при удалении или переименовании файлов. В этом случае WinRAR считывает только те параметры, которые подходят для текущей операции. При извлечении никакие параметры из применяемого по умолчанию профиля архивации не используются.

Немедленное выполнение

Если вы выберете из меню профиль с установленным параметром "Немедленное выполнение", то процесс архивации начнётся немедленно, без возможности поменять какие-либо параметры. Это полезно для устоявшихся операций архивации (например для создания резервных копий), поскольку после выбора такого профиля не нужно нажимать кнопку OK.

Создать ярлык на рабочем столе

Этот параметр доступен только при включённом параметре "Сохранить имена выделенных файлов". Он позволяет создать на рабочем столе значок с именем профиля, чтобы профиль можно было быстро активизировать щелчком по его значку. Например, можно создать профиль для резервного копирования файлов, а для упрощения операции поместить его ярлык на рабочий стол.

Добавить в контекстное меню

Если включён этот параметр, имя профиля будет отображаться в контекстных меню Проводника Windows, что позволяет активизировать профиль оттуда. Если также включить в профиле параметр "Немедленное выполнение", то архивирование будет начинаться сразу же при выборе этого профиля в контекстном меню. Если параметр "Немедленное выполнение" выключен, то сначала будет появляться окно выбора имени и параметров архива. При включённом параметре "Сохранить имя архива" WinRAR будет использовать сохранённое имя для нового архива. Если включён параметр "Сохранить имена выделенных файлов", то в архив будут добавлены как имена, сохранённые в профиле, так и выбранные в Проводнике.


Окно информации о пароле

Окно "Информация о пароле" вызывается нажатием кнопок "Добавить" или "Изменить" в окне "Управление паролями". Таким образом, вы можете либо ввести информацию о новом пароле, либо отредактировать запись об уже имеющемся пароле. Эта информация включает текст пароля (т.е. собственно пароль), метку, маску архивов в поле "Выбирать для архивов" и параметр "Принимать без подтверждения".

Единственное обязательное для заполнения поле – "Текст пароля". Оно должно содержать сохраняемый пароль.

Поле "Метка пароля" используется для того, чтобы в окне паролей не было видно настоящих паролей. Т.е. вы можете указать здесь метку для пароля и затем вводить не сам пароль, а эту метку всякий раз, когда потребуется указать пароль. WinRAR будет автоматически подменять такую метку паролем. О том, что была введена метка, окно пароля проинформирует вас сообщением "Введена метка пароля" прямо над полем ввода пароля.

Например, вы можете определить Fhtfl34Shu как текст пароля, и home как его метку. После этого вы можете вводить home вместо Fhtfl34Shu. Эта подстановка работает только в окне пароля. Она не влияет на режим командной строки и ключ -p[пароль].

Метки паролей должны быть уникальными. Они не должны совпадать ни с одной другой меткой или паролем. В метках не учитывается регистр букв, поэтому home и Home считаются одной и той же меткой.

Если вы указали и текст пароля, и метку, то в колонке "Метка" в окне "Управление паролями" будет отображаться метка. Если был указан только текст пароля, то в этом списке будет отображаться он.

Поле "Выбирать для архивов" может содержать одно или несколько имён или масок архивов (только имена, без пути), разделённых пробелами. Если в имени архива есть пробелы, такое имя должно быть заключено в кавычки. Если имя распаковываемого архива удовлетворяет одной из этих масок, WinRAR автоматически выберет пароль, указанный в поле "Текст пароля". Если параметр "Принимать без подтверждения" выключен, этот пароль будет установлен как принимаемый по умолчанию в окне ввода пароля, но у пользователя будет возможность его изменить. Если же параметр "Принимать без подтверждения" включён, пароль будет принят немедленно.

Например, если вы укажете MailDGWT58 как текст пароля, а в поле "Выбирать для архивов" введёте mymail*.rar mymail*.zip, то при распаковке архивов mymail*.rar и mymail*.zip будет автоматически выбираться пароль MailDGWT58. Этот параметр работает только при распаковке, не при архивировании.

Имейте в виду, что запомненные пароли хранятся в реестре Windows в виде обычного незашифрованного текста, поэтому их может увидеть любой, у кого есть доступ к вашему компьютеру. Таким образом, хотя функция хранения паролей делает более удобной работу с ними, вам нужно хорошо сознавать весь риск, который она несёт. Если защищённая паролем информация носит конфиденциальный характер, либо не пользуйтесь этой функцией, либо используйте её в компьютере, защищённом от неавторизованного доступа.


Окно "Результаты поиска"

В этом окне содержатся элементы, обнаруженные командой "Найти файлы". Здесь можно выделить один или несколько файлов, а затем распаковать их, нажав кнопку "Извлечь...". Кроме того, можно нажать кнопку "Просмотр", чтобы просмотреть содержимое файла под курсором, или "Выделить", чтобы поместить курсор на этот файл в главном окне WinRAR.

По техническим причинам операции с найденными файлами выполняются с некоторой задержкой, если при этом продолжается поиск. WinRAR выполнит команду только тогда, когда будет закрыт обрабатываемый в данный момент архив.


Окно "Дополнительные параметры SFX"

Это окно вызывается из команды "Преобразовать архив в SFX" нажатием кнопки "Дополнительные параметры SFX…". Он позволяет настроить ряд параметров самораспаковывающегося архива, например предлагаемый по умолчанию путь для извлечения, заголовок окна и текст. Он автоматически генерирует сценарий, состоящий из команд, описанных в разделе об SFX-модулях для Windows, поэтому от вас не требуется знание языка сценариев: вводить команды вручную необязательно, просто включите нужные параметры.

Обратите внимание, что параметры SFX применимы только к Windows-модулю с графическим интерфейсом (GUI), консольные и не-Windows модули SFX их не поддерживают.

SFX-параметры в этом окне разнесены по нескольким вкладкам:

SFX-параметры: Общие

SFX-параметры: Установка

SFX-параметры: Режимы

SFX-параметры: Дополнительно

SFX-параметры: Обновление

SFX-параметры: Текст и графика

SFX-параметры: Лицензия

SFX-параметры: Модуль


SFX-команды: Delete

Delete=<имя файла>

Перед началом извлечения удаляет указанный файл в папке назначения. Допускается использовать несколько команд Delete.

Если указанный в команде Delete файл заблокирован и не может быть удалён, SFX-модуль попытается перед извлечением переименовать его, дав ему временное имя, а после перезагрузки Windows - удалить. Успех этой операции зависит от используемой версии Windows.

Пример:

Delete=winrar95.exe

Delete=rarlng.dll


SFX-команды: License

License=<заголовок окна c Лицензионным соглашением>

{

текст лицензионного соглашения 1

текст лицензионного соглашения 2

…

}

Показывает лицензионное соглашение при запуске SFX-архива. Пользователь может либо принять это соглашение и продолжить распаковку, либо не принимать его и выйти.

Лицензионное соглашение может быть как в формате HTML, так и в виде обычного текста. В последнем случае SFX-модуль объединяет и переформатирует указанные текстовые строки так, чтобы они оптимально заполняли окно. Поэтому если вы хотите начать новый абзац, вставьте перед ним пустую строку.

С помощью языка HTML можно управлять цветами, шрифтами и форматированием выводимого текста. С описанием синтаксиса HTML вы можете ознакомиться на сайте WWW-консорциума. Кроме того, для подготовки текста в формате HTML подойдёт любой редактор web-страниц.

Если текст состоит из нескольких строк, SFX-модуль трактует символ '}' как признак конца текста, поэтому этот символ не следует указывать в тексте в самой первой позиции строки. Если же символ '}' всё-таки нужно использовать в начале строки, вставьте перед ним знак пробела.

Пример:

License=Лицензионное соглашение

{

Все права на программу RAR принадлежат исключительно её автору.

Это условно-бесплатная программа (shareware). Вы можете использовать её в течение пробного периода времени.

По окончании этого периода у вас должна проснуться совесть и сказать: "Я ДОЛЖЕН зарегистрировать программу".

}


SFX-параметры: Дополнительно

Это окно является частью окна "Дополнительные параметры SFX" и содержит следующие элементы:

Файлы, удаляемые в папке назначения

SFX попытается перед началом извлечения удалить один или несколько указанных файлов в папке назначения. Вы можете ввести здесь более одного файла - в этом случае имена файлов должны разделяться пробелами.

Если указанный в этом поле файл заблокирован другим процессом и потому не может быть удалён, SFX-модуль перед извлечением попытается переименовать его, дав этому файлу временное имя, а после перезагрузки Windows удалит его. Успех данной операции зависит от используемой вами версии Windows.

Соответствующая команда SFX-сценария: Delete

Ярлыки

После распаковки создать ярлыки для извлечённых из архива файлов. Нажмите кнопку "Добавить ярлык", чтобы определить новый ярлык. Параметры ярлыков см. в описании команды сценариев Shortcut. Область ниже кнопки "Добавить ярлык" содержит уже введённые ярлыки, при необходимости вы можете здесь отредактировать их.

Соответствующая команда SFX-сценария: Shortcut

Запрос административного доступа

Включите этот параметр, если нужно создать SFX-архив, который должен требовать права администратора при запуске в среде Windows Vista или более новых версиях Windows. На поведение SFX-архива в старых версиях Windows данный параметр не влияет.

Соответствующий ключ командной строки: -iadm


SFX-параметры: Общие

Это окно является частью окна "Дополнительные параметры SFX" и содержит следующие элементы:

Путь для распаковки

Здесь можно указать предлагаемый по умолчанию путь для извлечения файлов. Доступно три варианта: создавать путь в пользовательской папке "Program Files", в текущей папке, или же указать абсолютный путь. В первых двух случаях введённый путь не должен начинаться ни с буквы диска, ни с символа обратной черты (\). Для использования последнего варианта, напротив, путь должен начинаться с одного из них.

Соответствующая команда SFX-сценария: Path

· Сохранять и восстанавливать пути

Этот параметр позволяет SFX сохранять в реестре указанный пользователем путь назначения, а затем восстанавливать его при следующем запуске SFX-архива, у которого то же содержимое поля "Путь для распаковки". Исходное значение пути располагается в списке, ассоциированном с полем ввода пути назначения, поэтому у пользователя есть выбор между ранее введённым и исходным путями.

Данная возможность может пригодиться при установке новых версий или обновлений ПО в ту же папку, так как позволяет изменить предлагаемый путь на желаемый лишь единожды, не вводя его повторно каждый раз.

Для использования этой функции необходимо, чтобы поле "Путь для распаковки" было непустым.

Соответствующая команда SFX-сценария: SavePath

Сохранить текущие параметры как стандартные

Эта кнопка отображается, только если окно "Дополнительные параметры SFX" вызвано из команды "Преобразовать архив(ы) в SFX". Нажмите эту кнопку, чтобы сохранить установки, сделанные на всех вкладках данного окна. Сохранённые параметры будут в дальнейшем использоваться только при преобразовании архивов в самораспаковывающиеся. Для команд, модифицирующих архивы, используйте профиль архивации по умолчанию.


SFX-параметры: Лицензия

Это окно является частью окна "Дополнительные параметры SFX" и содержит следующие элементы:

Заголовок окна с лицензией

Введённый в этом поле текст будет отображаться как заголовок окна с лицензионным соглашением.

Соответствующая команда SFX-сценария: License

Текст лицензии

В этом поле вводится текст лицензионного соглашения, отображаемого при запуске SFX-архива. Пользователь может либо принять его и продолжить распаковку архива, либо не принимать и выйти.

Текст лицензии можно вводить в формате HTML либо в виде простого текста. В последнем случае SFX-модуль объединяет и переформатирует указанные текстовые строки так, чтобы они оптимально заполнили окно. Поэтому если вы хотите начать новый абзац, поместите перед ним пустую строку.

Используя HTML, вы можете управлять цветом, шрифтами и форматированием выводимого текста. С описанием синтаксиса HTML вы можете ознакомиться на сайте WWW-консорциума. Кроме того, для подготовки текста в формате HTML подойдёт любой редактор web-страниц.

Соответствующая команда SFX-сценария: License

Загрузить текст из файла

Загрузка содержимого выбранного файла как текста лицензии.


SFX-параметры: Режимы

Это окно является частью окна "Дополнительные параметры SFX" и содержит следующие элементы:

Временный режим / Распаковать во временную папку

Если включить этот параметр, SFX-модуль при выполнении создаст временную папку, извлечёт в неё все файлы, запустит программу, указанную в поле "Программа установки / Выполнить после распаковки", а по завершении работы этой программы удалит временную папку со всем её содержимым. При всех этих операциях SFX-модуль автоматически использует "тихий" режим вывода информации "Не показывать начальное окно", но при желании его можно переопределить на режим "Скрыть всё" (см. ниже). В качестве временной папки для распаковываемых файлов используется текущая папка программы установки.

Кроме того, вы можете ввести два необязательных строковых параметра, определяющих вопрос и заголовок окна с вопросом, выводимых перед извлечением. В этом случае извлечение начнётся, только если пользователь нажмёт кнопку "Да".

Если вы включили параметр "Распаковать во временную папку", то должны также указать программу установки. В этом режиме поле "Путь для извлечения" игнорируется.

Этот параметр может не работать с программой установки, выполнение которой прерывается раньше, чем её дочернего процесса. См. подробности в описании команды TempMode.

Соответствующая команда SFX-сценария: TempMode

Режим вывода информации

По умолчанию SFX-модуль запрашивает подтверждение начала извлечения и позволяет пользователю изменить путь распаковки. При выборе параметра "Не показывать начальное окно" этот запрос выдаваться не будет. Если вы также хотите отключить вывод экрана с лицензионным соглашением SFX и информации о распаковке архива, выберите пункт "Скрыть всё".

Соответствующая команда SFX-сценария: Silent


SFX-параметры: Модуль

Это окно является частью окна "Дополнительные параметры SFX" и позволяет выбрать самораспаковывающийся модуль. Обратите внимание, что не все модули поддерживают дополнительные параметры SFX. К числу поддерживающих расширенные настройки относятся GUI-модули RAR и ZIP (Default.SFX и Zip.SFX). Консольный модуль RAR (WinCon.SFX) дополнительных настроек не имеет.


SFX-параметры: Установка

Это часть окна "Дополнительные параметры SFX", она включает следующие установки:

Программа установки / Выполнить после распаковки

SFX попытается выполнить указанную программу после успешно завершившейся операции извлечения. Перед выполнением программы текущей назначается папка с извлечёнными файлами. Если имя программы содержит пробелы, оно должно быть заключено в кавычки.

Разрешается указывать несколько команд установки, по одной на строку. Если вы не хотите, чтобы все программы установки запускались одновременно, включите параметр "Ждать и устанавливать код возврата".

См. дополнительную информацию в разделе о команде Setup.

Соответствующая команда SFX-сценария: Setup

Программа установки / Выполнить до распаковки

SFX попытается выполнить указанную программу до начала извлечения файлов, поэтому данная программа уже должна быть на диске. Перед выполнением программы текущей назначается результирующая папка. Если имя программы содержит пробелы, оно должно быть заключено в кавычки. Эту команду можно использовать, например, для удаления предыдущей версии ПО, когда новая версия устанавливается поверх старой.

Разрешается указывать несколько команд установки, по одной на строку. Если вы не хотите, чтобы все программы установки запускались одновременно, включите параметр "Ждать и устанавливать код возврата".

Соответствующая команда SFX-сценария: Presetup

Программа установки / Ждать и устанавливать код возврата

Если включён этот параметр, SFX ждёт прекращения работы программы установки и устанавливает код возврата исполняемого SFX-файла равным коду возврата программы установки, увеличенному на 1000.

Если из-за какой-либо ошибки SFX не может запустить программу установки, он возвращает свои собственные коды ошибки, такие же, как коды возврата WinRAR, и которые всегда меньше 1000.

См. дополнительную информацию в разделе к команде SetupCode.

Соответствующая команда SFX-сценария: SetupCode


SFX-параметры: Текст

SFX-параметры: Текст и графика

Это окно является частью окна "Дополнительные параметры SFX" и содержит следующие элементы:

Заголовок окна SFX

Введённый в этом поле текст будет отображаться как заголовок окна SFX-архива.

Соответствующая команда SFX-сценария: Title

Текст в окне SFX

В этом поле нужно указать текст в формате HTML либо в виде простого текста, который будет отображаться в окне SFX-архива.

В случае простого текста SFX-модуль объединяет и переформатирует указанные текстовые строки так, чтобы они оптимально заполнили окно. Поэтому если вы хотите начать новый абзац, поместите перед ним пустую строку.

Используя HTML, вы можете управлять цветом, шрифтами и форматированием выводимого текста. С описанием синтаксиса HTML можно ознакомиться на сайте WWW-консорциума. Для подготовки текста в формате HTML подойдёт любой редактор web-страниц.

Соответствующая команда SFX-сценария: Text

Загрузить текст из файла

Загрузка содержимого выбранного файла как текста для окна SFX.

Загрузить логотип SFX из файла

Укажите здесь графический (*.bmp) файл с изображением логотипа для создаваемого или обновляемого SFX-архива.

Стандартный размер логотипа SFX — 93×302 пиксела. Рекомендуется использовать изображения такого же или меньшего размера.

Если вы собираетесь менять логотип, SFX-модуль не должен быть сжат какой-либо программой упаковки исполняемых файлов (например UPX).

Соответствующий ключ командной строки: -iimg.

Загрузить значок SFX из файла

В этом поле вы можете указать файл .ico со своим собственным значком, чтобы заменить им стандартный значок модуля SFX. При этом SFX-модуль не должен быть сжат какой-либо программой упаковки исполняемых файлов (например UPX).

Соответствующий ключ командной строки: -iicon


SFX-параметры: Обновление

Это окно является частью окна "Дополнительные параметры SFX" и содержит следующие элементы:

Режим обновления

· Извлечь и заменить файлы

Извлечь из архива все файлы вне зависимости от их времени.

· Извлечь и обновить файлы

Извлечь только те файлы, копий которых нет в папке назначения, или если извлекаемые файлы более новые, чем имеющиеся.

Соответствующая команда SFX-сценария: Update=U

· Обновить только существующие файлы

Извлечь только те файлы, которые существуют в папке назначения и их дата более старая, чем у соответствующих файлов в архиве. Если одноимённого файла на диске нет, то он пропускается.

Соответствующая команда SFX-сценария: Update=F

Режим перезаписи

· Выдавать запрос перед перезаписью (действие по умолчанию)

Запрашивать действие перед перезаписью файла.

· Перезаписывать все файлы без запроса

Перезаписывать файлы без выдачи запросов пользователю.

Соответствующая команда SFX-сценария: Overwrite=1

· Пропускать существующие файлы

Не перезаписывать уже имеющиеся файлы.

Соответствующая команда SFX-сценария: Overwrite=2


SFX-команды: Overwrite

Overwrite=[n]

Если параметр 'n' равен нулю, то при перезаписи существующих файлов будет выведен запрос на подтверждение. Это действие выполняется по умолчанию, поэтому для него необязательно указывать команду Overwrite. Если параметр 'n' отсутствует или равен '1', то все файлы будут перезаписываться без подтверждения. Если 'n' равно '2', то перезапись существующих файлов производиться не будет.

Пример:

Overwrite=1


SFX-команды: Path

Path=<путь>

Устанавливает путь, используемый по умолчанию для распаковки файлов. Абсолютные пути, т.е. начинающиеся с '<буквы диска>:', используются без изменений. Если <путь> содержит только имя, то он будет рассматриваться как начинающийся от папки "Program Files". Если вы хотите отменить подобное поведение, чтобы указанная папка создавалась в текущей папке, то начинайте <путь> с символов '.\' (точка и обратная косая черта).

Примеры:

а) Установить в качестве пути по умолчанию папку "Program Files\Calc 3.05":

Path=Calc 3.05

б) Установить в качестве пути по умолчанию папку "C:\Calc":

Path=C:\Calc

в) Установить в качестве пути по умолчанию папку "Calc" без какого-либо предшествующего пути:

Path=.\Calc

Примечания

  1. Допускается указывать в Path системные переменные окружения в формате %varname% (например "Path=%APPDATA%\MyApp"). SFX-модуль раскрывает их автоматически. Динамические переменные окружения, такие как %date% или %random%, не раскрываются.
  2. SFX-модуль устанавливает переменную окружения sfxstime, содержащую время запуска модуля в формате "ГГГГ-ММ-ДД-ЧЧ-ММ-СС-мс". Её можно указывать в команде Path, если требуется генерировать уникальный путь установки ПО на основе времени, например "Path=MyApp-%sfxstime%"


SFX-команды: Presetup

Presetup=<программа>

SFX-модуль попытается выполнить <программу> до начала извлечения файлов, поэтому <программа> должна уже быть на диске. Перед выполнением <программы> текущей папкой становится папка назначения. Эту команду можно использовать, например, для удаления предыдущей версии ПО при установке новой версии поверх старой. Если в имени программы есть пробелы, то оно должно быть взято в кавычки.

Пример:

Presetup=uninstall.exe /clean

Примечания

  1. SFX-модуль отображает кнопку "Извлечь" вместо "Установить", если в архивном комментарии нет команд Setup или Presetup. Если вы хотите, чтобы отображалась кнопка "Установить", но никакие программы установки не выполнялись, добавьте команду Setup без параметров.


SFX-команды: пример сценария

Приведённый ниже сценарий устанавливает для окна заголовок "Калькулятор v3.05", изменяет выводимый перед распаковкой стандартный текст на указанный, устанавливает путь распаковки по умолчанию в "Program Files\Calculator", разрешает перезапись существующих файлов и запускает файл setup.exe после извлечения из архива всех файлов.

Title=Калькулятор v3.05

Text

{

"Калькулятор" - условно-бесплатная программа. Вы можете

использовать её в течение 40-дневного пробного периода.

Если вы хотите с ней работать и по окончании этого

испытательного периода, то ДОЛЖНЫ зарегистрироваться.

}

Path=Calculator

Overwrite=1

Setup=setup.exe


SFX-команды: SavePath

SavePath

Эта команда позволяет SFX сохранять в реестре введённый пользователем путь назначения, а затем восстанавливать его при следующем выполнении SFX-архива с тем же параметром команды Path. Исходное значение команды Path помещается в список, ассоциированный с полем ввода пути назначения, что даёт пользователю выбор между ранее введённым и исходным путями.

Эта возможность может пригодиться при установке новых версий или обновлений ПО в ту же папку, позволяя изменить предложенный путь на желаемый лишь единожды, а не вводить его повторно каждый раз.

Команду SavePath можно использовать только в сочетании с командой Path.

Пример:

Path=Calc 3.05

SavePath


SFX-команды: Setup

Setup=<программа>

После удачного извлечения файлов SFX-модуль попытается запустить указанную <программу>. При этом перед запуском <программы > текущей папкой будет сделана та, в которую были извлечены файлы. Если в имени программы есть пробелы, то оно должно быть взято в кавычки.

Пример:

Setup=setup.exe

Примечания

  1. Если у вас возникают проблемы при использовании сценария установки SFX для запуска файла setup.exe, созданного программой InstallShield, попробуйте вместо обычной командной строки "setup.exe" использовать строку "setup.exe /SMS". Ключ /SMS позволяет модулю SFX определить завершение работы инсталлятора InstallShield.
  2. Если указанная в команде Setup программа не имеет никаких параметров, то с помощью ключа -sp<параметр> командной строки SFX можно передавать этой программе дополнительные параметры.
  3. Перед запуском программы установки SFX-модуль создаёт переменные окружения sfxname, sfxcmd и sfxpar. В переменной sfxname содержится имя SFX-архива. Переменная sfxcmd содержит полную командную строку, полученную SFX-модулем, первый параметр этой командной строки – имя SFX-модуля. Переменная sfxpar содержит только параметры командной строки, без имени SFX-модуля. Таким образом, если программе установки нужны данные сведения, она может прочитать их из этих переменных. Кроме того, в качестве параметра можно указывать %имя_переменной%, например, "Setup=setup.exe %sfxpar%".
  4. SFX-модуль отображает кнопку "Извлечь" вместо "Установить", если в архивном комментарии нет команд Setup или Presetup. Если вы хотите, чтобы отображалась кнопка "Установить", но никакие программы установки не выполнялись, добавьте команду Setup=<>. Либо, если вы конфигурируете SFX-архив в окне параметров SFX, просто укажите <> в качестве имени программы установки. SFX-модуль не будет пытаться выполнить программу с таким именем, но изменит текст на кнопке.


SFX-команды: SetupCode

SetupCode

Если присутствует эта команда, SFX-архив ждёт, пока завершит работу программа, указанная в команде Setup или Presetup, и использует её код возврата, увеличенный на 1000, как код возврата исполняемого SFX-файла.

Если из-за какой-либо ошибки SFX не может запустить программу установки, он возвращает свои собственные коды ошибки, такие же, как коды возврата WinRAR. Например, если выполнение SFX аварийно прекратилось из-за ошибки контрольной суммы, SFX-процесс вернёт значение 3. Если SFX успешно запустил программу установки, и она завершила свою работу с нулевым кодом возврата, то код возврата SFX будет 1000. Если программа установки вернула значение 10, то SFX вернёт 1010.

Таким образом, если была указана команда SetupCode, а код возврата SFX меньше 1000, значит, произошла какая-то ошибка и программа установки даже не была запущена. Если программа установки устанавливает нулевой код возврата для успешного завершения и ненулевой - для завершения с ошибкой, то код возврата SFX, равный 1000, означает успешное завершение, а любой другой код - ошибку.

Если используются несколько команда Setup и Presetup и присутствует SetupCode, SFX будет ждать завершения каждой команды Setup и Presetup и вернёт наибольший код возврата, установленный программами установки.

Пример

Setup=setup.exe

SetupCode


SFX-команды: Shortcut

Shortcut=<Тип>,<ИсхФайл>,<РезПапка>,<Описание>,<ИмяЯрлыка>,<ЗначокЯрлыка>

Эта команда создаёт ярлык для извлечённого из архива файла.

Тип — это односимвольное поле, которое может принимать следующие значения:

D | Создать ярлык на рабочем столе
P | Создать ярлык в меню "Пуск/Программы"
T | Создать ярлык в папке "Автозагрузка"

ИсхФайл — имя извлекаемого из архива файла, для которого нужно создать ярлык. Если это исполняемый файл, то после имени файла можно указать дополнительные параметры, заключив его в кавычки.

РезПапка — результирующая папка, в которой нужно создать ярлык; если указанной папки не существует, то она будет создана SFX-архивом.

Описание — текстовая строка с описанием ярлыка.

ИмяЯрлыка — имя файла .lnk (ярлыка), создаваемого SFX-архивом.

ЗначокЯрлыка — имя файла со значком, ассоциированного с ярлыком. Если этот параметр пропущен, то будет использоваться стандартный значок. Если имя файла со значком не содержит полного пути, SFX-архив будет искать файл значка в папке с извлечёнными файлами.

Все параметры разделяются запятыми. Если внутри какого-либо параметра требуется наличие запятых, весь такой параметр должен быть заключён в кавычки. Если требуется вставить в строку знак кавычек, введите его дважды. Обязательно указывать только Тип и ИсхФайл, остальные параметры факультативные – их можно пропустить или оставить пустыми.

Примеры:

1. Создать ярлык на рабочем столе в папке WinRAR для извлекаемого из архива файла winrar.exe с описанием "Исполняемый файл WinRAR", названием ярлыка "Архиватор WinRAR" и значком winrar.ico:

Shortcut=D,winrar.exe,WinRAR,"Исполняемый файл","Архиватор WinRAR",winrar.ico

2. Предоставить дополнительные параметры для rar.exe, исключить параметры РезПапка и ЗначокЯрлыка:

Shortcut=D, "rar.exe" a -ag c:\mydata\backup\daily c:\mydata\files, , Daily backup, Backup


SFX-команды: Silent

Silent[=Параметр]

Приступить к извлечению без вывода начального окна. Файлы будут извлечены либо в папку, указанную в команде Path, либо в текущую папку, если путь по умолчанию не задан.

В качестве Параметра можно указывать 1 или 2.

Если Параметр равен 1, начальное окно скрывается полностью, включая индикатор выполнения и имена файлов. Также в этом режиме SFX не выводит окно с лицензионным соглашением.

Если Параметр не указан или равен 2, то пропускается подтверждение начала извлечения, однако процесс распаковки архива пользователю виден.

Пример:

Silent=2


SFX-команды: TempMode

TempMode=[Запрос][,Заголовок]

Если в сценарии указана эта команда, SFX создаёт временную папку, извлекает в неё все файлы, запускает программу, определённую в команде Setup, а после завершения работы этой программы удаляет временную папку со всем её содержимым. При выполнении этих операций SFX-модуль автоматически устанавливает "тихий" режим в значение 2, не выводя начальное окно, но при желании этот режим можно переопределить, указав команду Silent с другим параметром. В качестве временной папки для распаковываемых файлов используется текущая папка программы установки.

Команда TempMode может иметь необязательный строковый параметр, определяющий строку запроса и заголовок окна с запросом, отображаемого перед началом извлечения. В этом случае извлечение начнётся, только если пользователь нажмёт кнопку "Да".

Если присутствует команда TempMode, то в сценарии также должна содержаться команда Setup. Команда Path в этом режиме игнорируется.

В TempMode модулю SFX требуется определять прекращение работы программы установки, чтобы удалить временные файлы. Такой метод работает правильно, если программа установки не завершает свою работу до окончания установки. Однако иногда программа установки порождает дочерний процесс, а сама прекращает работу, предполагая, что установку завершит дочерний процесс. В таком случае SFX удаляет временные файлы сразу же после того, как обнаружит, что основная программа установки завершила работу, что приводит к сбою в работе дочернего процесса. Поэтому TempMode корректно функционирует только с теми программами установки, которые не порождают дочерних процессов или, по крайней мере, не завершают свою работу до тех пор, пока не закончат работать все дочерние процессы.

Примеры:

а) TempMode

б) TempMode=Продолжить установку Calculator 3.05?,Установка калькулятора


SFX-команды: Text

Для этой команды поддерживаются два вида синтаксиса:

а)

Text=<строка>

б)

Text

{

строка1

строка2

…

}

Команда Text добавляет указанные обычные текстовые или HTML-строки в окно вывода текста SFX-модуля. Первая команда Text очищает окно от стандартного текста перед добавлением <строки>. Следующие команды добавляют <строку> к уже существующему тексту.

В зависимости от используемого синтаксиса эта команда может добавлять одну либо несколько строк за раз.

Если используется обычный текст, SFX-модуль объединяет и переформатирует текстовые строки так, чтобы они оптимально заполняли окно. Поэтому если вы хотите начать новый абзац, вставьте перед ним пустую строку.

C помощью языка HTML вы можете управлять цветами, шрифтами и форматированием выводимого текста. Описание синтаксиса HTML доступно на сайте WWW-консорциума. Кроме того, для подготовки HTML-текста подойдёт любой редактор web-страниц.

Если текст состоит из нескольких строк, SFX-модуль трактует символ '}' как признак конца текста, поэтому этот символ не следует указывать в тексте в самой первой позиции строки. Если же символ '}' всё-таки нужно использовать в начале строки, вставьте перед ним знак пробела.

Примеры:

а) Добавить в окно одну строку:

Text=Это моя новая программа

б) Добавить в окно указанный текст:

Text

{

Наиболее интересные возможности программы:

- поддержка буфера обмена Windows;

- работа с файлами размером до 10 КБ каждый;

}


SFX-команды: Title

Title=<заголовок>

Эта команда устанавливает заголовок окна SFX-архива.

Пример:

Title=Калькулятор, версия 3.05


SFX-команды: Update

Update=<c>

Параметр <c> может быть либо U, либо F.

Если указан модификатор U, то SFX-модуль извлечёт файлы, копий которых ещё нет на диске, а также файлы с датами более новыми, чем у соответствующих файлов на диске.

Если указан модификатор F, то SFX-модуль извлечёт только те файлы, копии которых на диске имеют более старые даты. Если в папке назначения нет файла с таким же именем, как у файла в архиве, то такой файл в режиме F извлечён не будет.

Пример:

Update=U


Ключ -ME[параметры] - задать параметры шифрования

Ключ -ME[параметры] — задать параметры шифрования

На данный момент поддерживается только один параметр: "ZL" (традиционное старое шифрование ZIP). Укажите ключ -mezl вместе с -p[пароль], чтобы создать зашифрованный ZIP-архив с использованием устаревшего алгоритма шифрования ZIP. Без ключа -mezl архивы ZIP шифруются с помощью алгоритма AES-256 – значительно более надёжного, но несовместимого со старыми программами распаковки ZIP-архивов.

Пример

Создать зашифрованный архив, используя устаревшее ZIP-шифрование:

WinRAR a -s -pmypassword -mezl docs.zip *.txt


Выбор кнопок панели инструментов

В этом окне можно указать, какие кнопки должны присутствовать на панели инструментов при просмотре папок на диске (группа "Кнопки вне архивов") и при просмотре содержимого архивов (группа "Кнопки внутри архивов").

При желании вы можете изменить порядок расположения кнопок. Для этого просто выделите кнопки, которые хотите переместить, и нажмите кнопку "Выше" или "Ниже", чтобы изменить их местоположение. Если нужно восстановить стандартную конфигурацию панели инструментов, нажмите кнопку "По умолчанию".

Кнопка "Разделитель" служит для вставки разделяющей линии перед выбранной в данный момент кнопкой. Если требуется удалить разделитель, либо снимите с него отметку, либо поместите на него курсор и нажмите кнопку "Разделитель".

Обратите внимание, что кнопки можно перетаскивать мышью прямо на панели инструментов, если удерживать нажатой клавишу <Alt>.